Jump to content

Slack 10.2


longgone

Recommended Posts

Bruno/Slack users.......Just received my copy of Slack 10.2 (4 disks) .. now I have a few questions regarding this adventure ... I have read through the currently posted tips and my questions in particular deal with the GUI, printing, run level, are the same steps still required or have things changed ... I would appreciate the input and hopefully I can do a smooth error free install...

Link to comment
Share on other sites

  • Replies 146
  • Created
  • Last Reply

Top Posters In This Topic

  • longgone

    74

  • Bruno

    61

  • burninbush

    4

  • havnblast

    3

I installed it and really appears to be the same as 10.1. I don't print with it tho so I couldn't tell ya about that. It just mainly serves is all.GUI no longer has gnomeThere has been some updates to 10.2 so when you install make sure you get swaret up and running and do the updates.

Link to comment
Share on other sites

:hmm: :thumbsup: :clap: ........Welllll ... in Slack 10.2 ... all went well EXCEPT ... did not make a boot/rescue floppy .. tried but it got kicked out "ran out of space" ,, brand new unformatted disk ... so I would guess that I need that cmd from Bruno to format a floppy to cover the 1.68mb floppy disk image .... put the LILO in the MBR .. not sure if that was correct or not ... guess it can be fixed later .... AND my Logitec trakball does not work ... none of it .... ... and so far other than that and having to change the LILO on MD2005LE to reflect this new install it appears good .... BTW I also have another new distro to try .... BUT not on this machine ..... :) :o
Link to comment
Share on other sites

Bruno,,,,,,,,,,,,Thanks .. floppy formatted/boot made .... now other than my trackballl not working and needing to opdate LILO on MD2005LE ... I d/l swaret, installed it and did updates ... BUT ... some of the updates appeared to be older versions of already installed pkgs and all the d/ls were listed as Slackware 10.0 ... of that I am very suspect that somewhere something is very wrong ..... ?????

Link to comment
Share on other sites

I will have to do research for the trackball . . .But as far as Swaret: I suspect that the "/etc/swaret.conf" file was still set to 10.1 ( or even 10.0 ) . . . you had to change that to 10.2 to make sure you get the correct packages.We can do the Mandriva lilo if you tell me what partition Slackware is installed.;) Bruno

Link to comment
Share on other sites

Bruno....I did a swaret.conf and installed the latest .. stable .. edition according to the swaret website 1.6.3-noarch-2.tgz .....also ... am in MD2005LE now and I did this in lilo here .... changed the kernel to the one in 10.2 .. left everything else as it was ... the vga setting was at 791 and the one listed in the new 10.2 install shows 773 but I left that alone ...10.2 is on hda8.........

Link to comment
Share on other sites

Judging by the time it takes I guess it did not work . . . So please let me see: ( in Mandrake )

# ls /boot# mkdir /mnt/hda8# mount /dev/hda8 /mnt/hda8

;) Bruno

Link to comment
Share on other sites

Password:[root@localhost dale]# ls /bootboot.0300 initrd-2.6.11-6mdk.img message@ suse/ vmlinuz-2.6.11-6mdkconfig@ initrd.img@ message-graphic System.map@ xandros/config-2.6.11-6mdk kernel.h@ message-text System.map-2.6.11-6mdkdrake10/ kernel.h-2.6.11-6mdk pclos/ us.kltgrub/ map slack/ vmlinuz@[root@localhost dale]# mkdir /mnt/hda8mkdir: cannot create directory `/mnt/hda8': File exists[root@localhost dale]# mount /dev/hda8 /mnt/hda8[root@localhost dale]#Wellllllllllllll........... it did boot into Slack quite well ... still no X but startx works fine ... the problem is that I could not get ppp to work .. it dials, connects then busts the connection, quits with status 4 , did the cmds it recommended and the results are that kppp is not installed (???) and it keeps refering back to the old kernel 2.4.26 ....

Link to comment
Share on other sites

;) :D [root@localhost dale]# cat /etc/lilo.conf# File generated by DrakX/drakboot# WARNING: do not forget to run lilo after modifying this filedefault="Mandriva"boot=/dev/hdamap=/boot/mapkeytable=/boot/us.kltpromptnowarntimeout=100message=/boot/messagemenu-scheme=wb:bw:wb:bwimage=/boot/vmlinuz label="Mandriva" root=/dev/hda1 initrd=/boot/initrd.img append="acpi=ht splash=silent" vga=788 read-onlyimage=/boot/suse/vmlinuz-2.6.5-7.201-default label="SUSE" root=/dev/hda10 initrd=/boot/suse/initrd-2.6.5-7.201-default append="splash=silent desktop resume=/dev/hda5 showopts" vga=0x317 read-onlyimage=/boot/slack/vmlinuz-ide-2.4.31 label="Slackware" root=/dev/hda8 append="hdc=ide-scsi" vga=791 read-onlyimage=/boot/drake10/vmlinuz-2.6.3-7mdk label="Mandrake10" root=/dev/hdb1 initrd=/boot/drake10/initrd-2.6.3-7mdk.img append="devfs=mount acpi=ht splash=silent" vga=788 read-onlyimage=/boot/xandros/vmlinuz-2.6.9-x1 label="Xandros_Desktop" root=/dev/hdb7 initrd=/boot/xandros/initrd-2.6.9-x1.gz append="quiet rw acpi=on" vga=0xf04image=/boot/pclos/vmlinuz-2.6.12-oci5.mdk-i586-up-1GB label="Pclos" root=/dev/hdb8 initrd=/boot/pclos/initrd-2.6.12-oci5.mdk-i586-up-1GB.img append="nomce acpi=ht splash=silent psmouse.proto=imps" vga=788 read-onlyimage=/boot/vmlinuz label="failsafe" root=/dev/hda1 initrd=/boot/initrd.img append="failsafe acpi=ht devfs=nomount" read-onlyother=/dev/hda3 label="WindowsXP" table=/dev/hda[root@localhost dale]# ls /boot/slackboot.0308 config@ diag1.img README.initrd@ System.map-ide-2.4.26 vmlinuz-ide-2.4.26boot_message.txt config-ide-2.4.26 map System.map@ vmlinuz[root@localhost dale]# Wellll... I see the problem .... now how do I correct it ??????????
Link to comment
Share on other sites

Wellll... I see the problem .... now how do I correct it ??????????
Simple: ( you forgot to copy over the right kernel and now are booting the wrong kernel ;) that is probably why kppp refuses to work )
# rm -rf /boot/slack# cp -r  /mnt/hda8/boot  /boot/slack# /sbin/lilo

:D Bruno

Link to comment
Share on other sites

Hi DaleFound something for the trackball issue . . . this should be the section in /etc/X11/xorg.conf:

Section "InputDevice" Identifier "Mouse1" Driver "mouse" Option "Protocol" "MouseManPlusPS/2" Option "Device" "/dev/psaux" Option "Buttons" "5" Option "Emulate3Buttons" Option "Emulate3Timeout" "50"EndSection
Source: http://www.linuxquestions.org/questions/sh...282#post1265282 via GoogleB) Bruno
Link to comment
Share on other sites

:thumbsup: :teehee: :hmm: .................Wellllllllllll.................. got a problem with getting X gui to work and the problem is that I can't get to it to make the change .... got some/any suggestions ???????????
Link to comment
Share on other sites

Hi DalePlease make backups of the files you are editing before you make any changes . . . . because a typo is quickly made and can lead to serious problems:

# cp /etc/X11/org.conf /etc/X11/org.conf-BACKUP# cp /etc/inittab /etc/inittab-BACKUP

After changing the xorg.conf file ( for the mouse ) or the /etc/inittab file ( for the startx ) you will have to reboot . . . . . ;):thumbsup: Bruno

Link to comment
Share on other sites

root@localhost:/home/dale# cp /etc/X11/org.conf /etc/X11/org.conf-BACKUPcp: cannot stat `/etc/X11/org.conf': No such file or directoryroot@localhost:/home/dale# cp /etc/inittab /etc/inittab-BACKUProot@localhost:/home/dale# :teehee: :hmm: :hmm: ........ Houston ...... :thumbsup: ..... errr Bruno ... this appears to indicate a problem .....

Link to comment
Share on other sites

Bruno.......... trying to cornfuse us old folk .... uh huh ...Password:root@localhost:/home/dale# cp /etc/X11/xorg.conf /etc/X11/xorg.conf-BACKUProot@localhost:/home/dale#Julia,,, Julia,,, Julia .... does my post have or not have "root" at the beginning of the line ..... I have no choice but to recommend an appointment with an opthamoligist .... :thumbsup: :hmm: :hysterical:

Link to comment
Share on other sites

Good . . now you have backups . . so now you can edit the files.

$ su# mcedit /etc/inittab

You will get the file loaded in an editor . . .at the bottom you see "1=Help" "2=Save" etc etc . . . those are for the function keys . . . so you save the file ( after the edit ) with F2 . . and close the editor with F10 !!When finished with the inittab file you reboot and see if it works . . . . if all is okay you edit the /etc/X11/xorg.conf file ( # mcedit /etc/X11/xorg.conf ) with the trackball tweak.:thumbsup: Bruno

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...