Jump to content

Debian Install


rolanaj

Recommended Posts

  • Replies 223
  • Created
  • Last Reply

Top Posters In This Topic

  • rolanaj

    107

  • Bruno

    82

  • teacher

    6

  • linuxdude32

    6

About the nvidia drivers I see I have choices I am guessing that I want the linux IA32 version? I am assuming the IA 64 is 64 bit or something

Link to comment
Share on other sites

Sorry . . . my commands were incomplete B)# apt-get install cupsys# apt-get install cupsys-clientAnd yep the IA32 version of the drivers is the one you want :)And yep maybe better remove the other source ( + link !! ) before installing a new one ;)Have to go now :D . . . see you tomorrow.B) Bruno

Link to comment
Share on other sites

Sorry . . . my commands were incomplete # apt-get install cupsys# apt-get install cupsys-client
Actually I am the one who is sorry I definitely should realize by now that I need to put install in there. I will try not to be so lazy next time. Thanks for your patience
Link to comment
Share on other sites

New problem, when I try to boot debian sarge 2.6 it stalls with an error about shpchp can't be loaded. Right before that error there was another one modprobe: FATAL ERROR inserting pcichp - pcichp can't be loaded missing kernel or user mode driver pcichp.Debian 2.4 is what I am posting from.

Link to comment
Share on other sites

Hi RolanaTry this: in your " /etc/modules/blacklist" add "pcichp" at the bottom of the file and try to boot 2.6 again ;):'( Bruno

Link to comment
Share on other sites

there apparently is no such file when I do vi /etc/modules/blacklist I am unable to save I have tried to do this as root as well as user with no luck either way. Am I doing something wrong here?

Link to comment
Share on other sites

Have you tried going over to your /etc/modules folder and running ls to see what is there? That will give us a big clue. :)

Link to comment
Share on other sites

Sorry Rolana . . . I made a mistake . . .it should have been "/etc/hotplug/blacklist" . . . . . .:) . . . . ( guess I was nit fully awake when I posted that reply ;) )B) Bruno

Link to comment
Share on other sites

Well I am back in Debian 2.6 I still have to install the nvidia drivers but wanted to be wide awake for that. I have a week off so hopefully I will get it done. I am still having a problem, when in debian 2.4 the kickpanel seems to freeze up when I do more than one thing at a time. I had trouble getting kopete to log in and forget trying to download anything. I was able to apt-get install mozilla-firefox and it worked a lot faster than through the MCC in Mandriva. What seems really funny things seem to work alot better in Debian 2.6. Oh and I installed Thunderbird for my email and it works just fine. One other problem is my mouse cursor seems to disappear when I am not using it and it can be a bit of a pain trying to find it. I have actually been having a problem with is Mandriva and Windows as well. It is an optical mouse so the track ball doesnt need to be cleaned. >_<

Link to comment
Share on other sites

I think those mouse problems will be hardware related, since you have the same problems in Windows too . . . ;)>_< Bruno

Link to comment
Share on other sites

I tried to install the nvidia drivers by using ctrl alt F2 and signing in as root I did telinit 1 got asked for the root password again and had no keyboard access to type it in. So should I maybe try to change it in the /etc/inittab file to id:1:initdefault: or will this give me the same problem with no keyboard access. I ended up having to use the skinny elephant thing to reboot, which tells me some keys must work. I have the 2.6 kernel installed so I might be able to follow the instructions from the debian install walk through and set it up that way. Any suggestions welcome at this point also is there anyother keyboard combo in Debian that will just reboot the system?

Link to comment
Share on other sites

Hi RolanaIf you do

ctrl alt F2 and signing in as root
You are good to install the nvidia drivers . . . there is no need to switch to run level 1 ;)Just "sh NVIDIA-Linux-x86-1.0-7667-pkg1.run " and after that change the XF86Config-4 . . . . and when finished reboot back into the GUI :DBut aside from that, it is a bit strange that you have no key-board in run-level 1 !:shifty: Bruno
Link to comment
Share on other sites

When I signed in as root and tried to do it I got an error saying that X was running so I thought I had to switch to run level 1. So maybe I just need to shut down X first. I'm pretty sure I saw a tip about that in our explorer tips sticky so off to investigate.

Link to comment
Share on other sites

linuxdude32

Very strange. You're not using a wireless keyboard and mouse by any chance are you? If so make sure the receiver is a couple of feet away from any other electrical devices (including the monitor or case).

Link to comment
Share on other sites

No not a wireless, but I was looking at something awhile ago somewhere else that mentions that I may need to change a setting to focus follows mouse. I think the problems in Windows with the mouse might be that I may not have installed the driver that came with the mouse.

Link to comment
Share on other sites

When I signed in as root and tried to do it I got an error saying that X was running so I thought I had to  switch to run level 1.  So maybe I just need to shut down X first.  I'm pretty sure I saw a tip about that in our explorer tips sticky so off to investigate.

Gee . . . now I do not remember how exactly I did it myself . . . . . only know that I did get the nvidia drivers installed okay . . . maybe try " telinit 3" ( level 3 should do :shifty: )B) Bruno
Link to comment
Share on other sites

Gee . . . now I do not remember how exactly I did it myself . . . . . only know that I did get the nvidia drivers installed okay . . .  maybe try " telinit 3" ( level 3 should do :shifty: )B) Bruno

telinit 1--to turn X offtelinit 2--turn X back on
Link to comment
Share on other sites

well that is what I did last time and wasn't able to type anything to log in, Maybe I should try doing it with apt-get. Trigggl did you have to install the nvidia drivers in your debian and how did you do it?

Edited by rolanaj
Link to comment
Share on other sites

Rolana . . . I found it :DAt the KDM login screen you have 3 buttons: "Login", "Clear" and "Menu" . . . choose "Menu" and you will see "Console Login" ( Alt+N ) :DB) Bruno

Link to comment
Share on other sites

rolana@debian:~$ glxgears3891 frames in 5.0 seconds = 778.200 FPS4771 frames in 5.0 seconds = 954.200 FPS4778 frames in 5.0 seconds = 955.600 FPS4773 frames in 5.0 seconds = 954.600 FPS4781 frames in 5.0 seconds = 956.200 FPS4778 frames in 5.0 seconds = 955.600 FPS4706 frames in 5.0 seconds = 941.200 FPS4682 frames in 5.0 seconds = 936.400 FPSX connection to :0.0 broken (explicit kill or server shutdown).rolana@debian:~$
I actually got it to work with telinit 1, I thought it wasn't going to let me type and all of a sudden it started working. I got confused following the written instructions and instead of doing telinit 5 I typed startx which gave me unkown command or something. So I changed Load "glx" to Load "/usr/X11R6/lib/modules/extensions/libglx.so" this time when I typed startx I remembered Greg had said it was telinit 5 to startx so this time it worked. (Thanks Greg) Should I leave well enough alone or change it back to Load 'glx" I'm thinking leave well enough alone :)However seeing the results I am getting with glx gears I am convinced that Mandriva doesn't have nvidia set up right it only get around 200.000FPS to 300.000FPS. I noticed when I installed it in Debian the tutorial mentions that the installer will remove any old drivers for nvidia so might I be able to just do another install of the nvidia drivers in Mandriva following the tips?Another question I am still having a slow down or something with Debian I ran glxgears, closed it leaving Konsole open to copy the results, logged onto the internet opened a browser and tried to open kmenu.... the button depressed like it had been selected but the menu didn't open. I was browsing the forum for a minute and then the menu opened. I would really rather not reinstall there has to be a way to figure out the problem and fix it. I am pretty sure I installed gkrellm so maybe that will be useful. Any ideas on what else I could do?I like the option of logging in with a console thanks Bruno never noticed that one. Should be in Mandriva as well shouldn't it?
Link to comment
Share on other sites

However seeing the results I am getting with glx gears I am convinced that Mandriva doesn't have nvidia set up right it only get around 200.000FPS to 300.000FPS. I noticed when I installed it in Debian the tutorial mentions that the installer will remove any old drivers for nvidia so might I be able to just do another install of the nvidia drivers in Mandriva following the tips?
I wonder why you did install the Nvidia drivers in Mandriva yourself . . . . with the CDs you have it should have been automatically setup during the install of the distro. ( meaning: the nvidia drivers are included on your CDs )
I ran glxgears, closed it leaving Konsole open to copy the results
Could it be this: If you start glxgears in the console you have to stop/close it in the console as well ( with Ctrl+C ) and not stop it by closing the glxgears-window (??):) Bruno
Link to comment
Share on other sites

well that is what I did last time and wasn't able to type anything to log in,  Maybe I should try doing it with apt-get.  Trigggl did you have to install the nvidia drivers in your debian and how did you do it?

Well, once I was told how to turn off X, it went smooth for me. I switched to tty2 to login as root. That's where I gave the telinit command. Once X was done shutting down then I just ran the installer as specified above by Bruno. I made sure I had the kernel headers beforehand and I don't remember having any problems. I'm sorry your install is having a problem with it. ;) I can't imagine why the keyboard would quit working.
Link to comment
Share on other sites

Bruno I didn't install the nvidia drivers myself in Mandriva, it tells me when it is booting that there is an error though, so I know they are there. That is probably it with the glxgears though, I did close it by closing the window isntead of ctrl + c.

Link to comment
Share on other sites

linuxdude32

This may sound odd but have you ever tried memtest86? Funky RAM can cause all sorts of weird issues, stalls, crashes, so on. The issues you're getting with the keyboard going in and out are just plain weird.http://memtest86.com/

Edited by linuxdude32
Link to comment
Share on other sites

it tells me when it is booting that there is an error though, so I know they are there. 

Hi Rolana . . . is this a "dkms" error ?? . . . Because I know the cure if it is ;);) Bruno
Link to comment
Share on other sites

is this a "dkms" error ?? . . . Because I know the cure if it is wink.gif
yes it is
This may sound odd but have you ever tried memtest86? Funky RAM can cause all sorts of weird issues, stalls, crashes, so on. The issues you're getting with the keyboard going in and out are just plain weird.
Good idea, doesnt the UBCD have memtest on it because I have a copy of that might save me the trouble of a download. Thanks for the suggestions I will definitely check it out.
Link to comment
Share on other sites

Hi RolanaHere is the tweak:

# rm /etc/rc.d/rc5.d/S04dkms # ln -s /etc/init.d/kdms /etc/rc.d/rc5.d/S61dkms

( Typo in second line . . see next post ! )Reboot and see if you still get the error ;):) Bruno

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...