Jump to content
Sign in to follow this  
rolanaj

Debian Install

Recommended Posts

My partitions are set up like thishda1-->ntfs--.19gb-->windowshda5-->ext3-->3.8gb--> /hda6--swap-->509mbhda7-->ext3-->15gb-->madrake10.2hda8-->ext3-->19gb-->Debianempty 43gbhda2-->ext3-->9.2gb-->windows restore??So If I install debian to hda8 will it steal my / partition for mandrake?Does it matter that hda2 is at the end of the drive?Could I install Mandriva over top of Mandrake or would it be better to just do a clean install?

Edited by rolanaj

Share this post


Link to post
Share on other sites

rolanajDebian should go to the Hd you assign it to go and not steal your Drake /Personally I would do a clean install on the Mandriva(but I think you can do an upgrade...and the order shouldn't be an issue either.

Share this post


Link to post
Share on other sites

Hi RolanaOnce you start the Debian installer the hda5 will not be called / anymore . . . it will just be a partition like any other . . . . . .So, during the install tell Deb that hda8 will be the / for Debian and it will not touch hda5 ;)B) Bruno

Share this post


Link to post
Share on other sites

I don't want to use the lilo for Mandrake as the bootloader, nor do I want to use grub. So can I force Debian to use lilo and then add Mandrake to its lilo? Or would I be better off to create a separate partition for Mandriva and then use its lilo for the bootloader?

Share this post


Link to post
Share on other sites
I don't want to use the lilo for Mandrake as the bootloader, nor do I want to use grub.  So can I force Debian to use lilo and then add Mandrake to its lilo?  Or would I be better off to create a separate partition for Mandriva and then use its lilo for the bootloader?

I don't think Debian will let you install without putting a bootloader somewhere but you can avoid it putting it in the MBR. Choose to install it to the root of the partition instead. However, you might want to try Debian's GRUB. I noticed on the install I was doing that it detected Windows XP and SUSE and offered to create boot entries for them and then I could still choose to install it in the partition it was on.

Share this post


Link to post
Share on other sites

Hi RolanaDebian defaults to Grub, so I would install it in the root partition and not in the MBR ( or on floppy is even better because you can do part 2 of the install and some tweaks booting from the floppy ) . . . we can then simply add Debian to the Mandriva Lilo ;)As example, here is the part I have in my lilo that boots Debian on hdb10:

image=/boot/debian/vmlinuz-2.4.27-2-386        label="Debian-Sarge-24"        root=/dev/hdb10        initrd=/boot/debian/initrd.img-2.4.27-2-386        vga=791        read-onlyimage=/boot/debian/vmlinuz-2.6.8-2-386        label="Debian-Sarge-26"        root=/dev/hdb10        initrd=/boot/debian/initrd.img-2.6.8-2-386        vga=791        read-only
( Sure I added kernel 2.6 after the install :( ) ;) Bruno

Share this post


Link to post
Share on other sites

I personally switched to Gnome and Grub when I installed Debian. I'm tired of KDE's dependencies with Gnome, so I figured I would go a head and use Gnome, since I seem to need it anyway. It's working great for me so far, though I haven't got my camera connecting properly yet.I also let it install Grub where Lilo used to be. It did a good job installing it with options for my windows and Slack systems. It's a learning opportunity. I've already switched my Firefox and Thunderbird settings over from Slackware and Debian is now my main distro. I guess you could call Slackware my backup.I don't like the way that the Debian installer offers it's partitioning options. The third and less obvious choice is probably what most people will want. I like Debian, but it doesn't get the whole hard drive to itself. It's sharing the Windsows drive.

Share this post


Link to post
Share on other sites

Well I guess I will have to install to the root partition as I don't have a floppy drive. :devil: I really don't like gnome as much as kde, I want to have four totally different looking desktops at least and for some reason I don't find gnome as intuitive as kde.

Share this post


Link to post
Share on other sites
I don't want to use the lilo for Mandrake as the bootloader, nor do I want to use grub.  So can I force Debian to use lilo and then add Mandrake to its lilo?  Or would I be better off to create a separate partition for Mandriva and then use its lilo for the bootloader?

Hi all,To force Debian to use Lilo, do the install until it says it will install Grub. Before you accept, I think you choose "GO BACK". (Or something of the sort. My memory is horrible.) Then you see a list with the steps of the installation. I think something like "Install Grub" is highlighted. But, you will also see "Install Lilo". Select that instead, and the installation continues normally and installs Lilo.I've done it 3 times already. :)I hope this helps. Best to all,Luis

Share this post


Link to post
Share on other sites
Hi all,To force Debian to use Lilo, do the install until it says it will install Grub.  Before you accept, I think you choose "GO BACK".  (Or something of the sort.  My memory is horrible.)  Then you see a list with the steps of the installation.  I think something like "Install Grub" is highlighted.  But, you will also see "Install Lilo".  Select that instead, and the installation continues normally and installs Lilo.I've done it 3 times already. :)I hope this helps.  Best to all,Luis

Thank You Luis for the tip. I have been fighting Grub for the past several days while trying to install it to the Debian 3.1 root partition as I use a 3rd party boot manager. after reading your tip I install Lilo and viola I now have a working Debian 3.1 I don't know why grub would not wotk but Lilo solved the problem once I found where to find Lilo during the install.Thanks again.Mel B)

Share this post


Link to post
Share on other sites

Yes thanks for the tip, I will try that. I installed Mandriva but it seems to be a little shaky and I forgot to add the gnome desktop so it might need a reinstall anyway. If Debian picks up the other distros that would just be too cool anyway. This has been a fun day got Mandriva installed and my modem started acting up, switched to the software one in windows and it was acting a little strange too. Finally got the hardware one to work in windows, it kept freezing in Mandriva. I have to add Mandrake to the Mandriva lilo before I can boot into it. Well enough stalling time to put Debian to the test. Wish me luck

Share this post


Link to post
Share on other sites
Thank You Luis for the tip. I have been fighting Grub for the past several days while trying to install it to the Debian 3.1 root partition as I use a 3rd party boot manager. after reading your tip I install Lilo and viola I now have a working Debian 3.1 I don't know why grub would not wotk but Lilo solved the problem once I found where to find Lilo during the install.Thanks again.Mel B)

I'm very glad to help! (I've been helped a lot in the past, so I'm glad to give my little contributions.)And I hope you will enjoy Debian. I tried Mandrake, Fedora (and old Red Hat) and Debian was always my prefered. There's a little learning curve to learn to do things "the Debain way", but it's a popular distribution and Googling you can always find something. And the new installer solved the hardest part of old Debian versions.Best to all,Luis

Share this post


Link to post
Share on other sites

Well I think I have a base Debian installed, no gui environment at all and DHCP network autoconfig failed, whatever that is. I managed to get it to use lilo but there was no chance to select windows on bootup it simply went to Debian. I put the Mandy cd1 in and told it to repair lilo so it repaired the Mandrake 10.1 lilo so that is where I am posting from. Not sure what to do next, maybe I will look at the lilo config tips and see if I can figure out how to add the other two to my lilo.

Share this post


Link to post
Share on other sites

Well I was following the tip for adding distros to the lilo and I got this part done

[root@localhost boot]# cd /boot/mandriva[root@localhost mandriva]# lsinitrd-2.6.11-6mdk.img  vmlinuz-2.6.11-6mdk[root@localhost mandriva]# cd /boot/debian[root@localhost debian]# lsinitrd.img-2.4.27-2-386  vmlinuz-2.4.27-2-386

so I figured that I had to add these parts to the lilo

image=/boot/debian/vmlinuz-2.4.27-2-386	label="debian"	root=/dev/hda8 initrd=/boot/debian/initrd.img-2.4.27-2-386	append=	vga=791	read-onlyimage=/boot/mandriva/vmlinuz-2.6.11-6mdk	label="Mandriva"	root=/dev/hda9 initrd=/boot/mandriva/initrd-2.6.11-6mdk.img	append=	vga=791	read-only

as you can see I am not quite sure what goes in the append line this is what I have at present

root@localhost root]# cat /etc/lilo.conf# File generated by DrakX/drakboot# WARNING: do not forget to run lilo after modifying this filedefault="linux"boot=/dev/hdamap=/boot/mapkeytable=/boot/us.kltpromptnowarntimeout=100message=/boot/messagemenu-scheme=wb:bw:wb:bwimage=/boot/vmlinuz        label="linux"        root=/dev/hda5        initrd=/boot/initrd.img        append="acpi=ht resume=/dev/hda6 splash=silent"        vga=791        read-onlyimage=/boot/vmlinuz        label="linux-nonfb"        root=/dev/hda5        initrd=/boot/initrd.img        append="acpi=ht resume=/dev/hda6"        read-onlyimage=/boot/vmlinuz-2.4.27-0.pre2.1mdk        label="2427-0pre21"        root=/dev/hda5        initrd=/boot/initrd-2.4.27-0.pre2.1mdk.img        append="devfs=nomount acpi=ht resume=/dev/hda6 splash=silent"        vga=791        read-onlyimage=/boot/vmlinuz        label="failsafe"        root=/dev/hda5        initrd=/boot/initrd.img        append="failsafe acpi=ht resume=/dev/hda6"        read-onlyother=/dev/hda1        label="windows"        table=/dev/hda[root@localhost root]#        

I am thinking I should add "acpi=ht resume=/dev/hda6 splash=silent" or do I need the append line at all?

Edited by rolanaj

Share this post


Link to post
Share on other sites

Hi RolanaThe Debian part does indeed need NO appendline so that part does look fine . . . . but the Mandriva part does need the append= . . . the best way to see what it is is to do: ( after hda9 is mounted )

# cat /mnt/hda9/etc/lilo.conf

That will show you the Lilo from Mandriva and you can simply copy the appendline from there.B) BrunoPS: Just curious, is that the lilo.conf of an older version of Mandrake you are showing us . . . what are the "label="linux" and the "label="2427-0pre21" you have in there ??

Share this post


Link to post
Share on other sites
Well I think I have a base Debian installed, no gui environment at all and DHCP network autoconfig failed, whatever that is.  I managed to get it to use lilo but there was no chance to select windows on bootup it simply went to Debian.  I put the Mandy cd1 in and told it to repair lilo so it repaired the Mandrake 10.1 lilo so that is where I am posting from.  Not sure what to do next, maybe I will look at the lilo config tips and see if I can figure out how to add the other two to my lilo.

When I installed lilo on my work computer, shhh..., it would boot straight into Windows. It was actually a good feature to have at work, but I later found out that with the DSmallLinux Lilo, you have to hold down the shift key for the lilo to come up. I don't remember what setting removes that feature, but if that's what's happening, you can either search google or I may have posted about it in the forum. It would probably just be easier to use the Mandrake or Mandriva lilo. It looks a lot better anyway.EDIT: I found the page where I learned of the need for the shift key in the normal configuration. It is here.
When booting, the boot loader will wait four seconds (40 deciseconds) for you to press Shift. If you don't, then the first kernel image mentioned (/zImage-1.5.99, that you probably installed just five minutes ago) will be booted. If you do, the boot loader will ask you which image to boot. In case you forgot the possible choices, press [TAB] (or [?], if you have a US keyboard), and you will be presented with a menu. You now have the choice of booting this brandnew kernel, or an old trusted kernel, or a kernel on another root file system (just in case you did something stupid on your usual rootfs), or booting a different operating system. There can be up to 16 images mentioned in lilo.conf.
Edited by trigggl

Share this post


Link to post
Share on other sites

Well I got debian added to Mandrakes lilo.

[root@localhost mnt]# /sbin/liloAdded Mandrake *Added debianAdded linux-nonfbAdded 2427-0pre21Added failsafeAdded windows[root@localhost mnt]#
There is a problem with Mandriva though [root@localhost mnt]# cat /mnt/hda9/etc/lilo.confcat: /mnt/hda9/etc/lilo.conf: No such file or directory

Share this post


Link to post
Share on other sites
PS: Just curious, is that the lilo.conf of an older version of Mandrake you are showing us . . . what are the "label="linux" and the "label="2427-0pre21" you have in there ??
It is Mandrake 10.1, I'm not sure what "label="2427-0pre21" is for though. I figured I would use the Mandrake lilo until I got Mandriva set up rightI am running into trouble with debian it wouldn't let me select the packages I wanted to install.I tried using arrow keys to go back and forth but was unable to select anything. I think I have a mail server set up though, just sends mail in the system though as there is no network ;) I tried to add the other kernel withapt-get install kernel-image-2.6.8-1-686it was unable to find it That was info from the tutorial so maybe it is the wrong kernel, at any rate it seems like I have a base system with no gui as it wont do anything with startx --unknown command Is there perhaps a different command I should be using?

Share this post


Link to post
Share on other sites
There is a problem with Mandriva though [root@localhost mnt]# cat /mnt/hda9/etc/lilo.confcat: /mnt/hda9/etc/lilo.conf: No such file or directory

Are you sure that /mnt/hda9 was mounted when you gave that command ? Because if hda9 is the / partition of Mandriva it should have it's own /etc/lilo.conf
I am running into trouble with debian it wouldn't let me select the packages I wanted to install.I tried using arrow keys to go back and forth but was unable to select anything.  I think I have a mail server set up though, just sends  mail in the system though as there is no network  ;) I tried to add the other kernel withapt-get install kernel-image-2.6.8-1-686it was unable to find it That was info from the tutorial so maybe it is the wrong kernel, at any rate it seems like I have a base system with no GUI as it wont do anything with startx --unknown command  Is there perhaps a different command I should be using?

I think it is best to not do the individual packages but simply choosing the "desktop" option ( where you can choose Desktop, Workstation, Server etc etc. ) This way you can not forget essential packages that will be needed for the GUI later on.I know it lets you choose a mail-server . . . but I think it just means you have to choose a MTA ( Mail Transport Agent ) . . . . anyway the default it suggests is "exim4" and just going for the default should be okay. ( And you will not have what we would call a "Mail Server" running when you are done :rolleyes: )We can see about the 2.6 kernel later . . . my first priority would be having X . . . and on all my installs I did not even have to type "startx" because after the second stage of the install the GUI was up automagically. ( still if startx does not work you could try "startx /usr/bin/startkde" but I have not much hope it will work if you have no X to start with )Hope I took care of all the questions . . . . . . please ask again if I forgot some detailB) Bruno

Share this post


Link to post
Share on other sites

When you are installing and you get to the screen that asks you what you want to install the one where you can select desktop how are you supposed to actually select anything, I ended up just hitting enter and went from there. I will try what you suggested and get back to you.

Share this post


Link to post
Share on other sites

Well, I selected the "Desktop" and that was it . . . I was never presented with the difficult task of selecting individual packages . . . . ;) Bruno

Share this post


Link to post
Share on other sites

rolanajDebian will load a pretty good set-up desktop from that desktop selection, after your up and with a gui you can add more packages from the repositories..(like up to about 9000 in sarge..) 15000 in sid...

Share this post


Link to post
Share on other sites
Well, I selected the "Desktop" and that was it . . . I was never presented with the difficult task of selecting individual packages . . . .
what I mean is this screen came up and there were no check marks or anything in front of anything and I wasn't able to add one, so I just hit enteranyway here is where I am now maybe this will mean something to someone hereI think I may have messed this up big time. I am installing from cd's so didn't put in a mirror, thought I had put all the cdroms as sources (14 of them) I did
apt-get updatereading package list...doneapt-get upgradereading package list...donebuilding dependency tree...done0 upgraded 0 newly installed, 0 to remove and 0 not upgraded

I did apt get install kdm and it seems to have added a bunch of stuff asked for cd1I did apt get install kde and it asked for cd 3 and added a bunch of stuffso rebooted and tried startx and got this

 Gizmo:/home/rolana# startxhostname:  Host name lookup failureUsing authority file /root/.Xauthorityw :angry: riting authority file /root/.XauthorityXauth: (argv):1: bad display name "Gizmo:0" in "list" commandusing authority file /root/.XauthorityXauth: stdin:1: bad display name "Gizmo;0" in "add" command/usr/X11R6/lib/X11/xinit/xserverrc: line 2: /usr/bin//X11X: no such file of directory/usr/X11R6/lib/X11/xinit/xserverrc: line 2: exec: /usr/bin/X11/X cannot execute: No such file or directorygiving upXinit: No such process (errno3): no server errorXauth: (argv):1: bad display name "Gizmo:0" in "remove" command

I wasn't able to do a screen capture apparantly you need X for that ;) so any typos are probably mine. Does this look like I may need to start over and perhaps let it put debian as localhost name and not change it to Gizmo?

Share this post


Link to post
Share on other sites

1). Geee . . I do not really remember how I selected "desktop" . . . but in most cases you can move the focus with the arrow-keys and select with the spacebar . . . then hit enter.2). The "Gizmo" does not seem to me a success . . . I would leave the default the installer is proposing you . . . and in that case "localhost" is the most obvious.( Note, I did change it to "jupiter.lan" but on my network this system is know as "jupiter" and seeing you are on dialup that might be very different for you ):lol: Bruno

Share this post


Link to post
Share on other sites
what I mean is this screen came up and there were no check marks or anything in front of anything and I wasn't able to add one, so I just hit enteranyway here is where I am now maybe this will mean something to someone hereI think I may have messed this up big time.  I am  installing from cd's so didn't put in a mirror, thought I had put all the cdroms as sources (14 of them) I did
apt-get updatereading package list...doneapt-get upgradereading package list...donebuilding dependency tree...done0 upgraded 0 newly installed, 0 to remove and 0 not upgraded

I did apt get install kdm and it seems to have added a bunch of stuff asked for cd1I did apt get install kde and it asked for cd 3 and added a bunch of stuffso rebooted and tried startx and got this<snip>

A few thoughts... * Did the installation of kdm went well? If so, you should be taken to a "graphic" login after boot, so no need for "startx".* Are you trying to startx as root? (You probably should not...)* To install (after initial installation) a desktop environment do (as root)
tasksel install desktop

* To try to get kdm running, do

update-alternatives --config x-session-manager

and select kdm.Finally, it really seems to me that that are more things that went wrong in your install... I hope this helps...Luis

Edited by finotti

Share this post


Link to post
Share on other sites
1). Geee . . I do not really remember how I selected "desktop" . . . but in most cases you can move the focus with the arrow-keys and select with the spacebar . . . then hit enter.
Well this was the info I was missing so I installed again and used the spacebar to select desktop and things went a whole lot different. I installed kdm and the kernel image and header for 2.6.8-2-386 Debian tried to go to gnome and ran into a problem with XFree86
Xf86OpenSerial cannot open device /dev/input/mice no such device no core pointer
I left a bit of it out. I gather there is a problem with the mouse and possibly the monitor setup I let debian choose and just ok'd whatever it chose.

Share this post


Link to post
Share on other sites

My guess is that the monitor section will be okay but not the mouse section of XF86Config-4 . . . so what you can do is boot another distro, mount the Debian partition and post what you see if you do:

# mount /dev/hda8 /mnt/hda8# cat /mnt/hda8/etc/X11/XF86Config-4

Then we can make changes if needed and your boot should be okay after that.My guess is that you will have to change: ( In the "Configured Mouse" section )

     Option          "Device"                "/dev/input/mice"
to
     Option          "Device"                "/dev/psaux"
In the "And Vi should do the trick working from Mandrake to the Debian partitionB) Bruno

Share this post


Link to post
Share on other sites

root@localhost rolana]# cat /mnt/hda8/etc/X11/XF86Config-4cat: /mnt/hda8/etc/X11/XF86Config-4: No such file or directory[root@localhost rolana]#Well I tried it a different way

[root@localhost X11]# cat /mnt/debian/etc/X11/XF86Config-4# XF86Config-4 (XFree86 X Window System server configuration file)## This file was generated by dexconf, the Debian X Configuration tool, using# values from the debconf database.## Edit this file with caution, and see the XF86Config-4 manual page.# (Type "man XF86Config-4" at the shell prompt.)## This file is automatically updated on xserver-xfree86 package upgrades *only*# if it has not been modified since the last upgrade of the xserver-xfree86# package.## If you have edited this file but would like it to be automatically updated# again, run the following commands as root:##  cp /etc/X11/XF86Config-4 /etc/X11/XF86Config-4.custom#  md5sum /etc/X11/XF86Config-4 >/var/lib/xfree86/XF86Config-4.md5sum#  dpkg-reconfigure xserver-xfree86Section "Files"        FontPath        "unix/:7100"                    # local font server        # if the local font server has problems, we can fall back on these        FontPath        "/usr/lib/X11/fonts/misc"        FontPath        "/usr/lib/X11/fonts/cyrillic"        FontPath        "/usr/lib/X11/fonts/100dpi/:unscaled"        FontPath        "/usr/lib/X11/fonts/75dpi/:unscaled"        FontPath        "/usr/lib/X11/fonts/Type1"        FontPath        "/usr/lib/X11/fonts/CID"        FontPath        "/usr/lib/X11/fonts/Speedo"        FontPath        "/usr/lib/X11/fonts/100dpi"        FontPath        "/usr/lib/X11/fonts/75dpi"EndSectionSection "Module"        Load    "GLcore"        Load    "bitmap"        Load    "dbe"        Load    "ddc"        Load    "dri"        Load    "extmod"        Load    "freetype"        Load    "glx"        Load    "int10"        Load    "record"        Load    "speedo"        Load    "type1"        Load    "vbe"EndSectionSection "InputDevice"        Identifier      "Generic Keyboard"        Driver          "keyboard"        Option          "CoreKeyboard"        Option          "XkbRules"      "xfree86"        Option          "XkbModel"      "pc104"        Option          "XkbLayout"    "us"EndSectionSection "InputDevice"        Identifier      "Configured Mouse"        Driver          "mouse"        Option          "CorePointer"        Option          "Device"                "/dev/input/mice"        Option          "Protocol"              "ImPS/2"        Option          "Emulate3Buttons"      "true"        Option          "ZAxisMapping"          "4 5"EndSectionSection "Device"        Identifier      "Generic Video Card"        Driver          "vesa"EndSectionSection "Monitor"        Identifier      "Generic Monitor"        HorizSync      28-50        VertRefresh    43-75        Option          "DPMS"EndSectionSection "Screen"        Identifier      "Default Screen"        Device          "Generic Video Card"        Monitor        "Generic Monitor"        DefaultDepth    24        SubSection "Display"                Depth          1                Modes          "800x600" "640x480"        EndSubSection        SubSection "Display"                Depth          4                Modes          "800x600" "640x480"        EndSubSection        SubSection "Display"                Depth          8                Modes          "800x600" "640x480"        EndSubSection        SubSection "Display"                Depth          15                Modes          "800x600" "640x480"        EndSubSection        SubSection "Display"                Depth          16                Modes          "800x600" "640x480"        EndSubSection        SubSection "Display"                Depth          24                Modes          "800x600" "640x480"        EndSubSectionEndSectionSection "ServerLayout"        Identifier      "Default Layout"        Screen          "Default Screen"        InputDevice    "Generic Keyboard"        InputDevice    "Configured Mouse"EndSectionSection "DRI"        Mode    0666EndSection[root@localhost X11]#         
Edited by rolanaj

Share this post


Link to post
Share on other sites

Did you mount it first ?

# mount /dev/hda8 /mnt/hda8# cat /mnt/hda8/etc/X11/XF86Config-4

:lol: Bruno

Share this post


Link to post
Share on other sites

LOL . . crosspost !!Okay I found it . . . . look here:

Section "InputDevice"        Identifier      "Configured Mouse"        Driver          "mouse"        Option          "CorePointer"        Option          "Device"                "/dev/input/mice"        Option          "Protocol"              "ImPS/2"        Option          "Emulate3Buttons"      "true"        Option          "ZAxisMapping"          "4 5"EndSection
Change that to
Section "InputDevice"        Identifier      "Configured Mouse"        Driver          "mouse"        Option          "CorePointer"        Option          "Device"                "/dev/psaux"        Option          "Protocol"              "ImPS/2"        Option          "Emulate3Buttons"      "true"        Option          "ZAxisMapping"          "4 5"EndSection
The simplest way is "vi /mnt/debian/etc/X11/XF86Config-4" ( if you can handle the Vi editor :lol: else do "kedit /mnt/debian/etc/X11/XF86Config-4" ):icon8: Bruno

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...