Jump to content
Scot's Newsletter Forums
Sign in to follow this  
V.T. Eric Layton

Slack 11 Is In, Baby!

Recommended Posts

... I'm gonna' need to study [url="http://forums.scotsnewsletter.com/index.php?showtopic=16989"]THIS[/url] thread because I seem to have no network connectivity currently. :w00t: I also need to make some changes here and there. I need to install Dropline Gnome as soon as I get connected. I also need to upgrade my kernel. I'm using 2.4.33.3. I want to get a 2.6 kernel in there. Well, that'll keep me busy for a while, I guess.I still have my Fedora Core 6 to install, but I think I'll save that for tomorrow sometime. :hysterical:

Share this post


Link to post
Share on other sites
Well, I haven't made any progress on getting connected with Slack 11. This is weird. I didn't have any problem with Slack 10.2. Hmm... Oh well, I'll work on it some more later. The other good news is that I decided to go ahead and install FC6. That went relatively well. I just have a couple minor bugaboos to work out of it. I'm in FC6 right now, as a matter of fact.Later...

Share this post


Link to post
Share on other sites
Have you seen this?[url="http://www.slackware.com/config/network.php"]http://www.slackware.com/config/network.php[/url]netconfig should work unless it's not detecting your ethernet port.

Share this post


Link to post
Share on other sites
netconfig is NOT working, unfortunately. It's late, I'm frustrated. I'll play with it a bit tomorrow or the next day. Thanks for that link, though. :hmm:

Share this post


Link to post
Share on other sites
Hi EricIf you have no other computers running DHCP you can set the Slackware to use a static IP addesss ( same tool "netconfig" or manually in /etc/rc.d/rc.inet1.conf )Running "/etc/rc.d/rc.inet1 restart" after changing settings should do the trick.:hmm: Bruno

Share this post


Link to post
Share on other sites
Here is the trick for DHCP use, . . . . in the /etc/rc.d/rc.inet1.conf change these lines like below:[quote]# Config information for eth0:IPADDR[0]=""NETMASK[0]=""USE_DHCP[0]="yes"DHCP_HOSTNAME[0]=""[/quote]And a bit down the file:[quote]# Default gateway IP address:GATEWAY="10.1.1.10"[/quote] ( !!!!!! Adapt the gateway IP to your situation )Save the file and after that give the command: [code]# /etc/rc.d/rc.inet1 restart[/code]Basically this *should* do the trick . . .:hmm: Bruno

Share this post


Link to post
Share on other sites
I'll check this out later, Bruno. Thanks. I also need to figure out how to upgrade the kernel. I installed one from the CD (sata1...). I'm not sure I installed the proper kernel. I'm going to go back in there today sometime and see for sure.

Share this post


Link to post
Share on other sites
Hey Bruno... oddly enough, when I booted to Slack just now, I seem to have connectivity. I dunno what happened, but all's well now. :)Now on to the other problems... my mouse wheel won't scroll, the 60hz screen flicker is killing my eyes, etc.

Share this post


Link to post
Share on other sites
[quote name='V.T. Eric Layton' post='207316' date='Nov 9 2006, 09:00 PM']Hey Bruno... oddly enough, when I booted to Slack just now, I seem to have connectivity. I dunno what happened, but all's well now. B)[/quote] LOL . . . . . . so it was false alarm was it ?[quote name='V.T. Eric Layton' post='207316' date='Nov 9 2006, 09:00 PM']Now on to the other problems... my mouse wheel won't scroll, the 60hz screen flicker is killing my eyes, etc.[/quote]First back up your /etc/X11/xorg.conf file: [code]# cp /etc/X11/xorg.conf /etc/X11/xorg.conf-BACKUP[/code] Next start tweaking the 60hz and the mouse settings according to: [url="http://brunolinux.com/09-Distro_Specific/Slackware_Tips_1.html"]Slackware Tips 1[/url]B) Bruno

Share this post


Link to post
Share on other sites
Yup. I've been attempting to tweak xorg.conf for the last 20 minutes, but I'm finding that I can't do it with root privileges from within the GUI (Kedit). I guess I'm going to have to do it the "Linux way". :thumbsup:

Share this post


Link to post
Share on other sites
OK, I'm back in Ubuntu because my printer is not working in Slack and I wanted to copy the stuff from the Slack Tips page before I attempted to fiddle with the xorg.conf. So off I go now...

Share this post


Link to post
Share on other sites
Hmm... I'm afraid Slack's not going to work with "Vesa Framebuffer" drivers on my system. :( Changing the vertical sync range in xorg.conf does not give me any better display characteristics. It won't let me have anything other than 61 hz refresh rate. So... how does one install nVidia drivers in Slack?By the way, scroll is working on the mouse now. :thumbsup:

Share this post


Link to post
Share on other sites
[quote name='V.T. Eric Layton' post='207335' date='Nov 9 2006, 04:36 PM']Hmm... I'm afraid Slack's not going to work with "Vesa Framebuffer" drivers on my system. :( Changing the vertical sync range in xorg.conf does not give me any better display characteristics. It won't let me have anything other than 61 hz refresh rate. So... how does one install nVidia drivers in Slack?By the way, scroll is working on the mouse now. :thumbsup:[/quote][url="http://www.brunolinux.com/06-Fine_Tuning_Your_System/Nvidia_Drivers.html"]From Brunos tips[/url]

Share this post


Link to post
Share on other sites
Hmm... when I click on that link, Sloppy, it takes me here:[url="http://www.w3.org/Protocols/"]http://www.w3.org/Protocols/[/url] :thumbsup:

Share this post


Link to post
Share on other sites
Hi EricI made an edit to the link SlSlacker posted . . it should work okay now.:thumbsup: Bruno

Share this post


Link to post
Share on other sites
Ah yes! Gooder! :)I'll snoop around there later this evening. I'm headed out the door for a while, which is just as well because the 60hz flicker in Slack was getting my nauseous. :thumbsup: Thanks, well keep you posted... :(

Share this post


Link to post
Share on other sites
[quote name='V.T. Eric Layton' post='207339' date='Nov 9 2006, 04:50 PM']Hmm... when I click on that link, Sloppy, it takes me here:[url="http://www.w3.org/Protocols/"]http://www.w3.org/Protocols/[/url] :offtopic:[/quote]Not sure how that happened, as I don't think I've ever been to that specific page. Sorry, should have checked the link. :hmm:

Share this post


Link to post
Share on other sites
OK, Bruno... I installed the nVidia drivers from your link above. I checked the xorg.conf as you suggest on that tip page. All's well. The nVidia drivers are in and working, but here's something weird... my range for vertical refresh in xorg.conf is 70-85hz, yet when I open the KDE Control Center and check the Display settings, it says my vert rate is 50hz. I don't have any flicker, though. It looks much closer to 70-85hz, not 50hz. What's up with that? Is this just a KDE bugaboo?One more thing, how to kill the nVidia splash screen before X loads? I know how to do it in Ubuntu, but not sure how in Slack.Now I'm off to find out why my printer doesn't work in Slack.Thanks for the help...~Eric[quote name='sloppyslacker' post='207423' date='Nov 10 2006, 12:56 AM']Not sure how that happened, as I don't think I've ever been to that specific page. Sorry, should have checked the link. :hmm:[/quote]No harm done... Bruno fixed it. I've been there, done that (see post above). Thanks! :offtopic:

Share this post


Link to post
Share on other sites
OK, I think I'm really going to need the 2.6 kernel in Slack. I'm installing Dropline Gnome as I type this, and while it will work with the 2.4 kernel, some of its features won't function. So, with that in mind, Bruno... what's the easiest way to upgrade to the 2.6 kernel? Supposedly, the kernel is on my installation disk. It didn't offer me the option for the 2.6 during the initial install, though. :(Help! :w00t: Edited by V.T. Eric Layton

Share this post


Link to post
Share on other sites
Hi EricFor the kernel have a look here: [url="http://distrowatch.com/weekly.php?issue=20040628#1"]http://distrowatch.com/weekly.php?issue=20040628#1[/url]Note: Do not forget to install the kernel-headers and kernel-modules packages as well !!And for the Nvidia splash, have a look in the /etc/X11/xorgconf:[quote]Section "Device" Identifier "NVIDIA" Driver "nvidia" [b] [color="red"] Option "nologo" "1"[/color][/b][/quote]That should do the trick ;):w00t: Bruno

Share this post


Link to post
Share on other sites
Ah... the old "nologo" trick. That's the same as in Ubuntu. I should have known that one.Dropline Gnome is up and running in Slack. Now I feel at home! Woo-hoo! I know where things are and what I'm doing. :w00t: Here's a shot of my Slack desktop:[url="http://img.photobucket.com/albums/v647/vtel57/Screenshots/Slack_Dropline.png"][img]http://smg.photobucket.com/albums/v647/vtel57/Screenshots/th_Slack_Dropline.png[/img][/url]*click for bigger picThe only bad thing I can find to complain about with Dropline is that it stuck me with FF 2.0... :(It's late. I'll fix that splash and read about the kernel upgrade tomorrow. Thanks again, Bruno!G'night... (or good morning, for you!) :w00t:

Share this post


Link to post
Share on other sites
OK, printer up and running in Slack! YAY! :thumbsup: But I have no color. ;) That's OK though, that's a printer problem, not the OS. I hardly ever print in color, anyway.So, here's a really ignorant Slack novice question: How to I install software in Slack. I can't seem to find any equivalent to synaptic or YUM or anything like that in here. I saw Bruno post on some thread around here about Swaret. Hmm... I'll go try to find that thread now.Later...

Share this post


Link to post
Share on other sites
Here it is Eric:[url="http://brunolinux.com/03-Installing_Software/Swaret.html"]Swaret[/url]Remember to set the /etc/swaret.conf to "[b]VERSION=11.0[/b]"Next to Swaret there is the command "installpkg" you can use on packages you find at: [url="http://www.linuxpackages.net/"]http://www.linuxpackages.net/[/url] ( packages ending on .tgz ):thumbsup: Bruno

Share this post


Link to post
Share on other sites
You know, Bruno, I should just make your tips page my home page in FF. ;)Thanks! I'm off to go see what trouble I can get into with Swaret. :thumbsup:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...