Jump to content

The GNOME Way


raymac46
 Share

Recommended Posts

31 minutes ago, raymac46 said:

The updates that are set to never in the software and updates section are for Flatpaks.

 

Then why is there no mention of Flatpaks in the Software & Updates window (Updates tab) where those settings are? How would a user even know if they're for Flatpaks or not?

Link to comment
Share on other sites

https://news.softpedia.com/news/gnome-3-30-desktop-will-finally-bring-automatic-updates-but-only-for-flatpaks-522302.shtml

 

Well this article sheds some light on the situation. Looks as if Flatpak updates are automatically downloaded and installed unless you turn it off. Even if you do, regular updates are downloaded but you have to manually install. As to why this is, I guess you'd have to ask the GNOME-ies who do the development. I sure can't answer why. Maybe that is why I don't get a dpkg lock when I issue separate apt update and apt upgrade commands.

  • Agree 1
Link to comment
Share on other sites

Thank you for looking into this. I have to admit, getting kinda irritated because I have never used Flatpaks and currently have no interest in doing so. I see the flatpak package when I do an apt search, but it certainly isn't installed. So whatever is being automatically downloaded shouldn't have anything to do with Flatpaks. And it shouldn't be being automatically downloaded in the first place, Flatpaks or not, according to the settings! Last I checked, "Never" means never.

 

In a way, it's no big deal, but... And, hey, why isn't this happening with your system?? Well, I'll be investigating further, as time permits. Thank you for that link!

Link to comment
Share on other sites

I guess the only solution to this is not to use GNOME 3 at all. With Linux Mint auto upgrades are an "opt-in" preference which I enable for my SIL's machines. Otherwise they never get updated.

  • Like 1
Link to comment
Share on other sites

On 8/10/2021 at 12:19 PM, raymac46 said:

I guess the only solution to this is not to use GNOME 3 at all.

 

I don't feel like I want to quit using GNOME because of this. But I'd like to understand what's going on.

 

Right now, I'm looking at this in my Buster GNOME installation, where I get a similar "Could not get lock" message. The Software & Updates settings are the same as in Bullseye.

 

The flatpak explanation doesn't make sense to me, as I don't have the flatpak package installed. However, when I run apt search flatpak, I do see these two packages:


 

xdg-dbus-proxy/stable,now 0.1.1-1 amd64 [installed,automatic]
  filtering D-Bus proxy

xdg-desktop-portal/stable,now 1.2.0-1 amd64 [installed,automatic]
  desktop integration portal for Flatpak and Snap

 

I don't know what to think about that.

 

I'm also trying to see what I can see in /var/log/apt/history.log and /var/log/dpkg.log.

 

Oh, well, maybe one day I'll get to the bottom of it. Lol, today is not that day.

Link to comment
Share on other sites

As I see it there are two things at work here:

  1. The Software and Updates switch referes only to Flatpak installation. Obviously if you don't use Flatpaks they won't be updated anyway. So it won't matter what option you choose.
  2. As for other package updates GNOME will download automatically, but you have to install. If you run apt update && apt upgrade you might run into a lock error. Why not just issue an apt update and wait and see what happens. Then apt upgrade. I have been doing this for a while and I haven't had any problems with "Could not get lock."
Link to comment
Share on other sites

Just did an update:

 

ray@ray-debian-T430:~$ sudo -i
[sudo] password for ray: 
root@ray-debian-T430:~# apt update
Get:1 http://security.debian.org bullseye-security InRelease [44.1 kB]
Get:2 http://ftp.debian.org/debian bullseye-backports InRelease [37.0 kB]      
Get:3 http://debian.mirror.rafal.ca/debian bullseye InRelease [154 kB]         
Get:4 http://dl.google.com/linux/chrome/deb stable InRelease [1,811 B]         
Get:5 http://debian.mirror.rafal.ca/debian bullseye-updates InRelease [40.1 kB]
Hit:6 https://repo.skype.com/deb stable InRelease                              
Get:7 http://security.debian.org bullseye-security/main Sources [10.5 kB]
Get:8 http://security.debian.org bullseye-security/main amd64 Packages [19.0 kB]
Get:9 http://security.debian.org bullseye-security/main Translation-en [10.1 kB]
Hit:10 http://dl.google.com/linux/earth/deb stable InRelease                   
Get:11 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,095 B]
Fetched 317 kB in 1s (381 kB/s)      
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@ray-debian-T430:~# apt upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  apache2-bin firefox-esr
2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 56.8 MB of archives.
After this operation, 51.2 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://security.debian.org bullseye-security/main amd64 apache2-bin amd64 2.4.48-3.1+deb11u1 [1,392 kB]
Get:2 http://security.debian.org bullseye-security/main amd64 firefox-esr amd64 78.13.0esr-1~deb11u1 [55.4 MB]
Fetched 56.8 MB in 3s (17.5 MB/s)       
Reading changelogs... Done
(Reading database ... 386261 files and directories currently installed.)
Preparing to unpack .../apache2-bin_2.4.48-3.1+deb11u1_amd64.deb ...
Unpacking apache2-bin (2.4.48-3.1+deb11u1) over (2.4.48-3.1) ...
Preparing to unpack .../firefox-esr_78.13.0esr-1~deb11u1_amd64.deb ...
Leaving 'diversion of /usr/bin/firefox to /usr/bin/firefox.real by firefox-esr'
Unpacking firefox-esr (78.13.0esr-1~deb11u1) over (78.12.0esr-1) ...
Setting up apache2-bin (2.4.48-3.1+deb11u1) ...
Setting up firefox-esr (78.13.0esr-1~deb11u1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1) ...
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for mailcap (3.69) ...
Processing triggers for desktop-file-utils (0.26-1) ...
root@ray-debian-T430:~# 

 

Link to comment
Share on other sites

Thanks, ray. As other users have reported, these kind of lock messages happen with apt update as well as if it's a combined apt update && apt upgrade command. I'm looking at this article, and the comments that follow. So, I don't believe my sudo apt update && sudo apt full-upgrade command is the problem.

 

Also, I believe the period of time between updates is a factor. It's usually a week or more before I log into one of these GNOME installations and update the system. I'll have to wait some days, I think, before I'll see the messages again.

 

The article I linked above discusses (and shows screenshots of) the Software & Updates tool, but makes no mention of flatpak. I don't see where this has anything to do with flatpak, in my case. But even if it IS downloading only something flatpak-related, and I change the settings (which you say are related only to flatpak) to never automatically check for updates, then the tool shouldn't be automatically checking for updates, wouldn't you agree? Something isn't right there.

 

The lock messages I've seen here certainly seem to be related to GNOME's Software & Updates tool, as I don't recall seeing them in my Openbox-only installation, for example. I'll take a closer look at what's going on with my other Debian installations, and with my Kubuntu installation.

 

Anyway, the best "solution" I've seen so far is to simply wait for apt to finish what it's doing. I'm good with that, for now. Thanks again for looking at this!

  • Thanks 1
Link to comment
Share on other sites

securitybreach

Man, it sounds like Gnome3 on Ubuntu and Debian is a cluster****. Just leave it to the package manager and leave those FlatPak and other BS package managers alone. It's like they over-complicate things just for the sake of change.

Link to comment
Share on other sites

Okay, this is what I'm gonna try, for keeping GNOME Software from automatically downloading stuff:

 

donf-editor > /org/gnome/software > toggle off "download-updates"

 

Found in the edit to the original post in this thread:: https://ubuntuforums.org/showthread.php?t=2338421

 

For good measure, also did this:

 

donf-editor > /org/gnome/software > toggle off "allow-updates"

 

Edited by saturnian
  • Like 2
Link to comment
Share on other sites

16 hours ago, raymac46 said:

I'll be interested to see if this works for you.

 

Nope.

 

Wow, after making those changes with dconf-editor, here's what what happened later after I first booted into Buster GNOME:

 

$ sudo apt update     
Reading package lists... Done
E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/lib/apt/lists/

 

And in Bullseye GNOME:

 

$ sudo apt update
Reading package lists... Done
E: Could not get lock /var/lib/apt/lists/lock. It is held by process 815 (packagekitd)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to lock directory /var/lib/apt/lists/

 

Lol. This is kinda ridiculous. Oh, well, I'll keep digging around.

Link to comment
Share on other sites

My wife took the Thinkpad with her to visit her mother, so I cannot check if I get any lock error. I did try an update before she left but since bullseye is the new stable, I didn't see any available upgrades.

Link to comment
Share on other sites

Okay, more info: https://www.reddit.com/r/gnome/comments/gn8rs4/how_to_disable_gnome_software_autostart/

 

I copied /etc/xdg/autostart/gnome-software-service.desktop into  ~/.config/autostart and appended X-GNOME-Autostart-enabled=false to the end of the file.

 

That second step mentioned, "To prevent Gnome Shell from starting Software open Settings->Search and disable Software from there", I don't see where to get to that setting. [Edit: Oh, duh, I see it, I was looking in the wrong place.]

 

But I think that with the other steps done, that might be enough. Not getting any lock message right now in Buster or in Bullseye. I might have to check back on this in a few days, though.

Edited by saturnian
Link to comment
Share on other sites

I think I am getting auto download of updates but because my wifi speed is around 20MB/sec it happens fast enough that I don't  get any lock errors when I update manually after a boot.

Link to comment
Share on other sites

Ah! When you said earlier that you weren't seeing this issue, I wondered about that, if your download speed might be the reason!

 

I think that the steps I followed from that last thread I linked to may have done the trick for me. I still want to wait and see what happens when some updates are available, though. Also I'd like to know what exactly triggers GNOME Software to check for updates. I think there must be a time-stamp created when the user updates, and then the tool checks again if a certain amount of time has passed since the last update.

 

Even though all this seems so annoying, it's also been a fun learning experience for me. But a user should never have to dig so much to find out how to turn it off. In fact, I think it should be an opt-in thing. But devs know best, right? Right? :)

Link to comment
Share on other sites

It is an opt-in thing with Linux Mint, but that option is handy if you know your "client" isn't all that reliable about updating manually. In fact GNOME is rather conservative with updates, since it simply downloads and waits for you to install. That said, I'd rather have full control.

I wonder if your solution works if you use Wayland as your display server?

Link to comment
Share on other sites

On 8/19/2021 at 7:00 AM, raymac46 said:

I wonder if your solution works if you use Wayland as your display server?

 

I've only been logging into the X11 session, but I'm switching back to Wayland for now, because I know of only one thing that isn't working correctly here under Wayland, and that's Screengrab, my preferred screenshot tool. Maybe I'll notice something else that isn't right. The "fix" mentioned above should work fine under Wayland, shouldn't it? Lol, I'll find out shortly.

Link to comment
Share on other sites

Well this is just plain weird. I got a lock errror yesterday with Linux Mint 20.2 when I tried an update with LM's GUI Update Manager. This is with Xorg, Cinnamon and - I think - all the automation switched off. So this issue goes deeper than the DE.

Linux Mint goes back thru Ubuntu to Debian so there might be some sort of user land parallel. The one thing I know they have in common is systemd so there might be a connection there. Waiting a bit (of course) solves the issue.

Link to comment
Share on other sites

44 minutes ago, securitybreach said:

So many problems with Desktop Environments, keep it simple and use a window manager. Those never break ;) :hysterical:

 

 

+1

 

In my case, I don't want/need GUI package manager, update manager, whatever. I update my systems regularly and don't need a notifier. (I don't like update notifiers, never have.) For example, I purged all that stuff (Discover, etc.) from my Kubuntu installation. I can't do that sort of purge in GNOME; it would break the system. Is it possible to have a Mint (Cinnamon or MATE) installation without the GUI package management stuff? Probably not, I figure.

 

But that's the issue for me. And if I can't get rid of it, at least let me turn it off completely. In Bullseye, I think I've stopped GNOME from automatically checking for updates or downloading anything.

Link to comment
Share on other sites

securitybreach
1 hour ago, saturnian said:

 

 Is it possible to have a Mint (Cinnamon or MATE) installation without the GUI package management stuff? Probably not, I figure.

 

Yes, you can run your updates in the terminal on LM, just run

 

sudo apt-get update && sudo apt-get upgrade

 

or

 

sudo apt update && sudo apt upgrade

 

Link to comment
Share on other sites

1 hour ago, securitybreach said:

 

Yes, you can run your updates in the terminal on LM, just run

 


sudo apt-get update && sudo apt-get upgrade

 

or

 


sudo apt update && sudo apt upgrade

 

 

No, I mean a Mint installation that does not have GUI package management tools included. Or where it can all be easily removed without breaking Mint. Same with GNOME here in Bullseye, I don't need those tools there. But that's the way things are, so this is where it's nicer sometimes for someone like to me to just start with a WM and go from there.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...