Jump to content

xinit


Recommended Posts

Hi everyone. I haven't posted in a long time mostly because I had no problem but now I have one.
My wife has a computer running Win 7, Ubuntu and PCLinuxOS. She is using the last one the most.

Lately she has been getting message saying that her Chrome browser was not up to date so last night I went into Synaptic and updated Chromium. I was very surprised when it downloaded and installed something like 1600 files or more. Today she had to switch to Windows for awhile and when she rebooted into PCLinuxOS she was asked for the local hostname and password which I supplied but then she was into a console. I did 'su' and then 'startx' and then I got the following messages;

 



/etc/host.conf:line 3: bad command ‘no spoof on’

/etchost.conf:line 4: bad command ‘no spoofalert on’

 

EE

fatal server error:

EE server is already active for display 0

If this server is no longer running,remove tmpX0-lock and start again.

 

Invalid MIT-MAGIC-COOKIE -1 keyxinit: giving up

xinit:unable to connect to X server: Resource temporarily unavailable

xinit:server error

/etc/host.conf:line 3: bad command ‘no spoof on’

/etchost.conf:line 4: bad command ‘no spoofalert on’

 

What can I do? Thanks!

Link to post
Share on other sites
securitybreach

 First, I would look at /etc/host.conf as it looks to have some stuff in there that shouldn't be.

/etc/host.conf:line 3: bad command ‘no spoof on’

/etc/host.conf:line 4: bad command ‘no spoofalert on’

 

As far as using startx, it looks like Xorg is already running hence the errors: 

EE server is already active for display 0

xinit:unable to connect to X server: Resource temporarily unavailable

 

Link to post
Share on other sites
securitybreach

Depending on the display manager that you are running, you may want to check the status of it for errors as well.

 

For instance:

systemctl status sddm

systemctl status lightdm

 

Replace it with whatever display manager PCLos uses.

Link to post
Share on other sites
Hedon James

I agree with SBs catch that the display server seems to be already running.  I would be looking at the display manager.  if you get the user console, ie:

 

rejean@machine-name:

that would suggest the user is logged into the system, but no display.  instead of "startx", can you type "sddm" or "gdm" or whatever your display manager is?  If you're lucky, it works; if it doesn't, another clue.

 

As an aside, PCLOS is a rolling release distro.  I only have experience with PCLOS in a VM, but if you don't keep it updated regularly in bite-site increments like Arch, a large and overdue update with 1600 packages is certainly possible.  No doubt we all agree on the likely cause, but that doesn't help ya after the fact.

  • Agree 1
Link to post
Share on other sites

thanks everyone. I still have a few outdoors chores to do but will try everything starting with SB latest suggestion and will get back to you this evening. Thanks again.

 

Link to post
Share on other sites

Hi everyone. 
I wished you all, my American friends, a very happy, albeit quieter but safe Thanksgiving. You are all often in my mind.

 

 

Edited by réjean
  • Like 1
  • Thanks 1
Link to post
Share on other sites

so, after I rebooted and gave my name as the local hostname and my password I get to a prompt that says;

 

[rejean@localhost]:

 

but then I tried all the suggestions and nothing worked. I think that nano doesn't get installed by default in PCLinuxOS. She normally uses Libre Office for word processing which I know needs a gui. Any other basic word processing that might have been installed by default or that could be installed with 'dpkg' or something?

 

Link to post
Share on other sites
securitybreach

Check to see if you are connected to the internet using 

ping 8.8.8.8

 

If you are connected, rub this to install nano by running

 

sudo apt-get install nano

Link to post
Share on other sites
securitybreach

So PCLinux uses the SLIM login manager. To see what is wrong with it, run the following two commands

sudo journalctl -xe

sudo systemctl status slim

 

Link to post
Share on other sites
securitybreach

BTW if you can't fix, you can always install and use another display manager:

sudo systemctl stop slim

sudo apt-get install sddm

sudo systemctl start sddm

 

If that works fine, you can disable slim and enable sddm at boot with the following:

sudo systemctl disable slim

sudo systemctl enable sddm

 

Or you could just stop slim and use startx (if pclinuxos supports it by default)

systemctl stop slim

Link to post
Share on other sites

Well sudo doesn't work but I managed to install nano using su. Now if I try to delete the 2 lines in /etc/host.conf using Ctrl+K, then Ctrl+O to save it and Ctrl+X to quit and I restart the machine then the 2 lines are still in /etc/host.conf.

All the other suggestions from SB don't work. I am downloading PCLinuxOs from my own computer hoping a reinstall will save her. I am pretty sure the install is on 2 partitions, one for / and one for /home. Hopefully I can save her /home without formatting. Any other suggestion?

 

Link to post
Share on other sites
Hedon James

did you try a different login manager/display manager?  and what DE are you using in PCLOS?

 

I really think you have a display manager issue.  Just a gut feeling from similar experience with Ubuntu many years ago.  I'd recommend installing a DM of the same flavor as your DE...gdm for Gnome; kdm for KDE; sddm for LXQT; etc...

 

OTOH, lightdm seems to be DE-agnostic and compatible with all desktops.  Seems to be...

  • Agree 1
Link to post
Share on other sites
Hedon James
7 minutes ago, réjean said:

Hi Hedon! I am pretty sure she have  KDM and I did try installing sddm but it didn't work. I could try again. 

 

i wouldn't recommend sddm.  sddm is the recommended DM for LXQT, and I have it on my system, but apparently it's a little buggy.  LXQT devs have recommended lightdm, FWIW.  I'd install kdm for KDE, or lightdm.

 

can you start the DM from the terminal?

rejean@localhost:  slim

or perhaps

rejean@localhost:  sddm

 

etc...you get the picture.

Link to post
Share on other sites
securitybreach
11 minutes ago, Hedon James said:

 

i wouldn't recommend sddm.  sddm is the recommended DM for LXQT, and I have it on my system, but apparently it's a little buggy.  LXQT devs have recommended lightdm, FWIW.  I'd install kdm for KDE, or lightdm.

 

 

 

Well I have never used a display manager so I was just naming a couple of them to try out ;)

 

Link to post
Share on other sites
42 minutes ago, Hedon James said:

 

i wouldn't recommend sddm.  sddm is the recommended DM for LXQT, and I have it on my system, but apparently it's a little buggy.  LXQT devs have recommended lightdm, FWIW.  I'd install kdm for KDE, or lightdm.

 

can you start the DM from the terminal?


rejean@localhost:  slim

or perhaps


rejean@localhost:  sddm

 

etc...you get the picture.

Nope. I tried them all; gdm,kdm,slim,sddm. no go.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...