Jump to content
ichase

Arch Linux news: Perl updated to 5.20

Recommended Posts

ichase

Not seeing this as being Arch Linux specific as I am sure other distros will be updating Perl as well. Though how they deal with this upgrade very well could be specific to their developers.

 

Florian Pritz wrote:

 

Perl 5.20, as any other new perl version, requires all modules that are not

purely perl code to be rebuilt. We did that for all packages in our repos.

 

The last couple major updates printed an error message when trying to load

modules built against the wrong version, 5.20 seems to cause segfaults. Please

make sure to rebuild all custom installed CPAN modules and binaries that link to

libperl.so.

 

Refer to [my post on arch-dev-public][1] for a script that helps to find those

packages.

 

[1] https://mailman.archlinux.org/pipermail/arch-dev-public/2014-June/026359.html

 

URL: https://www.archlinux.org/news/perl-updated-to-520/

Share this post


Link to post
Share on other sites
securitybreach

Thanks for the head's up Ian. You beat me to the post.... B)

 

Um, I guess I already have that version as it was updated on Sunday. Gotta love Testing.

comhack@Cerberus ~ % pacman -Qi perl | grep Version

Version : 5.20.0-2

Share this post


Link to post
Share on other sites
ichase

I keep saying I am going to uncomment the testing repo and I never seem to remember too ;)

If you don't have any modules that a specifically coded with Perl then it's a moot point. Obviously you have not noticed anything on your machine breaking.

  • Like 1

Share this post


Link to post
Share on other sites
securitybreach

I have some weechat modules that are Perl but yeah, no issues at all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...