Jump to content

[arch-announce] End of initscripts support


Recommended Posts

I told you, resistance is FUTILE!!!!!!

 

Tom Gundersen wrote:

 

As `systemd` is now the default init system, Arch Linux is receiving minimal

testing on `initscripts` systems. Due to a lack of resources and interest, we

are unlikely to work on fixing `initscripts`-specific bugs, and may close them

as WONTFIX.

 

We therefore strongly encourage all users to migrate to `systemd` as soon as

possible. See the [`systemd` migration gudie][1].

 

To ease the transition, `initscripts` support will remain in the official

repositories for the time being, unless otherwise stated. As of January 2013, we

will start removing `initscripts` support (e.g., `rc` scripts) from individual

packages without further notice.

 

[1] https://wiki.archlinux.org/index.php/Systemd

 

URL: https://www.archlinux.org/news/end-of-initscripts-support/

 

Looking at the systemd migration guide, this does not look like a piece of cake. I know Eric will probably say it is because he has already done it, but Eric is a "GURU" It is in print. :hysterical:

 

Don't make me post the article again Eric. :hysterical:

Link to post
Share on other sites
  • Replies 77
  • Created
  • Last Reply

Top Posters In This Topic

  • securitybreach

    26

  • V.T. Eric Layton

    24

  • ichase

    23

  • amenditman

    3

Top Posters In This Topic

Popular Posts

Yes, that's exactly what it's saying. Many of the configuration files that you change in this step are required for going to systemd, anyway. I did it haphazardly when I switched over because, of cour

Don't be afraid, my little ones. Systemd is not the big bugbear that everyone thinks it is. It's good for you. Now, just relax and drink the Kool-aid.

I actually installed that way back when. But to be honest with you, I did not put a lot of effort getting stuff to automount in THunar. Once it did not work, I was fine continuing to mount via the c

securitybreach

Actually it is pretty easy as long as you follow the wiki entry step by step B)

 

I switched over a couple of months ago, not long after Eric did.

Link to post
Share on other sites
V.T. Eric Layton

Don't be afraid, my little ones. Systemd is not the big bugbear that everyone thinks it is. It's good for you. Now, just relax and drink the Kool-aid. Monk_Emote___Meditate_by_Kitrakaya.gif

  • Like 1
Link to post
Share on other sites
amenditman

I told you, resistance is FUTILE!!!!!!

 

Tom Gundersen wrote:

 

 

 

URL: https://www.archlinu...cripts-support/

 

Looking at the systemd migration guide, this does not look like a piece of cake. I know Eric will probably say it is because he has already done it, but Eric is a "GURU" It is in print. :hysterical:

 

Don't make me post the article again Eric. :hysterical:

Switching over is a piece of cake, even I was able to do it without any major issues.

 

And yes, Eric is a Gnuru, I've said it many times.

Link to post
Share on other sites

Well it seems as if the kool aid is being forced fed. :angry:

The Wiki looks complicated with a lot of additional links. Truth be told, short time after Eric converted I attempted it on my laptop. It was a DISASTER!!!! Of course I cloned the partition prior so just put it back but it was bad.....real bad... :hysterical:

Link to post
Share on other sites
securitybreach
The Wiki looks complicated with a lot of additional links.

 

Do not worry about the additional links. Just follow the wiki(only) set-by-step and you will be fine.

Link to post
Share on other sites
V.T. Eric Layton

And yes, Eric is a Gnuru, I've said it many times.

*Emphasis mine ~Eric

 

Ooooh! Is that a new word?

Link to post
Share on other sites
amenditman

*Emphasis mine ~Eric

 

Ooooh! Is that a new word?

Nope, if you search this forum you will see it was used before. You and Josh were the subjects..

 

And yet, maybe yes. I believe I made it up. Never seen it used anywhere else before I first used it.

Edited by amenditman
  • Like 1
Link to post
Share on other sites
V.T. Eric Layton

Indeed it was. I wouldn't mind a pat on the back from Richard Stallman. He tends to lean a bit toward the eclectic or maybe even eccentric side, but the man is a genius all the same. :yes:

Link to post
Share on other sites

Well here I was about to jump in feet first when all of a sudden my inverter on my laptop went kapoot. Now I can move the laptop upstairs and hook up an external monitor but I think this was a sign for me not to jump into this right at the momemt. BUT........With that being said, I do have a question in regards to the systemd Arch Wiki It states:

 

It is highly recommended to switch to the new initscripts configuration system described in the rc.conf article. Once you have this configuration established, you will have done most of the work needed to make the switch to systemd.

 

Now is this saying that I should do this first prior to jumping to section 2.3 pure systemd installation?

 

And yes, Eric is most definitely a Gnuru if you have not done so already I would patent that title for future use. :thumbsup:

Edited by ichase
Link to post
Share on other sites
V.T. Eric Layton

Now is this saying that I should do this first prior to jumping to section 2.3 pure systemd installation?

 

 

Yes, that's exactly what it's saying. Many of the configuration files that you change in this step are required for going to systemd, anyway. I did it haphazardly when I switched over because, of course, it was still a new thing and the Arch community had not yet created how-to documentation for the switchover. You can still refer to mine and Josh's experiences during our systemd adventure here --> http://forums.scotsn...showtopic=56241

 

And my blog article about the experience here --> https://noctslackv1.wordpress.com/2012/07/09/running-pure-systemd-in-arch-linux/

  • Like 2
Link to post
Share on other sites

Josh, you may want to remove the link to that tutorial I posted with screenshots with the new Arch installation. The latest Arch iso is a systemd build and the link is for an intiscripts build which obviously has some different command line tasks. I am working on installing the systemd iso build on an older HP laptop. I will let you know how that goes.

Link to post
Share on other sites
V.T. Eric Layton

I don't think we should remove tutorials. We should just add a note to them stating that they are obsolete. The information in many older tutorials is still often useful to some folks out there.

Link to post
Share on other sites

Well I replaced the inverter so mission control is back up and running. :thumbsup:

Now that that is fixed, I am moving on to set the lappy up to pure systemd.

My question is, did you or did you not get rid of your rc.conf file? In reading the documentation it says you can get rid of it based on the fact that systemd can handle "most" daemons. But what file now do you state what daemons you want to start at bootup? How do you have a daemon start in the background the way you did with rc.conf ( @)

 

And then, what file took over setting up network setting such as static IPs?

 

Just need a nudge in the right direction,

 

Thanks and hope everyone is enjoying their weekend

Link to post
Share on other sites
securitybreach

Well I replaced the inverter so mission control is back up and running. :thumbsup:

Now that that is fixed, I am moving on to set the lappy up to pure systemd.

My question is, did you or did you not get rid of your rc.conf file? In reading the documentation it says you can get rid of it based on the fact that systemd can handle "most" daemons. But what file now do you state what daemons you want to start at bootup? How do you have a daemon start in the background the way you did with rc.conf ( @)

 

And then, what file took over setting up network setting such as static IPs?

 

Just need a nudge in the right direction,

 

Thanks and hope everyone is enjoying their weekend

 

I did not remove my rc.conf file as it contains my networking info. As far as the file to enable services, systemd does not use a file to do this: https://wiki.archlinux.org/index.php/Systemd#Basic_systemctl_usage

 

Also, you do not have to remove the daemons from rc.conf as systemd will take precedence.

Link to post
Share on other sites

Pardon my negativity, but as before this has resulted in disaster as if I expected ANYTHING less.

SystemD is already installed as it was part of upgrades a while back

I installed systemd-sysvcompat (uninstalled sysvinit by direction)

Python2-dbus and python2-cairo were already installed.

 

So at this point I removed initscripts (which prompted me that is was saving my rc.conf to rc.conf.pacsave)

locale.conf, hostname.conf, vconsole.conf were already there and configured correctly

 

Then I rebooted.

 

Welcome to emergency mode! Did you expect your computer to ACTUALLY boot and all would be well?  You IDIOT!!!!

 

Well it did not say all that but did say welcome to emergency mode!

 

It proceeded to tell me

 *ERROR* Failed to load firmware!
failed initializing CP (-2) # <-----What ever the heck that means
ERROR:  Firmware file 'b43/ucode5.fw" not found  # <-----Pretty much saying that my wifi firmware disapeared.

 

So I go ahead and enter Emergency Mode

 

Tried saving my rc.conf.pacsave to rc.conf again, reboot, same thing.

 

I checked out systemctl and everything but the /media/cd seemed to look good.

 

systemctrl unit files showed 196 unit files listed, all in which were either set to "static" or "disabled" except for 2 that were actually enabled getty@.service and remote-fs.target

 

So at this rate, as expected, I have no darn clue what to do next. It's 5 AM and I guess I can go to sleep now because I am really tired of messing with this. Good thing is, I can re-image it and go back to a working Arch system.

 

Again, I apologize for the negativity. I am just really agrivated and cant figure out where the heck I screwed up.

Link to post
Share on other sites
V.T. Eric Layton

Walk away. Come back in a few days.

 

When you do come back, read the thread where I converted and follow the steps I took.

  • Like 1
Link to post
Share on other sites

I started from scratch after re-imaging.

I followed your path pretty much how you initially described it Eric. I say initially because some packages were already installed on my system such as systemd, python2-dbus, cairo etc. I followed the wiki and switched to the new initscripts configuration system described in the rc.conf arcticle.

1) Install systemd from core using pacman:

systemd was already on the system

2) I intend to run pure systemd' date=' so I won't need to append my kernel line with "init=/bin/systemd" to get systemd to load at boot.[/quote']

I use grub2, and I did not change anything in grub.cfg

3) Installed via pacman: python2-dbus' date=' python2-cairo, systemd-arch-units, systemd-sysvcompat (must remove sysvinit).[/quote']

python2-dbus, python2-cairo were already installed. systemd-arch-units does not exist in the official repos nor in AUR. Installed systemd-sysvcompat and like you it promted me to remove sysvinit in which I did.

4) Removed initscripts

I removed initscripts which prompted me that rc.conf was being saved to rc.conf.pacsave

5) Create the following files:

All the files were already created or I created them

Reboot

Same thing, won't properly boot, puts me in "emergency mode" I am able by putting in root password to be at the root prompt. Try systemctl reboot same thing.

 

I followed EXACTLY what you did. This is what I am getting on my screen:

Welcome to emergency mode!  Type "systemctl defualt" or ^D to enter default mode.
Type "journelctl -b" to view system logs.  Type "systemctl reboot" to reboot.
Give root password for maintenance
(or typed Control-D to continue): [    71.520184] radeon_cp:  Failed to load firmware
"radeon/R300_cp.bin"
[	 71.520205] [drm:r100_cp_init] *ERROR* failed to load firmware!
[	 71.520224] radeon 0000:01:05.0: failed initializing CP (-2)
[	 71.520237] radeon 0000:01:05.0: Disabling GPU acceleration

Link to post
Share on other sites
securitybreach
]If you have devices not necessarily connected during startup and that you specify in / etc / fstab , do not forget to add the option nofail not to end up with a start off.

Note: The option nofail is not valid for dependent types fuse ( ntfs-3g , cifs , etc..) and partitions on the network are handled differently, systemd can start without.

systemd has a timeout of 90 seconds by default, it is only after this time notify you of a failure:

[TIME] Timed out waiting for device dev-sdb1.device

[DEPEND] Dependency failed for / media/disque_usb_1

 

and gives you the hand

Welcome to emergency mode. Use "systemctl default" or ^ D to enter default mode.

Give root password for maintenance

(Or type Control-D to continue):

 

Important: The Ctrl-D or systemctl default resume where systemd stopped. If you have made ​​any changes, you will leave for 90s waiting.

To remedy temporarily worry, you can optionally use the emergency shell (the one you once the password root entered):

systemctl mask media-disque_usb_1.mount

# Do not forget to 'unmask once the order set

systemctl default

 

Should continue booting. But for a more permanent solution, change the line on the device in the /etc/fstab by adding nofail :

/ dev/sdb1 / media/disque__usb_1 auto defaults, nofail 0 0

 

Also, I would suggest mv /etc/rc.conf.pacsave back to /etc/rc.conf.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...