Jump to content

Forums

  1. The Highlands

    1. Announcements

      General announcements of note for all forum members.

      1,759
      posts
    2. Bruno's All Things Linux

      The place to free your mind and explore Linux, which for many, isn't an "alternative" operating system — it's their only OS.

      205,383
      posts
    3. All Things Windows

      Topics related to Windows, Microsoft, help with Windows, techniques, performance, betas, all types of Applications, Windows news, Windows server OSes, the future of operating systems, and more.

      42,545
      posts
    4. All Things Mac

      Topics and discussions related to Apple, Macintosh hardware and accessories, OS X, Classic, iTunes / iTMS (Mac & PC), mainstream Mac software, and more.

      3,524
      posts
    5. Hardware

      Exploring CPUs, motherboards, overclocking, building your own PC, case mods, PC brands, handhelds, peripherals of all types, DVDs, CD burners, hardware-specific software, device drivers, and anything else related to hardware.

      19,343
      posts
    6. Mobility

      Topics related to ANY AND ALL Mobile Platforms, Mobile Devices, Mobile Operating Systems, Mobile Apps, and more.

      2,069
      posts
    7. Security & Networking

      Protecting PCs from attack, networking, network hardware, remote access, sharing broadband, different broadband technologies, network troubleshooting, spam, encryption, firewalls, and more.

      23,603
      posts
    8. Social Media

      Social Media will cover all topics related to Social Media, Web 2.0, browsers and web applications, email, and more.

      17,665
      posts
    9. The Restaurant at the Edge of the Universe

      The The Restaurant at the Edge of the Universe, previously known as The Water Cooler, is a place to post stuff that has absolutely nothing at all to do with computers, broadband, Scot's Newsletter, or anything that's "supposed" to be here.

      50,043
      posts
    10. Forum Feedback

      Forum-Related Feedback Only, Please: Bugs, problems, forum software, skins, graphics, webhost, stuff we're testing, suggestions, and more. NOTE: Testing Subforum is under the Forum Feedback forum.
      6,569
      posts
  • Recent Posts

    • securitybreach
      Sweet! Glad that it was just apparmor. This is why I said overkill     https://en.wikipedia.org/wiki/AppArmor
    • Hedon James
      You said apparmor is unnecessary and, in fact, overkill for a home user desktop scenario, correct?  If so, consider this resolved.   I nuked apparmor from the system. sudo apt remove apparmor it also took apparmor-utils with it, and I need to autoremove some orphans, but POOF....gone!   Tried to create a VM, but same errors.  Realized the libvirt.services probably needed to be restarted, so checked status: sudo systemctl status libvirtd.service sure enough, a red error line, so restarted service sudo systemctl restart libvirtd.service Tried to create a VM but same error.  Then realized that qemu/KVM is a kernel-based service, so maybe I needed to reboot the whole system.   Rebooted the system, tried to create a VM with user session and external disk image on /media/jim/sdc1 and TADA...there it is...VM booting in VMM.  THAT is what I've been looking for...exactly as desired!   Not sure what apparmor is, what it does, or why its installed by default on Debian 10, but it's gone now.  And VMM seems to be working (knock on wood) the way I thought it should.  I've probably swatted a fly with a sledgehammer, but I don't care right now.  I just need my VM available so I can use those windows-only programs that I need for my business!   Thanks for your help SB!
    • securitybreach
      Basically the error is the top line, the next lines are trying to trace the error with the last line repeating the error.
    • securitybreach
      Apparmor is the root cause of your issue as noted by the top part of your error:   unable to complete install: 'internal error: cannot load AppArmor profile 'libvirt-0f82c9ef-278d-4f2b-bb2f-3cf142f7d0e0''
    • Hedon James
      my VMs or my *vdi disk images?   my sdc disk image was indeed owned by root, so changed it to jim (username), but same error: Unable to complete install: 'internal error: cannot load AppArmor profile 'libvirt-0f82c9ef-278d-4f2b-bb2f-3cf142f7d0e0'' Traceback (most recent call last): File "/usr/share/virt-manager/virtManager/asyncjob.py", line 75, in cb_wrapper callback(asyncjob, *args, **kwargs) File "/usr/share/virt-manager/virtManager/create.py", line 2119, in _do_async_install guest.installer_instance.start_install(guest, meter=meter) File "/usr/share/virt-manager/virtinst/installer.py", line 419, in start_install doboot, transient) File "/usr/share/virt-manager/virtinst/installer.py", line 362, in _create_guest domain = self.conn.createXML(install_xml or final_xml, 0) File "/usr/lib/python3/dist-packages/libvirt.py", line 3732, in createXML if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self) libvirt.libvirtError: internal error: cannot load AppArmor profile 'libvirt-0f82c9ef-278d-4f2b-bb2f-3cf142f7d0e0'    
  • Who's Online (See full list)

    • Hedon James
    • securitybreach
    • raymac46
    • ichase
  • Today's Birthdays

    1. genaldar
      genaldar
      (40 years old)
  • Member Statistics

    • Total Members
      5,001
    • Most Online
      1,793

    KJ-Kaz
    Newest Member
    KJ-Kaz
    Joined
×
×
  • Create New...