Jump to content



Recommended Posts

This is just a advisory note -- It may be best to test out Foxclone on a non critical pc/os.  Foxclone does seem to be a darn neat tool so do not let me put you off testing it. 😎





Foxclone is a Linux based image backup, restore and clone tool using a simple point and click interface. It takes images of the partitions on your hard drive (HDD) or solid-state drive (SSD) and stores them for later restoration. Image files are compressed to save space.


Original thread by developer at Linux Mint Forums



Foxclone is a simple point and click linux image backup, restore and clone utility.

It will backup & restore:

  • GPT and MBR/legacy/MSDOS partition tables.
  • FAT, NTFS and ext4 partitions.
  • Swap partitions.
  • Extended partitions (MBR only).
  • Unknown partition types*.
  • Encrypted partitions*.

It will clone:

  • Direct disk to disk.
  • To disk from a full backup.
  • From a larger drive to a smaller drive (with limitations).


New updated thread by developer at Linux Mint Forums



This is a complete re-write of foxclone, primarily to improve maintainability of the code so basic functionality is unchanged. I used the opportunity to make some minor cosmetic changes.


  • nearly all windows are now resizable. Note if you resize the progress window there is a 3 second delay before it catches up. Underneath partclone is running on a 3 second update cycle.
  • you can change the text size - for those with poor eyesight, you will need to manually resize the windows to accommodate larger text.
  • default is now to select all partitions on a backup and if you want to deselect partitions you need to go to the settings tab and enable 'partition selection'. This to make it more difficult for newbies to make mistakes.
  • troubleshooting in the event of a problem is easier - enable debugging on the settings tab and it saves a file on the desktop - email it to help@foxclone.com.
  • more error checking, particularly when backing up/restoring.

In the iso:

  • lightdm replaces slim as the display manager - of interest to nobody but me!
  • connecting to wifi - it will prompt for your password (existing foxclone is clunky).
  • reverted to pcmanfm as the file manager replacing thunar (which had some issues).
  • there is a utility to set the timezone if date/time is showing incorrectly (an issue for some users).


I wanted to clone my Arch from the ADATA nvme to the new P14 nvme. Trouble is the P14 is several GB smaller than the ADATA so using Clonezilla would have been problematic I can not even remember if it is possible. so I looked for another solution.

I found Foxclone which states that you can clone from a larger to a smaller drive.Also you can do a clone from a disk to a disk. You can use it to make backups of partitions too. So I thought why not give it a go. Foxclone has to be installed on a usb  or much more friendly you can run it from a Ventoy usb. Downloaded the .iso and copied it over to Ventoy and booted it up.

As there is not a great deal on the Foxclone .iso it booted up pretty quickly and I set to work.

First I made a full image of my Arch. That is the boot,root and home partitions, using the compression setting this gave me a saved file size of 173 GB for my combined Arch size of 253 GB (used size) I saved that to an internal ssd. Foxclone did the task very quickly, can not give times as I forgot to monitor them.

Next I tried to do a disk to disk clone but came across a hitch. I thought as Foxclone only saves/clones the used data I would have plenty of space on the P14. Guess which dummy should have fully read the manual. So I shrank the home partition with gparted on the ADATA so that it was 1 GB smaller than the P14 and tried again. Foxclone would clone the boot partition but would not clone the root partition and then it cloned the home partition. Tried several times but it did the same thing. So I tried to do a clone from the saved image. Got the same result. Hmmmmmmmmmmmmm. Remembered that gparted can be somewhat peculiar in that you sometimes have to reboot for things to work as expected.

Rebooted and tried a disk to disk clone again. This time it worked and told me transfers had been done at 88GB per min. So it did not take long at all. Closed Foxclone and shutdown the pc.  Now Foxclone states that



Specifically, the partitions on the clone drive have identical UUIDs to the partitions on the source drive.


So no need to alter fstab or any other fiddling around needed. However if like me you are cloning with two installed drives you will end up with both drives having the same UUID's which is not ideal so the easiest route is to take out the old drive. No big deal for me as I have an elegant open case set up and both nvme's are on PCIe addon cards. So one screw to remove and pull the card and job done. Big Q is will it boot from this new drive ??

Yup it sure did boot and here I am using my old Arch setup running just fine and dandy on my new P14.

Well at least I think/hope so.

So far I have updated Arch which seemed to go ok. As it was a systemd update the initramfs had to be updated which seemed to go ok. I checked out a few programs and they seem to run ok. I ran kdiskmark and on the 1 GB test it was ok but on the 32 GB test I got this warning




Which I find strange as my root has not grown and the partition is the same size and I never got that warning on any of the test runs I did on these drives before.I'll have to investigate further.


For the time being I will run Arch on this P14 and see how it performs. If everything is tickety boo I will disconnect it and replace the ADATA and wipe it and repartition it form a Live distro and then replace the P14.


There you have it folks a easy peasy way to clone or backup all or individual partitions.



Edited by abarbarian
  • Like 1
Link to comment
Share on other sites


Trouble is the P14 is several GB smaller than the ADATA so using Clonezilla would have been problematic I can not even remember if it is possible.


You just need a partition at least the size of what you are cloning. If you do partition instead of entire disk, I think it just needs what the partition used. So if your partition was 100gb but only used 40gb, you would only need 40gb of space.

  • Agree 1
Link to comment
Share on other sites

On 6/20/2023 at 10:03 PM, securitybreach said:




You just need a partition at least the size of what you are cloning. If you do partition instead of entire disk, I think it just needs what the partition used. So if your partition was 100gb but only used 40gb, you would only need 40gb of space.


Clonezilla is definitely a much more powerful program and you can do a lot more with it. For instance you can do stuff with Clonezilla,



Many File systems are supported: (1) ext2, ext3, ext4, reiserfs, reiser4, xfs, jfs, btrfs, f2fs and nilfs2 of GNU/Linux, (2) FAT12, FAT16, FAT32, exFAT and NTFS of MS Windows, (3) HFS+ and APFS of Mac OS, (4) UFS of FreeBSD, NetBSD, and OpenBSD, (5) minix of Minix, and (6) VMFS3 and VMFS5 of VMWare ESX. Therefore you can clone GNU/Linux, MS windows, Intel-based Mac OS, FreeBSD, NetBSD, OpenBSD, Minix, VMWare ESX and Chrome OS/Chromium OS, no matter it's 32-bit (x86) or 64-bit (x86-64) OS. For these file systems, only used blocks in partition are saved and restored by Partclone. For unsupported file system, sector-to-sector copy is done by dd in Clonezilla.

  • LVM2 (LVM version 1 is not) under GNU/Linux is supported.
  • LUKS (Linux Unified Key Setup) is supported


Foxclone can not do



64 bit systems only.
Local drives only
RAID no.
LVM no.
Mac filesystems no.
English only.


However for the average user using Clonezilla is pretty hard and you have to be pretty careful whilst using it.There are quite a few steps to take before you even get into using Clonezilla. I believe you can use it from Ventoy which makes starting off a bit easier. It took me some time to get to grips with Clonezilla and I have used it successfully over the years.

Foxclone is much simpler. boot from usb,choose source,choose destination,click finish. All done from a gui.As it tested successfully it is definitely going in my toolbox.




Edited by abarbarian
Link to comment
Share on other sites

Fly in the ointment ----- or why do I seem to attract gremlins and their friends !!!!!!


The clone from ADATA to P14 went very smoothly. I saved the clone of the P14 as a clone backup to a USB2 dock with a 500GB hhd so it took almost an hour and a half to transfer the saved file size of 173 GB for my combined Arch size of 253 GB (used size).

Now I have two clone backups. One of the original drive and one of the new drive.Well done lad you are covered for any eventuality, pat yerself on the back.

I pulled the ADATA as I had a clone backup of it saved to an internal ssd which had taken around 18 minutes to run. Reason for pulling it instead of re-partitioning it was to be able to get back to my original set up if things did not work out. In hindsight I should have saved the backup to the slower hdd.As mentioned before the new clone to the P14 ran as expected on reboot.

So far all is good.


Now when you fiddle around with hdd's and ssd's taking them out of your pc and replacing them plugging in flash drives etc your sda can become a sdb or a sdf etc etc . This can be quite confusing. However if you have two drives and A is sda and B is sdb if you pull A then B becomes sda, plug A back in and it becomes sdb. Like I said it can be a tad confusing. The point is your pc will accept the change and run with it until you pull A or B when it will reasign sd's and run with them again.


Nvme's do not follow that reasoning, well at least not on my motherboard.


I have two PCIe slots which have an addon card with a nvme running from them. I could use the two M.2 slots on the motherboard but am concerned about heat hence the addon cards which have plenty of air circulating around them.


So in slot A lived the ADATA designated as nvme0n1. In slot B was the P14 designated as nvme1n1. This was how I cloned the drives.


Pulled the ADATA. Now the P14 in slot B was called nvme0n1, notice the change. P14 runs just fine seems like Foxclone has done a good job.


Reboot with Foxclone. Plug in ADATA to slot A and reparation it. The pc refuses to boot. Starts of well then shows FAILED to do this that and the other and ends up with telling me root is locked you are in an Emergency ?? do this that or the other when logged  in , press enter. Pressing enter leaves me with a flashing cursor which will accept no commands. All I can do is kill the power.


Hmmmmmmmmmmmmmm. Pull the ADATA. Boot up is ok on the P14. So I check out the boot config yes everything looks good. Note that P14 in slot B is now designated as nvme0n1 not nvme1n1, same slot different designation. My boot config is set to boot from nvme0n1p2 which is my boot partition. It has worked well even when slightly altering partitions in the past as I did not have to mess around with UUID's.


Hmmmmmmmmmmmmmm. Maybe if I change the boot config to run from UUID's so there is no confusion in the os. Do that and reboot and all is well.


Replace ADATA in slot A reboot and it fails as before.


Reboot with Foxclone and notice that the P14 in slot B in now designated as nvme1n1 and ADATA in slot A is now nvme0n1. What the heck !!***!!. If things ran as they do with ssd/hdd's the the ADATA installed after the P14 should now be nvme1n1.What the heck !!***!!


As I had noticed the erratic behaviour of the nvme designations maybe if I placed P14 in slot A that would make a difference. Shut the pc down and put P14 in slot A. Rebooted with Foxclone and yes P14 was now designated as nvme0n1. Whoopeeeeeeeeeeeee. Rebooted and it failed as before. What the heck !!***!!


So now I have P14 designated as nvme0n1 and am reinstalling the P14 clone backup to it in the hope that it will boot.


I'll be back. Unless I commit hari kiri.




Foxclone by the way connected me to the internet with no fiddling needed which I thought was pretty neat. It allowed me to write this as I wait for the rewrite to finish. 😴

Link to comment
Share on other sites

Well I nearly committed hara kiri.


Bear in mind that P14 was already partitioned but would not boot. I had managed to get it recognised as nvme0n1 and was trying to install the clone backup to it.


Well it did not boot and threw up the same error messages as before. Hmmmmmmmmmmmmmmm what to do now. Well I thought  I am not waiting an hour and a half using the clone backup on the slow docked hdd. So I copied the files over to an internal ssd.


One thing to note is if you make a clone with Foxclone it asks you where to save the clone to. If you just direct it to one of the options it gives you it will place the files on the root of the drive you select, like so,




What you could do before using the clone facility is to make a folder on your selected backup medium like so




Now the files are tidily placed in the 1stP14clone folder. Which is much easier to deal with.


So of I went again trying to use the clone backup. This time it took twenty five minutes at around 12GB/min. Much more acceptable. However the darn thing did not boot and threw up the same baffling errors. Hmmmmmmmmm what to do.


In a light bulb moment I thought those errors mentioned  something about not accessing any partitions or some such thing.  Maybe I should wipe the drive and leave it unformatted but create a partition table with gparted.

This I did and once again tried to do the clone job.


Hurray success :clap:. I am now running from P14 on nvme0n .


How long will it keep running. Who knows apart from the gods. I still have to reboot to see if it has stuck. I can only live in hope. If it does not boot again I have a handy pure white towel and avery sharp blade so hara kiri may yet happen.



Edited by abarbarian
  • Like 1
Link to comment
Share on other sites

Back gremlin hunting --------- Grrrrrrrrrrrrrrrrrrrrrr.


So I had what seemed like a working set up. The P14 was cloned and I made several reboots and all seemed fine. Ran an Arch update which included a kernel update and all seemed fine. Fired up after a reboot just fine.


Decided to try one last reboot and I was back to not booting and the same error messages. Darn it !!!!


I'll post the exact error messages I thought maybe someone can spot the problem. I'll use the rusty old ToughBook that I used last week on holiday which found a strange network instantly and worked flawlessly.Seems like them some of them pesky gremlins had jumped over to the ToughBook as  I could not get a internet connection. A problem to fix another day.


If I try one last time to boot up with the P14 it may miraculously boot and if not I'll write down the error messages with, you know that old fashioned obsolete pen and paper stuff. The very though made me shudder. Pressed the switch and at the boot screen I had another light bulb moment. Why not try the fallback option ?? Why not indeed what do I have to loose. Choice made and blow me I am allowed to proceed into my Arch set up.

Checked out my boot set up and all looks as normal, checked out fstab and all seems normal. Ran a update and all ran as normal. Ran another "mkinitcpio -P" and all  seems normal. So  am of to do yet another reboot.


I may be back. t12702.gif


I am not so sure about that smiley any more. Windows is looking more and more attractive by the minute.🫣

Link to comment
Share on other sites

Apologies to Foxclone.


It looks like my gremlins were associated with me.


After booting up the P14 in fallback mode and updating Arch and then running "mkinitcpio -P" the good old pc has finally decided to play ball and behave again.


I am now able to boot as normal. Have done five complete shutdowns and restarts so am pretty confident that my gremlins have been fully eradicated. It has been one strange experience and I am surprised at how many different bits of knowledge I managed to find in the old grey cell.


I hope that the gremlins are gone for good.


Don't you just love the penguin world.  t12702.gif

  • Like 1
Link to comment
Share on other sites

3 hours ago, abarbarian said:

Don't you just love the penguin world.  t12702.gif

Yeah, you actually fix problems.

  • Agree 1
Link to comment
Share on other sites

Well can you believe it. them pesky gremlins have jumped from Foxclone to Steam.


Reason for installing to the new nvme was to get the absolute best out of me hardware, just them few extra fps and seconds at load in games.


So I had a quick play of Witcher when I had the P14 tamed. Stopped and thought I'll just move some games around to the old nvme for max performance. An blow me all I can get from Steam is a black window when it loads.

So far I must have tried every tip posted on the net. Uninstalled, reinstalled,searched the pc for every file nad folder to delete, run from docked icon, run from cli, run from cli with extra commands. Just a big black window.


Darn it. 😵‍💫

Link to comment
Share on other sites

I tried Foxclone for cloning HDD to SDD and it doesn't work as well as my old Paragon app.  Paragon allows you to chose what partitions on the drive to use while Foxclone will only clone the entire drive.  So, if like me, you have a large data partition on the drive, you can't clone only the OS partitions like you can with Paragon.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...