Jump to content

Wired internet kaput !!!!


abarbarian
 Share

Recommended Posts

abarbarian

Was surfing ok via wired connection, same connection I have used for ages. Have done no fiddling about. I think I have done some small updates via pacman but am not sure.

Played around with Ventoy the booted back to Arch ,an no wired internet.

Luckily I have a usb wi-fi dongle and this worked fine once set up via "nm-connection-editor".

 Put brain in gear before pressing enter10:46:20-->Sun Aug 21-->~
-->nm-connection-editor
 Put brain in gear before pressing enter10:48:25-->Sun Aug 21-->~
-->ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:ac brd ff:ff:ff:ff:ff:ff
3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:aa brd ff:ff:ff:ff:ff:ff
4: wlp0s20f0u4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 8c:c8:2b:00:52:f6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.16/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20f0u4
       valid_lft 85188sec preferred_lft 85188sec
    inet6 fe80::cf94:58b4:995b:19e4/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

 

Using "ip" I can turn the wi-fi on and off,

 

 Put brain in gear before pressing enter10:48:38-->Sun Aug 21-->~
-->sudo ip link set dev wlp0s20f0u4 down
 Put brain in gear before pressing enter10:49:01-->Sun Aug 21-->~
-->ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:ac brd ff:ff:ff:ff:ff:ff
3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:aa brd ff:ff:ff:ff:ff:ff
4: wlp0s20f0u4: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 8c:c8:2b:00:52:f6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.16/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20f0u4
       valid_lft 85162sec preferred_lft 85162sec
    inet6 fe80::f5cc:8f00:2a2b:b084/64 scope link tentative noprefixroute 
       valid_lft forever preferred_lft forever

 

 Put brain in gear before pressing enter10:49:54-->Sun Aug 21-->~
-->sudo ip link set dev wlp0s20f0u4 up
 Put brain in gear before pressing enter10:50:09-->Sun Aug 21-->~
-->ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:ac brd ff:ff:ff:ff:ff:ff
3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:aa brd ff:ff:ff:ff:ff:ff
4: wlp0s20f0u4: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 8c:c8:2b:00:52:f6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.16/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20f0u4
       valid_lft 86397sec preferred_lft 86397sec
    inet6 fe80::f5cc:8f00:2a2b:b084/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

 

However trying to set either wired connection to "up" does not work with "ip"

 

 Put brain in gear before pressing enter10:49:04-->Sun Aug 21-->~
-->sudo ip link set dev enp7s0 up
 Put brain in gear before pressing enter10:49:38-->Sun Aug 21-->~
-->ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp7s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:ac brd ff:ff:ff:ff:ff:ff
3: enp0s31f6: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 40:8d:5c:e0:e4:aa brd ff:ff:ff:ff:ff:ff
4: wlp0s20f0u4: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 8c:c8:2b:00:52:f6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.16/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp0s20f0u4
       valid_lft 85125sec preferred_lft 85125sec
    inet6 fe80::f5cc:8f00:2a2b:b084/64 scope link tentative noprefixroute 
       valid_lft forever preferred_lft forever

 

I am a bit baffled as to what is stopping my wired connections from working. Any help greatly appreciated. Wireless connection is pretty fast so I can play ok but it would be nice to have the wired connection back. 😭

Edited by abarbarian
Link to comment
Share on other sites

Not sure if this is helpful...maybe you've done it already, but have you tried another p/c using the wired connection or maybe another wire?  Hope you get it sorted out.

Link to comment
Share on other sites

securitybreach

What network manager are you using? NetworkManager, systemd-networkd, netctl,  etc.

 

 

Link to comment
Share on other sites

abarbarian
Posted (edited)
18 hours ago, securitybreach said:

What network manager are you using? NetworkManager, systemd-networkd, netctl,  etc.

 

 

 

NetworkManager, however wa4chq had the answer. 😀

 

16 hours ago, crp said:

NIC or motherboard interface?

 

wa4chq had the answer.

 

21 hours ago, wa4chq said:

Not sure if this is helpful...maybe you've done it already, but have you tried another p/c using the wired connection or maybe another wire?  Hope you get it sorted out.

 

Are you a magician ??

The cable was indeed the culprit. How I do not know. It is routed along with another cable and has been quite happy for several years, never get bumped or snagged or anything or pulled out of the pc at all. It is only about four years old so why it has gone belly up is a mystery.

Currently posting from my Tough Book with a twenty year old cable that has a broken clip and has been badly abused in its life and is still working.

😎

You could say problem solved but I still have to buy another cable and then place it in its pretty complicated route from router to pc. darn and drat.🤔

An a pox on tech.Tried to update me MX-21 on me Tough Book whilst it is up and running and got this,

Err:5 http://ppa.launchpad.net/apandada1/brightness-controller/ubuntu jammy InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A507B2BBA7803E3B
Reading package lists... Done
W: GPG error: http://ppa.launchpad.net/apandada1/brightness-controller/ubuntu jammy InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY A507B2BBA7803E3B
E: The repository 'http://ppa.launchpad.net/apandada1/brightness-controller/ubuntu jammy InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

🙄

Edited by abarbarian
Link to comment
Share on other sites

abarbarian
35 minutes ago, wa4chq said:

Yes, I am....pick a card, any card...

 

King of Spades 🤣 as I am doing some heavy duty gardening at the moment.

 

Funnily enough on a whim I took out the spare network cable and thought I'll just give the original cable a last try. Blow me down it worked straight away. Go figure.Maybe a gremlin just popped in for a quick visit and left. 😬

Link to comment
Share on other sites

13 minutes ago, abarbarian said:

 

King of Spades 🤣 as I am doing some heavy duty gardening at the moment.

 

 

LOL....one of those cards would work as a shovel!

  • Haha 1
Link to comment
Share on other sites

raymac46

I don't think I've ever had a wired Internet issue that was software related. Router cockup, bad (or loose) cable, borked ethernet card - yes. Software no.

Wifi is a whole 'nother problem.

  • Like 1
Link to comment
Share on other sites

1 hour ago, abarbarian said:

Funnily enough on a whim I took out the spare network cable and thought I'll just give the original cable a last try. Blow me down it worked straight away. Go figure.Maybe a gremlin just popped in for a quick visit and left. 😬

 

Electrical contacts oxidise over time. Often just unplugging and re-plugging can re-establish the connection but it may pay to give it a proper clean with contact cleaner.

  • Like 1
  • Agree 1
Link to comment
Share on other sites

On 8/22/2022 at 6:00 AM, raymac46 said:

I don't think I've ever had a wired Internet issue that was software related. Router cockup, bad (or loose) cable, borked ethernet card - yes. Software no.

Wifi is a whole 'nother problem.

I've had USB Network Interfaces not work in one port but do fine in another.

Link to comment
Share on other sites

raymac46
7 hours ago, crp said:

I've had USB Network Interfaces not work in one port but do fine in another.

Back in my dialup days I've had modems get fried by thunderstorms. Again a hardware issue.

Link to comment
Share on other sites

40 minutes ago, raymac46 said:

Back in my dialup days I've had modems get fried by thunderstorms. Again a hardware issue.

I don't know about you guys, but I miss the sound of the modem dialing up...

Edited by wa4chq
Link to comment
Share on other sites

securitybreach

No problem chief, enjoy. BTW I had that as my ringtone at one time.

  • Like 2
  • Haha 1
Link to comment
Share on other sites

16 hours ago, securitybreach said:

No problem chief, enjoy. BTW I had that as my ringtone at one time.

Yes, I believe having it as a ringtone only one time is the way to go.... lol

  • Agree 1
Link to comment
Share on other sites

raymac46

Hard to believe I first went online at 14.4 Kbps with a provider (Prodigy) that used NAPLPS rather than TCP/IP. Paid by the minute for access. Tied up my phone line.

Link to comment
Share on other sites

Yes, I tied up our phone line too from the 1990's through the beginning of 2005. It was not that I was browsing, it just took so long just to do email!

 

I tried dial up when our cable was out. I had an external 56K modem. I couldn't stand it.  It was painful to wait for something to load. I e-cycled that piece of hardware because I realized no way would I ever use that.

Now that I have a smartphone, there is a way to get on without cable and power.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...