Jump to content

Linux Mint 20.3 New Install- Networking Weirdness


Cluttermagnet
 Share

Recommended Posts

Cluttermagnet
Posted (edited)

Hi, All-

 

I just got another of these old Dell Precision T-3400 workstation towers

dirt cheap off of Ebay. (About 30 bucks plus similar shipping) These are

way old, 2009 tech, but I have just had such success with them that I

have sorta standardized on them. Super easy to work on with a very

well thought out chassis design including easy access to things and

good cooling. This one came with an ancient Intel E7400 dual CPU,

2.8GHz. I put in double the memory for 8GB now (20 bucks on Ebay)

and I installed Mint on a 250GB SSD. (~30 bucks)

 

I'm working on it here at Casa Betty, but plan to put this one over at

Casa David, where I do not have a broadband internet pipe, but use a

wireless hot spot thingie to get on the net. It's a lot cheaper than cable

or fiber... I'm not on often enough over there to justify a 'regular' ISP...

 

I really like that both the live session Mint 20.3 and the installed OS

were able to easily find the pci-e 300M network card I put in

(about 7-8 bucks used on Ebay). Here's my problem, though:

 

Both wifi and ethernet were working great out of the box. I could

easily switch between them. So I got all the way through the lengthy

install, over an hour, and at the very end of all this the ethernet started

acting up. If I try to connect to ethernet, it quickly disconnects. No idea

why this should be happening. Only thing I can think of so far is that

I allowed it to update to a newer kernel right at the end. I always save

that for last because it is the only change needing a reboot. So could

I have bricked my ethernet networking due to the new kernel? Seems

unlikely to me. Wifi still connecting great, and seem to be getting an

OK data rate that way? BTW although it would be nice to understand

and fix this problem, this tower is destined to go into a wifi-only

environment. So it is actually not crippled right now, so far as how

it will be used.

 

Comments? Suggestions?

 

TIA, Clutter

 

Edited by Cluttermagnet
Link to comment
Share on other sites

Hedon James

in order to eliminate your suspected culprit (updated kernel), just select the original kernel from your GRUB boot menu.  If the problem goes away, you have confirmed it IS the kernel update.  If the problem persists, there's another issue.  Perhaps the wifi module is somehow the preferred connection over the ethernet, provided that wifi is available.  Can you turn off your router's broadcasted wireless SSID, allowing only ethernet?  Again, this could isolate and/or eliminate a potential culprit.

 

OTOH, I understand wanting to solve a mystery, but why not just place it into service into it's wifi environment and consider it "customized" for that intended environment?  LOL!

Link to comment
Share on other sites

raymac46
Posted (edited)

I have seen a kernel mess up a wifi connection but never a wired one. And never with Linux Mint. It happened with a much later kernel and only with an Atheros wifi card. I would switch off wifi if possible or take the wifi card out of the machine and see if the problem persists. HJs suggestion to boot with the older kernel is also a good one. If you have an ethernet card you could try that just in case the old onboard ethernet connection is too slow or faulty to work reliably.

Edited by raymac46
Link to comment
Share on other sites

raymac46

A bad ethernet cable can also cause problems. Did you install via wire or wifi?

  • Agree 1
Link to comment
Share on other sites

securitybreach

Yup, sounds like a bad ethernet cable or NIC going out as mentioned by others.

 

Link to comment
Share on other sites

V.T. Eric Layton

My suggestion: drivers.

 

Whenever, I've had Ethernet or Wifi issues after a kernel (or other type) upgrade, it's usually a driver issue.

Link to comment
Share on other sites

Cluttermagnet
Posted (edited)

Wow, some very good and logical suggestions here. Perhaps I'll address in reverse order.

Only driver I changed was at Mint's suggestion after install. They persuaded me to substitute

an nVidia driver for the linux generic one installed. I never touched any networking drivers.

That was all automagical during the boot into Live DVD session and subsequently during

the installation of Mint 20.3. Come to think of it, that was the other software install that

occasioned a reboot- that video driver.

 

I like the idea of just yanking the wifi card and seeing if it starts up normally again.

(Power off, of course). That's an easy one so I will try it first.

 

I did my entire install and subsequent software updates over an ethernet cable. While

I can't yet completely rule that out as a problem, I sort of doubt that's it. But I'll look at

that too.

 

It is making sense that maybe an installed wifi card could cause such problems, but

again, I sort of doubt it. Certainly in the live DVD environment, pre-install, the OS that

lived in RAM at the time saw both possibilities and allowed both, wifi or ethernet.

Weird, but what I'd expect to happen, actually.

 

If forced to, I can certainly try to revert to the previous kernel. That's towards the

bottom of my current list, but surely on the list.

 

I'm in a nice situation for sure- even if I don't do anything to fix this little problem,

I have a fully functional machine to use over at Casa David with my cellular 'hotspot.

Thanks all. I'll let you know how it's going... BTW I *seem* to remember at one point

the installed OS did support both networking modes, but things go fast and furious

during an install, so I am not positive about that. My best guess is I did something

software-wise towards the very end to upset the apple cart...

 

Clutter

 

Edited by Cluttermagnet
Typos
Link to comment
Share on other sites

V.T. Eric Layton

I wasn't talking about vid drivers above. I was specifically talking about wifi drivers... or, in your case, drivers specific to that wifi card that you have installed on that system. I could be wrong, but I seriously doubt that Ubuntu auto-magically has generic card drivers for every brand of wifi card out there. A kernel upgrade will quite often deactivate existing drivers. The test, as someone above mentioned, is to just boot the older kernel and see what happens. If the wifi works fine on the older kernel, then it's most likely an incorrect or incompatibility issue with the new kernel and your previous wifi card drivers.

 

Keep us posted on progress.

Link to comment
Share on other sites

raymac46

I run Linux Mint all the time. Here's my setup:

 

ray@ray-basement-SSD ~ $ inxi -Fxz
System:
  Kernel: 5.4.0-121-generic x86_64 bits: 64 compiler: gcc v: 9.4.0 
  Desktop: Cinnamon 5.2.7 Distro: Linux Mint 20.3 Una 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> 
  Mobo: Gigabyte model: F2A85XM-D3H serial: <filter> 
  BIOS: American Megatrends v: F3 date: 04/08/2013 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M310/M310t 
  charge: 55% (should be ignored) status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech K520 
  charge: 70% (should be ignored) status: Discharging 
CPU:
  Topology: Quad Core model: AMD A8-5600K APU with Radeon HD Graphics 
  bits: 64 type: MCP arch: Piledriver rev: 1 L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28797 
  Speed: 1400 MHz min/max: 1400/3600 MHz Core speeds (MHz): 1: 1399 2: 1400 
  3: 1399 4: 1399 
Graphics:
  Device-1: AMD Tobago PRO [Radeon R7 360 / R9 360 OEM] 
  vendor: PC Partner Limited driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.13 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD BONAIRE (DRM 2.50.0 5.4.0-121-generic LLVM 12.0.0) 
  v: 4.5 Mesa 21.2.6 direct render: Yes 
Audio:
  Device-1: AMD FCH Azalia vendor: Gigabyte driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 
  Device-2: AMD Tobago HDMI Audio [Radeon R7 360 / R9 360 OEM] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: Microdia USB 2.0 Camera type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 8-1:2 
  Sound Server: ALSA v: k5.4.0-121-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k 
  v: kernel port: d000 bus ID: 04:00.0 
  IF: wlp4s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.03 TiB used: 219.87 GiB (20.9%) 
  ID-1: /dev/sda vendor: Toshiba model: THNSNH128GBST size: 119.24 GiB 
  ID-2: /dev/sdb vendor: Toshiba model: DT01ACA100 size: 931.51 GiB 
Partition:
  ID-1: / size: 101.55 GiB used: 72.06 GiB (71.0%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 15.95 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 11.8 C mobo: N/A gpu: radeon temp: 30 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 258 Uptime: 4m Memory: 15.65 GiB used: 1.43 GiB (9.2%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.4.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38 
ray@ray-basement-SSD ~ $ 

Note I have both ethernet and wifi listed but ethernet is down and wifi is running things. This setup has been stable and reliable for donkey's years. I don't have ethernet cabling in my basement.

Having said that I find your problem a bit strange because ethernet connections are always the most stable you can get - assuming the hardware is OK.

You could reinstall the driver I suppose - in my case it would be r8169. Also check that you have a Gigabit ethernet connection, the old 10/100 solutions can be a problem.

Link to comment
Share on other sites

raymac46

You can also try

lsmod | grep Ethernet

to see if your ethernet driver is installed.

Link to comment
Share on other sites

raymac46
Posted (edited)

https://www.dell.com/community/Networking-Internet-Bluetooth/Dell-precision-T3400-broadcom-netXtreme-57xx-gigabit-Controller/td-p/3155257

 

BIOS update maybe?

https://www.dell.com/support/home/en-ca/drivers/driversdetails?driverid=dy07g&oscode=biosa&productcode=precision-t3400

If I absolutely needed a wired connection I'd just install a discrete ethernet card. But it sounds like you won't need it. Good old Broadcom messing things up.

Edited by raymac46
Link to comment
Share on other sites

Cluttermagnet

OK, I had a chance to fire the computer up again just now- after pulling

the Wifi card from its pci-e socket. Bingo! Booted right up into a

working ethernet connection. So this post will go out to the group over

ethernet, whereas last night was a wifi session. Clearly this is going to

be good enough, so I will plan to take this tower over to Casa David in

the next day or so.

 

I will need to carefully read and digest the last several posts above

for fuller understanding. Not sure if, at this point, I will need to do any

further (in terms of software/driver fixes). I must say that it seems to

be quite advantageous if one has the ability to move fluidly between

wifi and internet without messing with pulling cabinet sides and PC

cards. OTOH that is something I can probably live without. The vast

majority of my online work is via ethernet connection. Wifi is the

way I do it at my other location, however.

 

Thanks all- for lots of good, insightful comments. I'll try a few of them.

Terminal commands are so easy to do, and often yield quick, major

insights about 'under the hood' (UK = bonnet).

 

Clutter

 

  • +1 1
Link to comment
Share on other sites

raymac46

I have a relatively new Dell desktop which has both wifi and ethernet built in, but I switched the wifi off and just use the ethernet. That is with Windows 11. On other Linux based systems I use wifi and there I can use the Network options to switch off ethernet. I rarely switch between wifi and cable based ethernet, but that's just me. Given a choice I go with cable because it's faster and more secure.

  • +1 1
Link to comment
Share on other sites

Cluttermagnet

:ph34r:

 

Bingo! I have always seen it that way too. Ethernet more secure.

 

Clutter

Link to comment
Share on other sites

Cluttermagnet

Just to add to the topic interest, tonight when I booted up this

new box, it decided to come up with *both* an ethernet and

a wireless connection. I have experienced this in the past, on

different machines. It has been a relatively rare occasion for

me, however. Well, tonight I disconnected the wireless and

am continuing with ethernet. Go figure. Kind of weird...

 

I sorta thought having the wifi card plugged in caused the

machine to preferentially connect wirelessly. Clearly not the

case. Or maybe the OS remembered the last configuration

and repeated it by default. Nope.  Ah well, by now this has

morphed into the merely 'academically interesting' category.

So far this box does networking just fine. It ain't broke so I

won't fix it any more.

 

This 'new' box will go over to Casa David whenever I get around

to it, next few days...

 

Clutter

 

Link to comment
Share on other sites

raymac46

Maybe a Network Manager glitch that corrected itself by the re-re of the wifi card and the reboot or two. In any event it seems you are good to go either way.

Link to comment
Share on other sites

Wifi is one of the trickiest things to reliably get right in Linux. I just changed ISP and couldn't get my old modem to work despite half an hour on their help line, and considerable more time myself. So I didn't have ethernet and never used wifi on this system so it wasn't set up and has no NetworkManager. Plugged in an old Atheros USB wifi dongle to hotspot from my phone and tried to get it working. Sneakernet the firmware and follow the wiki to set up with IWD. Got frustrated, gave up, rebooted and it was working! However it didn't work on subsequent reboots. 😟 

ISP sent me a new pre-configured modem for free and it worked instantly so back on ethernet now.

 

At least I got the opportunity to check out the latest siduction/KDE for a few days as it has NetworkManager and works with the dongle. siduction is rather excellent these days.

Link to comment
Share on other sites

Hedon James
7 hours ago, Cluttermagnet said:

(snipped)

 

I sorta thought having the wifi card plugged in caused the

machine to preferentially connect wirelessly. Clearly not the

case. Or maybe the OS remembered the last configuration

and repeated it by default. Nope.  Ah well, by now this has

morphed into the merely 'academically interesting' category.

So far this box does networking just fine. It ain't broke so I

won't fix it any more.

 

(snipped)

 

Clutter

 

My experience has always been the opposite.  Ethernet being the default, even when a wifi connection is available.  Every laptop I've ever used with linux connected with wifi (some required a little more "coaxing"), but the moment an ethernet cable was connected, I had an ethernet connection.  Which allowed me to download firmware, troubleshoot with google & forums, and learn the magic incantations necessary to coax the wifi from its slumber.  LOL!

  • Like 1
Link to comment
Share on other sites

Cluttermagnet

My big moment of relief came this afternoon as I cleaned up my

computer corner at Casa David, installed this machine, and

tried- successfully- to connect to my (cellular) wifi hotspot.

Whew! Problem solved for now I guess. So here I am with my

alternative Clutter computer emporium working. Yay! Now to

go mow the lawn...

 

Clutter

 

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...