Jump to content

Sadly


raymac46
 Share

Recommended Posts

raymac46

I have had to remove Arch Linux from my Lenovo Flex2-15D notebook. It isn't really Arch's fault. It's just that the ugly AR956X wifi card doesn't work well with the latest kernel and ath9k driver. When I try to update, the download speed drops off to zero after a few seconds. Speed tests show it starting out at 24 Mbps and repidly going down to 2-4. I could use a USB dongle but that only gives me 17 Mbps as a starting point, and it uses up a scarce USB port.

I looked at most stuff in the forums and it appears to be a combination of bad driver and bad hardware.

I tried an LTS version of Lubuntu and it's giving me a steady 40 Mbps speed. I installed Lubuntu so at least I get to stick with the LXQt desktop I was using in Arch.

I haven't abandoned Arch completely as I still have it on my Toshiba netbook. But it is a bummer that this crappy notebook won't run it properly. :bangin:

  • Sad 1
  • +1 1
Link to comment
Share on other sites

securitybreach

Why not simply, hold back the kernel for now and try it again on the next major update? I do that on my server so I only update on major releases, not minor ones. In other words 5.x and not 5.x.x. Open /etc/pacman.conf and find the IgnorePkg line and add linux to it.

 

Quote

IgnorePkg   = linux

 

Downgrade your kernel by installing the previous one from /var/cache/pacman/pkg/ using

 

pacman -U linux-5.16<version that worked>.zst

 

You may want to limit how many versions pacman keeps as it can get rather large. Use paccache manually or you can set it up to clean weekly:  https://wiki.archlinux.org/title/Pacman#Cleaning_the_package_cache

 

The only thing you will get is a message when you update saying the linux package is being held back but it will tell the version that it is skipping so you know when to try again.

 

  • Thanks 1
Link to comment
Share on other sites

raymac46

Lubuntu is using kernel 5.13.X so i suppose I could try that one. I'm sure there is more to it than the kernel though. I think the major reason is the bad wifi solution this laptop has. It has been a problem since the beginning. I think I might just install Arch on my old desktop here where I am already using a more compatible USB wifi. Lots of USB ports on the desktop. Manjaro users also reporting issues with this wifi card in laptops.

Link to comment
Share on other sites

securitybreach

I would still try to downgrade the kernel to see if it works.

Link to comment
Share on other sites

raymac46

Well I have been looking for an excuse to install Arch on the old desktop so maybe this is it.

 

  • Like 1
Link to comment
Share on other sites

securitybreach
Quote

Note that the same commits have been applied to 5.15.29 and upwards, so you cannot revert to the latest LTS kernel 5.15.30-1 as that exhibits the same problem: you can use 5.16.14 or 5.15.28 until upstream fixes this: use the ALA or a local copy to revert.

 

  • Thanks 1
Link to comment
Share on other sites

V.T. Eric Layton

HAHAHA! Boy! You guys sure have some high kernel numbers. Here's mine...

 

vtel57@ericsbane07~:$ uname -a
Linux ericsbane07 4.4.301

 

  • Haha 4
Link to comment
Share on other sites

raymac46

The ath9K driver is part of the kernel so yes it can be affected by regressions I guess. Add that to a rather crummy wifi card and you are asking for trouble. Atheros had a sterling reputation back when I got the laptop, but I had problems even with Windows.

Link to comment
Share on other sites

3 hours ago, crp said:

wifi drivers are kernel dependent ?

 

Yes. Drivers are either included in the kernel or external modules loaded with the kernel at boot.

Link to comment
Share on other sites

raymac46

Well I now am back in business with Arch Linux on my Core 2 Duo desktop. Although it's kinda old and slow it has enough RAM to run Xfce so that's what I'm using. All I need is a decent media player to play music with it.

To be honest I installed Endeavour OS so I don't have to tweak the desktop - I get a nicely configured one. But it's pretty close to vanilla Arch.

I have a TP-Link USB wifi adapter so I'm not having any issues with wifi crashing. Also I have a junk Nvidia GTX 950 card for giggles. Pretty sure it would bottleneck the CPU if I actually tried gaming on it.

 

[ray@ray-inspiron530-workroom ~]$ inxi -Fxz
System:
  Kernel: 5.16.16-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: Xfce v: 4.16.0 Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Desktop System: Dell product: Inspiron 530 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0RY007 serial: <superuser required> BIOS: Dell
    v: 1.0.18 date: 02/24/2009
CPU:
  Info: dual core model: Intel Core2 Duo E8400 bits: 64 type: MCP
    arch: Core Yorkfield rev: A cache: L1: 128 KiB L2: 6 MiB
  Speed (MHz): avg: 2003 high: 2011 min/max: 1998/2997 cores: 1: 2011
    2: 1995 bogomips: 11973
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
Graphics:
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: Micro-Star MSI
    driver: nvidia v: 510.54 bus-ID: 01:00.0
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: nvidia
    unloaded: modesetting gpu: nvidia,nvidia-nvswitch
    resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GTX 950/PCIe/SSE2 v: 4.6.0 NVIDIA 510.54
    direct render: Yes
Audio:
  Device-1: Intel 82801I HD Audio vendor: Dell Inspiron 530
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Device-2: NVIDIA GM206 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.16.16-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel 82562V-2 10/100 Network vendor: Dell Inspiron 530
    driver: e1000e v: kernel port: ff00 bus-ID: 00:19.0
  IF: enp0s25 state: down mac: <filter>
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter type: USB
    driver: r8188eu bus-ID: 2-3:2
  IF: wlan0 state: up mac: <filter>
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    bus-ID: 00:1f.2
Drives:
  Local Storage: total: 223.57 GiB used: 10.53 GiB (4.7%)
  ID-1: /dev/sda vendor: A-Data model: SU635 size: 223.57 GiB
Partition:
  ID-1: / size: 210.34 GiB used: 10.53 GiB (5.0%) fs: ext4 dev: /dev/sda1
Swap:
  ID-1: swap-1 type: partition size: 8.8 GiB used: 256 KiB (0.0%)
    dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 185 Uptime: 1h 22m Memory: 7.76 GiB used: 1.55 GiB (19.9%)
  Init: systemd Compilers: gcc: 11.2.0 Packages: 822 Shell: Bash v: 5.1.16
  inxi: 3.3.14
[ray@ray-inspiron530-workroom ~]$ 

 

Link to comment
Share on other sites

raymac46
Posted (edited)

A bit on the history of this venerable Dell Inspiron 530. It originally belonged to the late Lillian who gave up on it after her son botched an upgrade from Vista to Windows 7. When I got it, it had a cheap dual core Pentium and 2 GB of RAM. I refurbed it with Linux Mint and gave it to another older lady, Jean.

After Jean passed away her brother gave it back to me. At that point I upgraded the CPU, maxed out the memory at 8 GB, and added the video card and an SSD. My granddaughter used it for a while in remote learning. Eventually I gave her a better desktop and put the old machine back in the basement workroom. It has come a long way from its humble origins as a "Vista capable" desktop.

Edited by raymac46
  • Like 2
  • +1 2
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...