Jump to content

This Slacker Running Current Now


V.T. Eric Layton
 Share

Recommended Posts

V.T. Eric Layton

I posted this on Diaspora yesterday...

 

Greelings and Hallucinations, my fine friends…

I’m going to be absent from the Internets for a couple daze. I’m upgrading my Slackware64 GNU/Linux OS from v14.2 to Current.

 

I’m downloading Alien Bob’s (Eric Hameleers) Slackware64-Current ISO as I’m typing this. Once I have it burned, I’ll be installing it. Afterwards, for a day or so, I’ll be installing my fav apps and customizing to my tastes. I’ll be back online shortly thereafter.

 

If, for some reason, you do now see me for a while, it’s because I’ve trashed my system and thrown it down on the floor and danced an Irish jig on top of it. Since it’s my ONLY system currently, I may be absent for a very long time.

 

Please don’t miss me too much. I was a bit of a pain in your arse at times, anyway. ;)

 

Toodles for now…

 

~Eric

 

Well, it's the next day, and after d-loading, burning, installing, setting up, customizing, tweaking, etc., I'm done. All is working now. Yippee!

 

- Slackware64 - Current (soon to be 15) running the 5.12.14 kernel

 

Everyone have a nice weekend. Looks like I may be dodging a hurricane or tropical storm by Sunday evening. YAY! FUN! /sarcasm

  • +1 1
Link to comment
Share on other sites

Hedon James

running current doesn't sound very slackerish.  might hafta change your tagline from nocturnal slacker to nocturnal go-getter!  LOL!

  • Haha 1
Link to comment
Share on other sites

securitybreach

Good luck to you. Make sure to backup your /etc directory along with your other configs.

  • +1 1
Link to comment
Share on other sites

V.T. Eric Layton

I did NOT format my /home partition, so most of my interface and app settings were still there with the new installation. I also don't worry too much about /etc because I tweak my rc.d manually, and only need to copy my fstab and lilo.conf from my mirror to complete /etc. :)

 

Oh, I did also have to copy over my fonts from my mirror, too. MY GAWD what awful fonts come with Slackware! 🙄

 

Sadly, a few of my old SlackBuild apps would not build on the new system and they haven't been updated in eons, so I just dumped 'em. KDE had equivalents. I did the Full Monty Slack install; includes everything and the kitchen sink (15 Gigs' worth).

 

Also sadly, a couple of my fav extensions for Thunderbird would not work in the new version. Oh, well... I'll live.

 

Anyway, as to your comment, @Hedon James, I did this now because Pat's getting ready to lock the development stage... Slack 15 will be out shortly. All I have to do at that point is change my package mirror from "current" to "15"... and I'll be back in standard release again.

 

This may be my last version of Slackware (15) and Windows (10) because once this hardware fails, I'll probably be leaving computering and the Internets permanently. It'll be time to go live some life then. :)

  • +1 1
Link to comment
Share on other sites

securitybreach

There will always be a version of linux that you could get running on hardware. **** a $35 raspberry pi could keep you online. I'll get you a machine when that time comes.

  • Sad 1
  • +1 1
Link to comment
Share on other sites

V.T. Eric Layton
12 minutes ago, securitybreach said:

I'll get you a machine when that time comes.

 

Hmm... seems I may not be able to escape this H3LL. ;)

  • Haha 1
Link to comment
Share on other sites

amenditman

I've got a couple 5 -7 year old machines just wasting away in the workshop. Let me know when you want one and it's yours.

  • Like 1
  • +1 1
Link to comment
Share on other sites

amenditman
1 hour ago, securitybreach said:

Yeah, I have a few extra laptops as well.

 

How is it we end up with all this computer stuff? I didn't buy it.

  • Haha 2
Link to comment
Share on other sites

V.T. Eric Layton

Hey, Bob... I may be interested in some of those graveyard 'puters. I need a PSU and some other odds and ends for my shop system.

  • Like 1
Link to comment
Share on other sites

amenditman

K, I've got PSUs. How about a system with and AMD FX 8350 CPU, 16GB Ram, mobo

Only thing I don't have is a graphics card. No one is giving me any old ones. You'd think they were hard to get or something!? /s

  • +1 2
Link to comment
Share on other sites

Hedon James
7 hours ago, amenditman said:

K, I've got PSUs. How about a system with and AMD FX 8350 CPU, 16GB Ram, mobo

Only thing I don't have is a graphics card. No one is giving me any old ones. You'd think they were hard to get or something!? /s

That thing is a WORKHORSE!  Dated maybe, but still powerful.  I've got a system with AMD FX6200 and 16GB Ram....almost 10 years old now, but still going strong and hardly ever breaks a sweat.  And FWIW, my FX6200 CPU is actually an APU with onboard Radeon graphics.  I'll bet the FX8350 is also an APU; an 8-core CPU with onboard graphics.  That's a beast for you VT!

 

EDIT:  Yep, CPU specs are what I thought, but apparently no onboard GPU, FWIW:

https://www.amd.com/en/products/cpu/fx-8350

 

 

Link to comment
Share on other sites

My theory on how we get so much aging hardware (aside from being packrats:)

  1. CPUs and mobos last a lot longer. The motherboard makers have learned their lessons about bad capacitors, and CPUs from 2008 - assuming they are 64 bit - can still be useful.
  2. It doesn't take 8 cores and 16 threads to surf the Web and play a YouTube video. Even "failed" technology like a Bulldozer CPU is perfectly fine.
  3. SSDs have made a huge difference in perceived speed and snappiness. Even laptops can benefit.
  4. When your old machine won't run Windows 10 and get updates, just install Linux.
  5. Broadband gets better and better and download speed makes an old machine look faster. Wifi is better too with things like mesh routers.
  • Agree 1
  • +1 1
Link to comment
Share on other sites

amenditman

Mine come from folks needing help with their new Win 10 devices, which they can't figure out. "Where is the 'My Computer'? I need that to get to my files."

 

After I school them in the evils of MS and Win they always say, "I have my old junk computer, do you know how to recycle it in an environmentally responsible way?"

Somehow I always answer, "Yes".

 

That's how I get all my "old junk".

  • Agree 1
Link to comment
Share on other sites

Back in the days when desktops dominated, I used to get a lot of obsolete XP and Vista machines which were capable Linux candidates. But around 2014 or so most people in the hood went to laptops. Now all I see are cheap bad slow notebooks. These are hard to upgrade and not really worth my time.

  • +1 1
Link to comment
Share on other sites

V.T. Eric Layton

Well, when I first started with Slackware, Bruno was still around. He made it a lot more easier for me than it could have been. :)

  • Like 1
  • +1 1
Link to comment
Share on other sites

1 hour ago, V.T. Eric Layton said:

Well, when I first started with Slackware, Bruno was still around. He made it a lot more easier for me than it could have been. :)

No doubt,  he was an amazing person.  They say the good die young.   I hope his family are doing well.

  • Agree 1
  • +1 2
Link to comment
Share on other sites

V.T. Eric Layton

Well... Current had a kernel upgrade today.

 

I got it all taken care of, but something weird is going on with my /dev/sda1 partition (Slackware main). I could not get Porteus to mount the /dev/sda1 partition to make an rsync backup before upgrading the kernel. I had to mirror using Clonezilla, instead.

 

Everything looks fine, but I get a warning when I ran LILO that /dev/sda1 is "not active". What does that mean, pray tell? I ended up having to put LILO on the MBR instead of the 1st partition. I also had to do this a week ago when I installed Slack Current. Weird. Changing the boot flag (w/ fdisk) seems to have no effect, either.

 

Other than that, all seems to be working fine.

Link to comment
Share on other sites

securitybreach

Well one of the benefits of using UUIDs is that the number never changes so you do not have to worry about the order of your drives/partitions.

  • +1 1
Link to comment
Share on other sites

V.T. Eric Layton

Oh, I'm familiar with UUID. I hate it like the metric system, though. ;)

  • Haha 1
Link to comment
Share on other sites

V.T. Eric Layton

Update that I just posted on the thread at LQ.org:

 

UPDATE since last night...

After running removing the boot flag from the Windows partition and adding a boot flag to the /dev/sda, I ran #lilo (standard w/ no options) this placed LILO on my /dev/sda1 partition. There were no errors.

This morning, though, I got a "lilo checksum error" when I initiated the machine. I had to use the ISO to chroot into the installation and run #lilo -b /dev/sda again. This allowed normal boot again.

When I first installed Slack -Current from the ISO, it would not boot initially because the installer could not run lilo. At this time, I booted the new installation with the boot stick that I had created. Once in, I ran #lilo -b /dev/sda placing a LILO on the MBR. I think this is when all the troubles started.

I believe that having LILO on the MBR and also on the /dev/sda1 partition simultaneously is causing this checksum error. I'm wondering, if I remove LILO from the MBR (using dd, possibly), this may clear up the entire issue. Thoughts on this, folks? I'd like a little feedback before I use dd for anything. It's a dangerous command. wink.gif

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...