Jump to content

Microphone Follies


Recommended Posts

So I have this Lenovo Flex2-15D laptop which has always given me some sort of hardware grief. The wifi was bad under Windows, often disconnecting at inconvenient times. Now with Linux installed it is rock stable. But I've never been able to get the internal mic to work under any Linux distro with Skype or Zoom or Google Meet. Nor will it record anything.

It appears to be recognized, and if I futz around with PavuControl I can get it to respond in one of those online mic testing sites, but mostly all I get is static and no sound. It apparently has been a problem for many years and nobody has come up with a workable solution. The camera and speakers are fine.

It might be hardware related because most of the issues are with my ALC233 audio chip. I have an ALC3202 in my Thinkpad and everything is fine there.

I have worked around the problem by putting in an external USB mic/speaker combo. This speaker was fuzzy and muddy when plugged into a USB2 port but sounds fantastic when hooked to a USB3 port. I think it's more a matter of getting the right power than it is speed of the connection. Go figure.

Has anyone else had these sort of microphone issues with Linux on laptops?

Link to comment
Share on other sites

  • 1 month later...

I have an old Toshiba Satellite A200 that has a pretty crappy webcam. As far as I know it worked ok in Vista (at least I'm fairly sure that I tried it back when we got this laptop in '07), however the sound steadfastly refuses to work in ubuntu. All I get is static. All settings look like they are correct as I searched for a couple hours and made sure I enabled/disabled all relevant settings - still only static.


The web is littered with posts that seek to find a solution, but very little in the way that anyone has hit on the answer. I chalk it up to an impossible solution, either that or there are only a tiny minority of us "old outdated laptop" users and no one else has had this problem. Not too big of an issue, as I just found it in the back of a closet, blew the dust of her and installed ubuntu 18.04 basically to see if this old girl had any life left in her.

Link to comment
Share on other sites

I have an old Toshiba NB305 netbook that runs Arch Linux and the microphone works with that relic. It is too feeble to attempt any sort of videoconferencing.

I did sort of get the Flex2 microphone working by going into PAVUControl, unlinking the stereo channels on input, and lowering the right channel slider to Silence. Then I got some response out of the mic but it still was staticy.

The Toshiba has Intel audio and the Flex has Realtek.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...