Jump to content

Network not working Slackware


Recommended Posts

I booted up using the latest KDE Live DVD (USB) and everything worked and I could get on the internet with no problem. Using Xterminal and Root I was able to install the Live version to my hard drive using the code "setup2hd" everything installed fine. I booted up to the new install and everything is working except I can't get my internet. There is a red X on the network Icon. I tried using network manager but no luck. My connection is through my router and then to my modem hooked to comcast cable network using DHCP. My connection is wired not wireless. could it be that I have to configure something or is the ethernet missing. Does slack have a Mod Probe to find hard ware? Eric Security and Slacker HELP!

Mel

 

Edited by mhbell
added
  • +1 1
Link to post
Share on other sites

I got it up and running am using it now. I just have to find out how to set it up to do it when I boot it up I used

/etc/rc.d/rc.inet1 eth0_start but the network manager icon still has a red x so it must not be working

Mel

  • Like 1
  • +1 1
Link to post
Share on other sites
V.T. Eric Layton

Also, see --> https://docs.slackware.com/slackware:beginners_guide#configure_your_network

 

Remember, Slackware does NOT use SystemD. It's still uses the SysVinit method. The first thing I usually do after installing Slack is to check /etc/rc.d/ to see if the init permissions are set as I want them to be. In particular, Mel, you need to check /etc/rc.d/rc.networkmanager to see if permissions are such that the Network Manager is starting up at boot time.

 

vtel57@ericsbane07~:$ ls -al /etc/rc.d/rc.networkmanager
-rwxr-xr-x 1 root root 2674 Mar 24  2020 /etc/rc.d/rc.networkmanager*

 

You can see from this that my Network Manager is set to Root (Owner): Read, Write, Execute; Group: Read, Execute, All Users: Execute or 755 (octal).

 

Your settings should be the same for Network Manager to start and be functional for the User.

 

My /etc/rc.d/ permissions:

 

vtel57@ericsbane07~:$ ls -al /etc/rc.d                  
total 388
drwxr-xr-x  10 root root  4096 Sep 24 15:06 ./
drwxr-xr-x 107 root root 12288 Nov 25 10:33 ../
drwxr-xr-x   2 root root  4096 Sep 23  2008 init.d/
lrwxrwxrwx   1 root root     4 Dec 19  2019 rc.0 -> rc.6*
-rwxr-xr-x   1 root root  1362 Apr  5  2015 rc.4*
-rwxr-xr-x   1 root root  8631 Mar 26  2016 rc.6*
-rwxr-xr-x   1 root root  3103 Feb 11  2016 rc.K*
-rwxr-xr-x   1 root root 12126 May  5  2016 rc.M*
-rwxr-xr-x   1 root root 16117 Jun 12  2016 rc.S*
-rwxr-xr-x   1 root root   552 Mar  7  2016 rc.acpid*
-rw-r--r--   1 root root  2556 Apr  1  2016 rc.alsa
-rw-r--r--   1 root root   999 Apr  1  2016 rc.alsa-oss
-rw-r--r--   1 root root  1009 Dec 19  2019 rc.atalk
-rw-r--r--   1 root root  2980 Dec 19  2019 rc.atalk.orig
-rw-r--r--   1 root root  2825 Apr 18  2013 rc.autofs
-rw-r--r--   1 root root  3378 Jun 24  2010 rc.bind
-rw-r--r--   1 root root  1419 Dec 19  2019 rc.bluetooth
-rw-r--r--   1 root root  4917 Jun 14  2018 rc.cgconfig
-rw-r--r--   1 root root  4895 Aug 25  2014 rc.cgconfig.orig
-rwxr-xr-x   1 root root  1462 Dec 14  2015 rc.cgmanager*
-rwxr-xr-x   1 root root  1270 Dec 14  2015 rc.cgproxy*
-rw-r--r--   1 root root  3347 Jun 14  2018 rc.cgred
-rw-r--r--   1 root root  3333 Aug 25  2014 rc.cgred.orig
-rwxr-xr-x   1 root root   572 Jul  7  2012 rc.consolekit*
-rwxr-xr-x   1 root root  2403 Feb  2  2016 rc.cpufreq*
-rwxr-xr-x   1 root root  3678 Jun 15  2016 rc.cups*
-rw-r--r--   1 root root  3085 Jun 23  2016 rc.cups-browsed
-rw-r--r--   1 root root   512 Mar 16  2011 rc.dnsmasq
-rw-r--r--   1 root root   119 Aug 21  2012 rc.font
-rwxr-xr-x   1 root root  1893 Jan 30  2011 rc.fuse*
-rwxr-xr-x   1 root root  1156 Dec  1  2016 rc.gpm-sample*
-rw-r--r--   1 root root  1061 Dec 19  2019 rc.httpd
-rwxr-xr-x   1 root root 10634 Aug  5  2012 rc.inet1*
-rw-------   1 root root  3941 Jan  1  2020 rc.inet1.conf
-rw-------   1 root root  3920 Dec 21  2019 rc.inet1.conf~
-rwxr-xr-x   1 root root  4845 Aug 14  2012 rc.inet2*
-rwxr-xr-x   1 root root   497 Sep 11  2003 rc.inetd*
-rw-r--r--   1 root root  3781 May 18  2013 rc.ip_forward
-rwxr-xr-x   1 root root   272 Aug 11  2006 rc.local*
-rwxr-xr-x   1 root root   168 Apr 23  2011 rc.loop*
-rw-r--r--   1 root root  1340 Dec 19  2019 rc.lxc
-rw-r--r--   1 root root  1487 Jun 12  2016 rc.lxc.orig
-rwxr-xr-x   1 root root  1935 Sep 27  2010 rc.mcelog*
-rwxr-xr-x   1 root root  1864 Dec 19  2019 rc.messagebus*
-rwxr-xr-x   1 root root   778 Dec 15  2015 rc.modules*
-rwxr-xr-x   1 root root   689 Dec 15  2015 rc.modules.local*
-rw-r--r--   1 root root  3191 Dec 19  2019 rc.mysqld
-rwxr-xr-x   1 root root  2674 Mar 24  2020 rc.networkmanager*
-rw-r--r--   1 root root  2449 May 21  2013 rc.nfsd
-rwxr-xr-x   1 root root   804 Jun 23 14:47 rc.ntpd*
-rw-r--r--   1 root root  3489 Feb 28  2018 rc.openvpn
-rw-r--r--   1 root root  1722 Mar 16  2007 rc.pcmcia
-rw-r--r--   1 root root  2326 Dec  2  2016 rc.php-fpm
-rw-r--r--   1 root root  2334 Oct 11  2013 rc.php-fpm.orig
-rw-r--r--   1 root root  1171 Jun 22  2016 rc.pulseaudio
-rw-r--r--   1 root root  1526 Dec 19  2019 rc.rpc
-rw-r--r--   1 root root   940 Dec 19  2019 rc.samba
-rw-r--r--   1 root root   791 Oct 20  2013 rc.samba.orig
-rw-r--r--   1 root root  1170 Jul 12  2013 rc.saslauthd
-rw-r--r--   1 root root   687 Jun  4  2002 rc.sendmail
-rw-r--r--   1 root root  2895 Aug  7  2013 rc.serial
-rw-r--r--   1 root root   895 Jun  5  2013 rc.snmpd
-rw-r--r--   1 root root  1726 Aug  5  2016 rc.sshd
-rwxr-xr-x   1 root root  1371 Jun 29  2016 rc.syslog*
-rw-r--r--   1 root root  1226 Dec 19  2019 rc.sysstat
-rwxr-xr-x   1 root root  1654 Nov 23  2015 rc.sysvinit*
-rwxr-xr-x   1 root root  7042 Dec 19  2019 rc.udev*
-rwxr-xr-x   1 root root   437 Oct  8  2013 rc.ulogd*
-rwxr-xr-x   1 root root  1087 Mar 26  2016 rc.wicd*
-rw-r--r--   1 root root 13316 Aug 19  2012 rc.wireless
-rw-------   1 root root  7320 Aug 19  2012 rc.wireless.conf
-rw-r--r--   1 root root  3683 Oct 17  2013 rc.yp
drwxr-xr-x   2 root root  4096 Sep 23  2008 rc0.d/
drwxr-xr-x   2 root root  4096 Sep 23  2008 rc1.d/
drwxr-xr-x   2 root root  4096 Sep 23  2008 rc2.d/
drwxr-xr-x   2 root root  4096 Sep 23  2008 rc3.d/
drwxr-xr-x   2 root root  4096 Sep 23  2008 rc4.d/
drwxr-xr-x   2 root root  4096 Sep 23  2008 rc5.d/
drwxr-xr-x   2 root root  4096 Sep 23  2008 rc6.d/

Keep us posted on your progress.

 

~Eric

  • Like 1
Link to post
Share on other sites
2 hours ago, V.T. Eric Layton said:

Also, see --> https://docs.slackware.com/slackware:beginners_guide#configure_your_network

 

Remember, Slackware does NOT use SystemD. It's still uses the SysVinit method. The first thing I usually do after installing Slack is to check /etc/rc.d/ to see if the init permissions are set as I want them to be. In particular, Mel, you need to check /etc/rc.d/rc.networkmanager to see if permissions are such that the Network Manager is starting up at boot time.

 

 

 

Hello Eric and thank You. It's been 15 plus years since I last used slack. I have it working now. Very simple to set up in (netconfig) for a wired network which I have. Now I need to find out if there is a way to login and startx at the same time without having to login, password, and startx. I was bored so decided to try out some different distros. At one time many years ago I use to use SuSe commercial as my main distro. I also used Mandrake. years and years ago I tried Minix, but never got it to work right. I also used ARCH, but it was a lot different then. Maybe someday I'll try arch again, nah to much work. I like Manjaro super easy. Guess debian and apt spoiled me. LoL! I've rambled on long enough. Thanks again Eric.

Mel

 

Edited by me to remove author's comment from quotation box. ~Eric

  • +1 1
Link to post
Share on other sites
V.T. Eric Layton

You can auto-login to Slackware. I don't use it, but that's just me. :)

 

First, you'll need to edit your /etc/inittab. You'll need to change the run level.

 

The line you're looking for is:

 

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

 

You'll notice that RL 3 is the default out-of-the-box setting.

 

Slackware Run Levels:

 

# These are the default runlevels in Slackware:
#   0 = halt
#   1 = single user mode
#   2 = unused (but configured the same as runlevel 3)
#   3 = multiuser mode (default Slackware runlevel)
#   4 = X11 with KDM/GDM/XDM (session managers)
#   5 = unused (but configured the same as runlevel 3)
#   6 = reboot

 

You'll be needing to edit the line above to --> id:4:initdefault:

 

By doing this, Slack will initialize with X running and your choice of session managers (KDM/GDM/XDM). Set up your session manager with username, password... and allow to "auto-login" at startup.

 

That should work for you. :)

 

 

  • +1 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...