Jump to content

Network Manager Went Wonky


raymac46
 Share

Recommended Posts

I don't know if it's all the fooling around with DEs and WMs but the Network Manager package on my Arch Linux install on the old Toshiba must have gotten corrupted. When I boot up it connects, then disconnects, then reconnects, then disconnects ad nauseum.

I got into the wonderful world of systemd and disabled NetworkManager.service. Now I am connecting manually through the Terminal using netctl and an old fashioned WPA profile similar to what I did 10 years ago. I have to set the wireless interface down with ip link and the start the netctl profile. It works but it is a crude way to do it. I can't get the netctl to start at boot because the interface is up right away.

@Josh do you know anything about this? How do you connect your wireless laptops?

Edited by raymac46
Link to comment
Share on other sites

securitybreach

If you use netctl, just run wifi-menu as root. Personally, I use NetworkManager on most of my laptops.

Link to comment
Share on other sites

I don't think I have more than one  network service running unless you don't want dhcpcd.

alsa-restore.service                            loaded active exited  Save/Re>
  avahi-daemon.service                            loaded active running Avahi m>
  colord.service                                  loaded active running Manage,>
  dbus.service                                    loaded active running D-Bus S>
  dhcpcd.service                                  loaded active running dhcpcd >
  kmod-static-nodes.service                       loaded active exited  Create >
  lightdm.service                                 loaded active running Light D>
  lvm2-lvmetad.service                            loaded active running LVM2 me>
  lvm2-monitor.service                            loaded active exited  Monitor>
  netctl@wireless\x2dwpa.service                  loaded active exited  Network>
  ntpd.service                                    loaded active running Network>
  org.cups.cupsd.service                          loaded active running CUPS Sc>
  polkit.service                                  loaded active running Authori>
  systemd-backlight@backlight:acpi_video0.service loaded active exited  Load/Sa>
  systemd-journal-flush.service                   loaded active exited  Flush J>
  systemd-journald.service                        loaded active running Journal>
  systemd-logind.service                          loaded active running Login S>
  systemd-random-seed.service                     loaded active exited  Load/Sa>
  systemd-remount-fs.service                      loaded active exited  Remount>
  systemd-sysctl.service                          loaded active exited  Apply K>
  systemd-tmpfiles-setup-dev.service              loaded active exited  Create >
  systemd-tmpfiles-setup.service                  loaded active exited  Create >
lines 1-23
 

Link to comment
Share on other sites

securitybreach

Stop netctl@wireless\x2dwpa.service  

 

Then use wifi-menu (as root) to choose your connection. After successful connection, it will save the profile and autoconnect after that.

Link to comment
Share on other sites

It doesn't stick through a reboot. After I reboot I have to go in as root and ip link set wlp7s0 down, Then wifi-menu will make a connection.

 

Link to comment
Share on other sites

I think I fixed it. I disabled dhcpcd.service since I don't use the ethernet connection on this old laptop. Now wlp7s0 stays down and the netctl service can start properly. I have rebooted a few times and it sticks. I'd prefer Network Manager but at least this works.

Link to comment
Share on other sites

Hedon James

You guys are above my paygrade here, but SBs comment(s)

Quote

It sounds like you have more than service managing your network.

and

Quote

Well that means that something is starting wlp7s0 before netctl.

makes me think of an experience I had with LXQt.

 

Is the problematic machine the one you installed LXQt on, in addition to whatever was there before?  I ask because LXQt recommends ConnMan as the network manager, and depending on how LXQt is packaged, your LXQt install may have pulled in ConnMan, which may be conflicting with Network Manager.  If that's what's happening, sounds like they're taking turns starting & connecting, bumping each other offline, only to restart and try again.  Dueling network connections?  Just a thought...

Link to comment
Share on other sites

Yes I installed LXQt on this machine after Xfce. Looking at my list of services above I don't see anything conflicting other than dhcpcp.service. I always used Network Manager as part of Xfce which was the original install. I am pretty sure I never enabled dhcpcd.service intentionally - nor would I need to since Network Manager handles both wired and wireless.

Right now I am just letting netctl handle things but it is pretty crude in my view. I removed the network-manager-applet but not network manager itself. I may play around a bit later and see if I can get things stable again. If not I'll stick with netctl as I don't take this old machine anywhere and I certainly don't need ethernet.

Edited by raymac46
  • +1 1
Link to comment
Share on other sites

Well I got tired of trying to get netctl to stick through a reboot (it failed again today.) So I disabled it and re-enabled NetworkManager.service. Now it seems stable. I removed the applet earlier and I really don't need it. We'll see how this goes.

I just did a package update with no problem.

Link to comment
Share on other sites

Reinstalled network-manager-applet and everything seems stable. Just don't try to run dhcpcd.service and NetworkManager.service at the same time, dummy.

  • Agree 1
Link to comment
Share on other sites

securitybreach
3 hours ago, raymac46 said:

Just don't try to run dhcpcd.service and NetworkManager.service at the same time, dummy.

 

It happens, trust me B)

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...