Jump to content
réjean

could not start kdeinit5 in PCLinuxOS

Recommended Posts

réjean

Hi all! I haven't posted in quite awhile because I tried not to fool around too much but now that I am waiting to change my system (probably need a new mobo and/or processor) but right now I am using a laptop with PCLinuxOS installed on it. It worked okay until this morning (awfully slow but this is just temporary.

Anyway I updated it this morning and now when I reboot,after entering my username and password I get the following message;" Could not start kdeinit5". If I boot into a recovery mode and type "startkde" I get the following message;"display is not set or cannot connect to the X server".

I am actually posting using a live Kubuntu from a flash drive and I am wondering if there is something I can do beside a reinstall.

Thanks!

Share this post


Link to post
Share on other sites
Hedon James

I'd try the login manager. For KDE I'd assume it's

 

start kdm

 

But depending how up to date your pclos OS is, and which version of KDE it's running, could be using the latest & greatest sddm (simple desktop display manager).

 

start sddm

Edited by Hedon James

Share this post


Link to post
Share on other sites
réjean

When I do boot in in normal mode I do get a login manager where I can click on the icon with my name and then I am asked for the password. It's after that that I get the message about being unable to start kdeinit5.

But I will reboot again in recovery mode and try your suggestions in awhile (I am away from the laptop right now).

Share this post


Link to post
Share on other sites
réjean

I forgot to say that after I got the problem and before I posted I had tried from the recovery mode to "apt-get update" which didn't help and after that "apt-get upgrade" but I was told that there was nothing to upgrade. And I am using KDE Plasma.

Share this post


Link to post
Share on other sites
Hedon James

sorry, i missed the part about username & password. but it does sound like a login manager problem, where system services aren't being started, such as the xserver. I think I'd purge kdm from the CLI, then re-install kdm from the CLI. If that doesn't work, I'd install sddm from the CLI and use sddm.

 

I had a corrupted login on my wife's ubuntu laptop a few years ago. I couldn't get it fixed properly, so I installed gdm (ubuntu default was lightdm at the time) and ubuntu gave me a message about 2 login managers, and asked which was to be used as default. I chose gdm and her system was good from that point.

 

Of course, this doesn't necessarily mean your diagnosis is the same, but they sure sound similar. I'd start with the login manager and see what happens from there. fwiw...

Share this post


Link to post
Share on other sites
réjean

I thought about installing gdm.

Share this post


Link to post
Share on other sites
sunrat

Could also be a display driver issue. Did the drivers or kernel update? There are occasional mismatches particularly with Nvidia drivers not building for certain kernels.

I'm not familiar with PCLos though.

 

I thought about installing gdm.

I doubt that's a good idea. SDDM works well for me. Not sure what is default in PCLos.

Edit: :> Oops, I just had a quick look at their forum and Tex said something that makes me think gdm is the default.

Have you tried booting with a different kernel? It seems you're not the only one to have this issue today so check the PCLOS forum.

Share this post


Link to post
Share on other sites
réjean

Could also be a display driver issue. Did the drivers or kernel update? There are occasional mismatches particularly with Nvidia drivers not building for certain kernels.

I'm not familiar with PCLos though.

 

[

Have you tried booting with a different kernel? It seems you're not the only one to have this issue today so check the PCLOS forum.

 

How could I bootin in a different kernel?

Share this post


Link to post
Share on other sites
réjean

also it seems that whatever I try (apt-get update, aapt-get upgrade, apt-get install gdm) I get the 2 following lines:

/etc/host.config: line3: bad command 'nospoof.on'

/etc/host.config: line4: bad command 'spoofalert on'

then more action takes place like fetching, eg.

Share this post


Link to post
Share on other sites
Hedon James

I can't imagine gdm is default on a KDE plasma desktop. I'd bet kdm or sddm; maybe even lightdm...in that order.

Share this post


Link to post
Share on other sites
sunrat

I can't imagine gdm is default on a KDE plasma desktop. I'd bet kdm or sddm; maybe even lightdm...in that order.

 

Me either but read comment #14 from Tex at the post about exactly the same issue: https://www.pclinuxos.com/forum/index.php/topic,148618.0.html

 

 

How could I bootin in a different kernel?

In the GRUB boot menu you should be able to select "Advanced options" or something and select a different kernel. That's assuming you have a different kernel, and you have a GRUB menu.

Share this post


Link to post
Share on other sites
réjean

at this point I am tempted to replace PCLinuxOS with Kubuntu 18.10 wich is what's on the flash drive and what I was using on my main system, but keep the /home partition.

Share this post


Link to post
Share on other sites
réjean

Yahoo! I am back in business. I don't know if it is because I login as root instead of booting into recovery mode or because I told the system that I was going to install Kubuntu in lieu of PCLinuxOS (lol) but after trying a few of the suggestions on the PClos forum and then either an 'apt-get update' or an 'apt-get upgrade' but a bunch of lib64qt5... types of files got installed and upon rebooting KDE Plasma came back.

Thanks guys for your help. Greatly appreciated.

Share this post


Link to post
Share on other sites
Hedon James

I can't imagine gdm is default on a KDE plasma desktop. I'd bet kdm or sddm; maybe even lightdm...in that order.

 

Me either but read comment #14 from Tex at the post about exactly the same issue: https://www.pclinuxo...c,148618.0.html

 

How could I bootin in a different kernel?

In the GRUB boot menu you should be able to select "Advanced options" or something and select a different kernel. That's assuming you have a different kernel, and you have a GRUB menu.

 

I see what you mean. For the record, I didn't doubt you, I just find that pairing gdm to login into a KDE desktop strange & unlikely. Then again, this is PCLOS, which uses Debian Aptitude as a front-end package manager for RPM packages, so why not, right?! :pirate:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...