Jump to content
Robert

Ubuntu Broke This Morning

Recommended Posts

Robert

This morning I clicked on Ubuntu Software and unfortunately decided to install the updates it found. It required a reboot and that now gives me a black screen. I can hold the Shift key down while rebooting and choose an old kernel and then log in fine, but would like to know what is going on.

 

Ubuntu 16.04 LTS

 

Black screen with 4.4.0-143

Boots okay with 4.4.0.142

 

The History Log file says:

 

Start-Date: 2019-03-15 11:10:36

Commandline: aptdaemon role='role-upgrade-system' sender=':1.79'

Install: linux-modules-4.4.0-143-generic:amd64 (4.4.0-143.169, automatic), linux-headers-4.4.0-143:amd64 (4.4.0-143.169, automatic), linux-image-4.4.0-143-generic:amd64 (4.4.0-143.169, automatic), linux-headers-4.4.0-143-generic:amd64 (4.4.0-143.169, automatic), linux-modules-extra-4.4.0-143-generic:amd64 (4.4.0-143.169, automatic)

Upgrade: linux-headers-generic:amd64 (4.4.0.142.148, 4.4.0.143.151), linux-libc-dev:amd64 (4.4.0-142.168, 4.4.0-143.169), linux-image-generic:amd64 (4.4.0.142.148, 4.4.0.143.151), snapd:amd64 (2.34.2ubuntu0.1, 2.37.4), snap-confine:amd64 (2.34.2ubuntu0.1, 2.37.4), ubuntu-core-launcher:amd64 (2.34.2ubuntu0.1, 2.37.4), linux-generic:amd64 (4.4.0.142.148, 4.4.0.143.151)

End-Date: 2019-03-15 11:11:37

Share this post


Link to post
Share on other sites
securitybreach

You could try the following:

 

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade -y

 

Or you could pass the kernel parameter nomodeset by editing the boot options line and adding 'nomodeset'.

Share this post


Link to post
Share on other sites
Robert

Thanks, but I'm afraid of messing up this kernel with another update.

Share this post


Link to post
Share on other sites
securitybreach

You are not messing with the kernel, you simply edit the boot command before hitting enter. The change only occurs for that boot.

 

Just select the kernel, hit e and add nomodeset to the kernel line and hit X to boot.

 

If it works, I can show you how to add that permanently. If not, just reboot and its gone.

  • Like 1

Share this post


Link to post
Share on other sites
Hedon James

are you using an Intel video driver? I've had some issues with lubuntu 16.04 and funky/quirky displays. I am also on the 4.4.0 kernel series. Google-fu suggests there's something going on with intel-based drivers and video stack in Ubuntu right now. One person even posted "ironically, AMD and nVidia are in better places than Intel right now."

 

I'd just boot with the good kernel until this gets resolved. Might even want to pin the good kernel until the newer ones are fixed, fwiw.

Edited by Hedon James
  • Like 2

Share this post


Link to post
Share on other sites
Robert

It is an nvidia driver. Not sure if I got this kernel today or before.

 

I'll reboot and try nomodeset

Share this post


Link to post
Share on other sites
Robert

After adding nomodeset it says does not recognize command.

Share this post


Link to post
Share on other sites
Robert

That sort of works. It boots to the sign-in screen, but after signing in it immediately jumps back to the sign-in screen and plays a drum roll.

Share this post


Link to post
Share on other sites
V.T. Eric Layton

Possibly, your old Nvidia drivers (built on the previous kernel) will not load with the new kernel. You'll need to do a fresh install of the Nvidia drivers.

Share this post


Link to post
Share on other sites
Robert

I experimented on a second hard drive and found later versions of Ubuntu, 16.04.6 and 18.04, locking up within a few minutes of logging in. I remember having the same problem last year when I first tested 18.04 when it first came out.

 

I have already lost 4-5 hours into this kernel problem and finally found a work around by editing the grub boot order.

 

To fix I did this:

Copy-Paste gksudo gedit /etc/default/grub in terminal

Then change GRUB_DEFAULT=0 to GRUB_DEFAULT="1>3" so it will choose the 4th kernel choice in the menu.

Then Save, and sudo update-grub to make sure it really saved.

 

Now it automatically boots into the kernel it did this morning before the ill fated update.

  • Like 1

Share this post


Link to post
Share on other sites
securitybreach

Well that works but eventually you will need to update the latest kernel.

 

Things like this is one of the reasons I love Archlinux. Archlinux package manager, pacman, would of rebuilt the nvidia driver when the kernel got installed. If there was a problem, you would been told before the update even started downloading (through pacman or from archlinux.org).

 

The installation is a bit more involved but I find admining arch much simpler that the "easier" distros like Ubuntu and others. A lot of this has to do with all the custom patching that distros do to personalize their user's experience or other reasons. When you use vanilla packages from the upstream source as the dev intended, you end up with less breakage because things were originally built against the vanilla packages. Basically, your systems know what to expect.

 

Sorry for the rant..

 

Ubuntu and others do a lot of testing but sometimes bugs creep up because of custom patching. I would do as Eric suggested and reinstall nvidia again. Just out of curiosity, could you give us the output from this command?

 

lspci | grep VGA

 

Thanks

 

PS, I do not suggest that you install Arch, I was just ranting. B)

Share this post


Link to post
Share on other sites
Robert

I do not think nvidia is the issue. Last night I tried installing 16.04.1 kernel 4.4.0-31, and then updated it, but without nvidia. It unfortunetly updated to 4.4.0-143 and while it let me sign in, it would lock up before fully loading the desktop. And after the update 4.4.0-31 also locked up, probably becouse it is too old. Ubuntu appears to be no longer compatible with my hardware.

  • Like 1

Share this post


Link to post
Share on other sites
V.T. Eric Layton

"...Ubuntu appears to be no longer compatible with my hardware."

 

Hmm... I find that hard to believe. Most any Linux is compatible with older hardware. I'm not really up-to-date on Ubuntu (or Debian) these days, so I don't really know.

Share this post


Link to post
Share on other sites
securitybreach

"...Ubuntu appears to be no longer compatible with my hardware."

 

Hmm... I find that hard to believe. Most any Linux is compatible with older hardware. I'm not really up-to-date on Ubuntu (or Debian) these days, so I don't really know.

 

Well Nvidia announced this back in 2014: NVIDIA to Drop Support for Old Video Cards from Linux Drivers

  • Like 2

Share this post


Link to post
Share on other sites
V.T. Eric Layton

Ah... well, what vid is the OP using?

  • Like 1

Share this post


Link to post
Share on other sites
Hedon James

FWIW, my Lubuntu 16.04 install just updated to the 4.4.0-143-generic kernel (+1 from the prior *142 kernel) and everything seems to be functioning fine, same as before. If it helps with troubleshooting, here's my system info:

 

jim@Asus-SS:~$ inxi -b

System: Host: Asus-SS Kernel: 4.4.0-143-generic x86_64 (64 bit)

Desktop: Fluxbox 1.3.5 Distro: Ubuntu 16.04 xenial

Machine: System: ASUS product: All Series

Mobo: ASUSTeK model: Z87M-PLUS v: Rev X.0x

Bios: American Megatrends v: 0311 date: 04/18/2013

CPU: Quad core Intel Core i7-4770 (-HT-MCP-) speed/max: 3400/3900 MHz

Graphics: Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller

Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)

Resolution: 1920x1080@60.00hz

GLX Renderer: Mesa DRI Intel Haswell Desktop

GLX Version: 3.0 Mesa 18.0.5

Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

driver: r8169

Drives: HDD Total Size: 4269.0GB (47.6% used)

Info: Processes: 274 Uptime: 6 min Memory: 1869.5/15732.2MB

Client: Shell (bash) inxi: 2.2.35

jim@Asus-SS:~$

 

based on nothing more than what I've seen in this thread, I'd be looking squarely at the nVidia driver as culprit. Either pin the *142 kernel that works for you, or try to boot to the terminal with the buggy 143 kernel and update nvidia driver from a terminal, then login from that terminal. I believe Ubuntu is using lightdm as login service; I know Lubuntu uses LightDM.

 

Side note...do you NEED proprietary nvidia drivers, or just prefer them? Or are you using the open source nouveau drivers for nvidia hardware?

  • Like 1

Share this post


Link to post
Share on other sites
sunrat
The installation is a bit more involved but I find admining arch much simpler that the "easier" distros like Ubuntu and others.

I find siduction easier than "easier" distros too, even MX. Once you realise to abort upgrade when many packages are flagged to remove and just wait, it's fairly plain sailing.

 

PS, I do not suggest that you install Arch, I was just ranting. B)

 

I don't suggest to install siduction either. :D

 

I do agree with Hedon James though, completely uninstall Nvidia drivers and see if nouveau works ok. Nouveau works well for my system with GTX560 Ti.

  • Like 2

Share this post


Link to post
Share on other sites
Robert

Using version 364.19 for a GeForce GTX 660.

 

Based on my previous experiences with trying to change or update nvidia drivers, and once even permanently losing access to the hard drive, it is not worth the risk to my main computer. The 2nd Hard Drive was locking up without nvidia drivers so...

 

A couple of years ago I bought a Dell Desktop with the build-in Intel graphics from Goodwill for $25 and yesterday installed the 2nd (experimental) hard drive that was locking up in my main computer and it booted right up and had no issues.

Share this post


Link to post
Share on other sites
V.T. Eric Layton

Every time I've ever upgraded a kernel on ANY of my Linux installations (Slackware, Debian, CentOS, etc.), it was a MUST-DO to reinstall the Nvidia drivers. They must be built against the new kernel, modules, and headers or Nvidia will NOT function. I used to do this by booting into run level 3 (no X enabled) and run the Nvidia installer via command line. I still use this method in Slackware.

 

I still say this is an Nvidia driver issue. The drivers you had installed (built) using the older kernel won't work with the new kernel. It's just not going to happen. Nvidia must be re-installed.

 

---

 

NOTE: The above is only true if you manually installed proprietary Nvidia drivers downloaded from their site. If you installed Nvidia drivers from the Ubuntu repos, they should have updated with the kernel, I would think. Could be wrong, though. I haven't messed around with Ubuntu or Debian in quite some time.

Share this post


Link to post
Share on other sites
Robert

With the 2nd hard drive, a new clean install with the new kernel, it locks up too quickly after login for nvidia drivers to be installed.

 

With the original hard drive and the new kernel it goes to a black screen and I cannot log in.

 

If there is a way to install nvidia drivers in either case I am missing it.

Share this post


Link to post
Share on other sites
V.T. Eric Layton

Stand by for help from some of the Ubuntu users, Robert. I'm not at all sure how Ubuntu handles Nvidia updates.

Share this post


Link to post
Share on other sites
Robert

The motherboard is a Gigabyte Z68XP-UD3P. A Google search turns up problems running Linux the last few years. Some say stay away from Gigabyte if running Linux.

  • Sad 1

Share this post


Link to post
Share on other sites
sunrat

The motherboard is a Gigabyte Z68XP-UD3P. A Google search turns up problems running Linux the last few years. Some say stay away from Gigabyte if running Linux.

I run a couple of Gigabyte mobos and they are fine.

The newer one has a setting in UEFI called something like "OS Type" which I had to change to even get Linux installed. Can't look now, but I have that one multiboot with about 6 Linuxii currently. ;)

Share this post


Link to post
Share on other sites
Hedon James

See if this forum/FAQ advice applies to you:

 

https://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it

 

#3 (if an update or something else...) has specific scenarios for nvidia users. Seems like you need to get booted into a terminal so you can manually uninstall nvidia and either use nouveau or reinstall nvidia against that 4.4.0-143 kernel.

Share this post


Link to post
Share on other sites
raymac46

Gigabyte works fine for me as well. Mind you I am all AMD on that system. That one runs Linux Mint 19.

I have another desktop running MX Linux with a GTX 950 and I just use Nouveau. Unless you need sophisticated 3D for something, Nouveau works well enough.

A new install is also locking up? It wouldn't have any proprietary drivers installed. I would try another distro like MX Linux or Mint to be sure you don't have a hrdware issue.

Edited by raymac46
  • Like 1

Share this post


Link to post
Share on other sites
V.T. Eric Layton

My last three main systems and one shop system were all Gigabyte mobos. The only one I ever had issues with was the one currently in my shop system. The PCIe vid slot went bad. I can only use onboard vid on that machine, which is fine. I don't need special vid capabilities out there in the shop.

Share this post


Link to post
Share on other sites
V.T. Eric Layton

Hedon James said, "Seems like you need to get booted into a terminal so you can manually uninstall nvidia and either use nouveau or reinstall nvidia against that 4.4.0-143 kernel.'

 

YES! This is the method that I always used in any Linux distro and still use in Slackware. :)

  • Like 2

Share this post


Link to post
Share on other sites
raymac46

Normally DKMS will look after a module rebuild when you update the kernel.

Share this post


Link to post
Share on other sites
Hedon James

Hmmmm....I might've spoken a little too soon Robert. ^ Above I said I upgraded to kernel 4.4.0-143-generic with no issues. Tried to use Virtualbox to access a VM today and got the message:

 

r0X3H.png

 

but executing

 

sudo sbin/vboxconfig

 

in terminal yielded an error, with suggestion to look at log file. I don't understand that log file....hundreds of entries of debug code; I simply understood "Failed". Much googling led me to this page:

 

https://superuser.com/questions/1285964/how-to-fix-and-prevent-virtualbox-kernel-driver-not-installed

 

before I realized I'd dealt with this about 2-3 weeks ago, and elected to just boot with working 4.4.0-142-generic kernel and wait for the next kernel to get things worked out (4.4.0-144-generic?). Everything seems to firmly point to kernel header issues with that 143 kernel. Your issue is slightly different, but likely still related, as faulty kernel headers won't allow your HOST to boot. I thought this might be limited to virtualbox-dkms and intel drivers/graphics stack, but your reported issues with nvidia drivers suggests to me that there is more going on with the 4.4.0-143 kernel and graphics than we know. I'm thinking it's just a BAD kernel, not to be used.

 

I'm going to wait for the 4.4.0-144-generic kernel to hit my 16.04 release and see if that addresses the issue. If it doesn't, I'll probably go through the gyrations suggested in the linked thread. In the meantime, just gotta remember to boot into the 4.4.0-142 kernel until the *-144 is an option. I don't really have time to see if the recommended fix addresses the *-143 kernel issue when I already have a working *-142 kernel. I'll wait to see if ubuntu gets its act together for the next kernel. We can't be the ONLY 2 ubuntu users experiencing this issue. I'm inclined to think it gets fixed in the next kernel update. JMO...

Edited by Hedon James
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...