Jump to content

Edumicate the stumped one


ichase
 Share

Recommended Posts

I know I am missing something extremely simple here, but I built my new desktop computer, installed Arch, no problems there, but when I remove the Arch Linux Live disk and boot into the OS I can't get ethernet to work? Works fine with the live disk in but once I am in the OS, nada.

 

I did run

 # systemctl enable dhcpcd@eth0.service 

 

That ran without errors but still a no go. I have never had ANY issues when plugging up an ethernet cable to any Arch linux build I have owned.

 

So you know I am missing ONE major step and maybe because my eyes just are not what they used to be I missed it. ;)

 

Any suggestions are ALWAYS welcome.

 

Thanks again

 

Ian

 

Still have not got the SSD drive on the lappy loaded yet, time has not been on my side. Maybe next week.

Link to comment
Share on other sites

amenditman

Arch does not use the eth0/wlan0 naming from BIOS any longer, it uses a name provided from udev/hardware detection.

It should be something like 'enp0s25' see the ArchWiki Networking page and scroll down to the Device Names paragraph under Network Interfaces.

 

You should be able to get it to go with just

# systemctl enable dhcpcd.service

 

Try disabling the service you show above and run this one without any interface name first and see if that fixes it.

Link to comment
Share on other sites

I disabled the first service, again no problem there but when I try and enable dhcpd.service is says it does not exist. Have NEVER had issues getting ethernet to work, that is normally not a problem.

 

I'm delving into the Network Configuration Arch Wiki to see if I can figure this simple thing out.

Edited by ichase
Link to comment
Share on other sites

amenditman

You can type

# ip link

to discover the names on your system.

Then you can use

# systemctl start dhcpcd@interface.service
# systemctl enable dhcpcd@interface.service

where interface is the name from the ip link output.

  • Like 1
Link to comment
Share on other sites

Eric, I promise you have NOT been ignored, and Slackware is all that and a bag of chips, but I am an Arch guy, I still respect Slackware being the "original" :thumbup:

Am going to try Ameditman's suggestion first thing in the morning. Just not sure what happened, Arch has always seemed to recognize the network when the ethernet cable is plugged in. Heck, I USED to have my desktop setup with Wifi, which was a piece of cake. :)

Edited by ichase
  • Like 1
Link to comment
Share on other sites

amenditman

We all have to admit that Slackware must be really stable and easy to keep running smoothly.

How else would Eric have so much time to admin forums, pad his post count, write all those blogs, and write detective stories?

 

Hey, maybe if I ran Slackware I could have a life also!

  • Like 1
Link to comment
Share on other sites

V.T. Eric Layton

Yeah, old folks and cats like Slackware (and Debian) because there are rarely any surprises.

  • Like 1
Link to comment
Share on other sites

Guest LilBambi

Not just that, but for cats in particular ;) they like things that don't move around a lot. You know, like having to pull out the system and put in all kinds of new shiny stuff, etc. ;)

Link to comment
Share on other sites

securitybreach

Hmm, my cat loves stuff that moves around. She loves to swat at new things or anything moving. B)

Link to comment
Share on other sites

saturnian

Yeah, old folks and cats like Slackware (and Debian) because there are rarely any surprises.

 

Debian's boring (my friend, though, says, "Boring is good"). :P

 

So I also run Arch and Sabayon, where updates might break something. :Muahaha:

 

Even though I'm an old cat.

Edited by saturnian
  • Like 3
Link to comment
Share on other sites

V.T. Eric Layton

I think what Fran means when she says "moving" is like rearranging furniture and stuff like that. My cats hate it whenever I move stuff around in my house. The grumble and give me angry looks for days afterwards. It's like rearranging the furniture at Helen Keller's house. They just like things to stay the same.

  • Like 2
Link to comment
Share on other sites

securitybreach
So I also run Arch and Sabayon, where updates might break something. :Muahaha:

 

Might is the key word B)

 

I have not had anything break in a really long time plus I do the weekly clonezilla backups just in case.

Link to comment
Share on other sites

Guest LilBambi

I think what Fran means when she says "moving" is like rearranging furniture and stuff like that. My cats hate it whenever I move stuff around in my house. The grumble and give me angry looks for days afterwards. It's like rearranging the furniture at Helen Keller's house. They just like things to stay the same.

 

Exactly Eric! :yes:

Link to comment
Share on other sites

Ok, up and running :) I was pretty much right the first time except for the fact I used eth0 instead of enp2x0x

 

# systemctl enable dhcpcd@enp2x0x0.service

 

Still have some tweaking to do but so far I was able to get my official and local packages from my laptop installed on the desk top. Now to see how ard it is going to be to run video from both the Nvidia video card and the AMD on board video to get the 3 monitors going. Won't be touching this until next week. HOPEFULLY this week I can start the install on the SSD drive on the laptop. Yeah, that was a few weeks ago and life just seems to get in the way ;)

Edited by ichase
Link to comment
Share on other sites

V.T. Eric Layton

Wow! That systemd sure is complicated. To enable networking using SysVinits, I would just do this:

 

# chmod -R 755 /etc/rc.d/rc.networkmanager

 

And that's it. Off to the races... :yes:

 

=====

 

Just yankin' you Archbois' chains, you know. ;)

Link to comment
Share on other sites

securitybreach

Actually that is more complicated than simply running:

# systemctl enable dhcpcd@[interface].service

  • Like 1
Link to comment
Share on other sites

V.T. Eric Layton

Actually that is more complicated than simply running:

# [color=#282828][font=helvetica, arial, sans-serif][size=4] systemctl enable dhcpcd@[i]interface[/i].service

[/size][/font][/color]

 

I don't know, man. All that UBBcode was pretty complicated looking to me. ;)

  • Like 2
Link to comment
Share on other sites

Interesting that the wired protocol didn't "stick" from installation. When I was installing Arch a short while ago on my old desktop, I was able to enable the USB wifi on the install CD and do the whole installation with wireless. As far as I can remember the wifi worked after I had the system installed and rebooted.

ETA: No I did get the wifi working on the installer manually so I did the install OK but - on reboot I had to install dhclient and use that to get an automatic wifi connection every time with netctl.

Edited by raymac46
Link to comment
Share on other sites

amenditman

Wow! That systemd sure is complicated. To enable networking using SysVinits, I would just do this:

 

# chmod -R 755 /etc/rc.d/rc.networkmanager

 

And that's it. Off to the races... :yes:

 

=====

 

Just yankin' you Archbois' chains, you know. ;)

Please don't say that systemd is complicated in the same sentence you mention using NetworkManager for the same task.

systemd is simplicity and clarity exemplified compared to NetworkManager.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...