Jump to content

Mint Cinnamon live cd help


Recommended Posts

So I installed LMC to a usb. Did some tweaking and installed stellarium, everything was ok, reboots worked.

Then I thought maybe me mate does not want auto login. Big mistake.


I used the configuration program from LMC and unchecked the "auto login" boxes. Now I can not start LMC.


Everything seems to work up to a point. I get some writing on a black screen, get the MINT logo and then some more writting. Up to this point this is as normal.


Then the writing stops and tells me the system can not find this that or the other and drops me into a "init shell?" Which seems to be some sort of rescue (?) shell. I can type in "help" and get a list of commands I can use but have no idea how to use them. There is no shutdown or reboot option so I have to kill from the wall switch.


Can anyone tell me what to do to save this install ? I could reinstall but have made quite a few changes and it is probably easier to save than reinstall.



Link to comment
Share on other sites

Hedon James

This sounds like a graphics card issue, or a lightdm issue. Did you enable a proprietary graphics driver? From the command prompt, can you start the desktop GUI with "startx" command? If you can, I'd be less suspicious of a graphics driver issue and moreso of the lightdm software. Found this on the Mint forum, which may be helpful if you can "startx" from terminal:



  • Like 1
Link to comment
Share on other sites

Thanks for the search.


Startx is not one of the commands I could use. I recon you are right about it being something to do with the log in.


I fannyed around and eventually after six restarts I got into Mint by pressing "enter" several times when the MINT logo was on screen, no idea why that worked but it did. Reset the changes and am now going to try a reboot.


I may be some time.



Link to comment
Share on other sites

Well I could not access Mint.


The message I get is,



BusyBox v.1.20.2 built in shell (ash)

(intramfs) Unable to find a medium containing a file system


If I type "help" at the cli I get a list of commands but can not see anything I recognise that may help.


I can access the Mint Live session but am trying to access the Mint Live with Persitence.


Any bright ideas folks. :'(

Link to comment
Share on other sites

Stone me I just do not know what is going on.


It now looks like Mint is working just fine :w00tx100: so I am not going to fiddle anymore and send the stick of to me mate asap. I added a few notes to help him on his way.





Link to comment
Share on other sites

Thanks raymac46.


It is a bit of a puzzle but I think it is sorted now, keeping me fingers crossed.


Mint Cinnamon (Ubuntu) worked well from the E2B usb, but I only tried it in Live mode not Persistence mode.


I used LiLi to make a usb with persistence and everything seemed to work well, I rebooted quite a few times to check that it was ok.


I made some changes, added a few programs, set up FF, and changed the log in from auto to manual. This is where the problems started.


Would not boot, would boot, would not boot, so I changed back the log in to auto and that seems to have cleared up the glitch. So I am sort of confident that I have a reliable usb install. This is only a short term solution as as soon as me mate is comfortable with being a penguin I will do a full install to his hdd or I may be able to persuade him to buy a small ssd. I'll have to check that his Dell will work with a ssd first though.


So I am quietly impressed with Mint despite the hickups. It works on his lappy and my pc straight otb. The only flaw I have found so far is that I can access my Windows partitions and files but I can not access my Arch files as access is denied. :happyroll:

Link to comment
Share on other sites

Hmm ! Ignore all my previous ramblings.


I had downloaded Super Grub2 Disk to try and sort out the booting problem. Ran through the options and it would not find the usb stick, so I discounted it as a help.




However. If I try to boot with just the usb plugged in to the pc it will fail.

If I try to boot the usb and have the SG2D in the cd drawer the usb boots. I do not have to access the SG2D or interact with it at all, it never shows on the screen, it never shows up at all on screen, Mint seems to run through its normal set up except at a certain point I hear the cd drive running, and then Mint boots and loads and runs just fine.


So it looks as though raymac46 was heading in the right direction with his help.


The whole thing has left me rather puzzled but I seem to have a work around and that will have to do for now.


Only reason I am posting is it may help other folks who have trouble booting usb live distros. It is certainly worth trying at the very least.



Edited by abarbarian
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...