Jump to content

Conky error in Arch with recent update of wirelesstools


Recommended Posts

If you are using conky-lua in Arch Linux you may experience the following error. I have my conkys set up in my OpenBox menu and when selected they were not coming up. When I tried to run them via the command line I received the following error:

conky: error while loading shared libraries: libiw.so.29: cannot open shared object file: No such file or directory

 

2 Days ago, a bug was created: https://bugs.archlinux.org/task/38813 but it was deemed not a bug.

 

Seems as if you downgrade wirelesstools; downgrading to version 29-8 conky starts working again. I have confirmed this to be true. Provided you have not recently run pacman -Scc the older package should be in /var/cache/pacman/pkg

 

Just run the following to downgrade from wirelesstools version 30.pre9-1

 

# pacman -U /var/cache/pacman/pkg/wirelesstools-29-8-x86_64.pkg.tar.xz

 

And Conky will start running again. :)

 

Edit: Forgot to mention, if you are running 32 bit Arch Linux, the file name will be different, just search /var/cache/pacman/pkg, run -ls and find the correct file name for wirelesstools-29-8 running the same code as above but with the correct file name after /pkg/. :)

Edited by ichase
  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...