Jump to content

.asf files in linux


LLfan
 Share

Recommended Posts

WEll I tried to get mplayer working on my machine before without much success so let me read up on your first post a bit.
Still using SuSE? That's probably why. SuSE doesn't include any of the windows codecs (patent concerns). The creator of Mplayer mentions this at his website. You can either download mplayer from him, compile and install it or try just downloading the codecs and finding the correct address to put them in. Lest anyone think SuSE is nuts, Debian users have to do the same thing. Mandrake doesn't seem to worry about lawsuits. I guess when you don't make any money, you don't have to worry about someone suing you for it! :huh: Just kidding, Mandrake fans, don't hurt me!
Link to comment
Share on other sites

  • 3 years later...
Hi MikeBut did you try it the way as described in the xs4all link ?? ( looks easier then installing yet another player :hmm: )You can get extra codecs here: http://www.mplayerhq.hu/homepage/design6/dload.htmlB) Bruno
Hallo Bruno :D ,I used to be able to play non copyright .wma and .asf files in mplayer on my 'old ' machine, by selecting the win32 codecs. If the 'wrong codec' was selected replay was muffled & had short breaks in it.On my new 64 bit machine I'm running MPlayer 1.0pre8-4.1.1 and I can't get it to play the old files properly, they are decoded, but the sound is muffled and there are short breaks. (Plays fine in XP). I've looked in the audio codec section of mplayer, but can't see the win 32 codecs which I know are loaded from my other posts on updating mandriva 2007 B) . How do I get Mplayer to recognise the codecs, or does this version of Mplayer do things differentley?Looking forward to more advice please :thumbsup: .GrogerfPS,The link above doesn't work anymore. Did a search and found the Mplayer pages, but I was unsure how to go further.Grogerf Edited by Grogerf
Link to comment
Share on other sites

I always copy those win32 codecs to /usr/local/lib/codecs,if that directory doesn't exist I create it.Then I copy the codecs to /usr/lib/codecs, again if that directory doesn't exist I create it.Then I copy them to /usr/local/lib/win32 and /usr/lib/win32,again if those directories don't exist I create them.In the past /usr/local/lib/win32 or /usr/lib/win32 was the default directory,some packages as well as a few other Unix players like xine and avifile still use it, but other packages look in one of the other directories. So instead of messing around with links that and links this I just copy all the codecs to the directories mentioned above, they don't eat that much space anyway. Until now it has always worked with all my 20 distros.I think that's were your problem is, so trying the above might not break a thing.The link above still works, tested it here. Codecs are here:http://www.mplayerhq.hu/design7/dload.html#binary_codecs(Linux x86 20061022)

Link to comment
Share on other sites

I always copy those win32 codecs to /usr/local/lib/codecs,if that directory doesn't exist I create it.Then I copy the codecs to /usr/lib/codecs, again if that directory doesn't exist I create it.Then I copy them to /usr/local/lib/win32 and /usr/lib/win32,again if those directories don't exist I create them.In the past /usr/local/lib/win32 or /usr/lib/win32 was the default directory,some packages as well as a few other Unix players like xine and avifile still use it, but other packages look in one of the other directories. So instead of messing around with links that and links this I just copy all the codecs to the directories mentioned above, they don't eat that much space anyway. Until now it has always worked with all my 20 distros.I think that's were your problem is, so trying the above might not break a thing.The link above still works, tested it here. Codecs are here:http://www.mplayerhq.hu/design7/dload.html#binary_codecs(Linux x86 20061022)
Hallo Stricker :) ,Thanks for your help. I found that I did not have /usr/local/lib/codecs, /usr/lib/codecs, or /usr/local/lib/win32, but I did have /usr/lib/win32. When I looked in /usr/lib/win32 it had wma9dmod.dll, wmadmod.dll, wmspdmod.dll and others looking like codecs together with a reaqdme saying they were binary codecs for use with mplayer. I made the directories you suggested and copied all the files into the new directories. It didn't make any difference to playing the .asf file and I still couldn't see the 'win32' codecs in the mplayer gui. ;) Next I deleted all the files from the new directories, downloaded essential-amd64-20061203.tarbz2 from the mplayer site, it gave four files (atrc.so,cook.so, drvc.so, sipr.so and a readme. I then copied these files into the new directories.This didn't work either B) - no new codecs visible in mplayer. Did I download the wrong file :( I obviously need more help - hope that you've got the patience - and looking forward to getting it right!Grogerf
Link to comment
Share on other sites

Hi GrogerI think there is a big chance that the codecs will work in Xine ( install xine-ui ;) ) . . . would you mind to try ?B) Bruno

Link to comment
Share on other sites

Hi GrogerI think there is a big chance that the codecs will work in Xine ( install xine-ui ;) ) . . . would you mind to try ?B) Bruno
Hallo Bruno :D ,Thanks for your input ;) Xine plays the files the same poor way as mplayer - muffled & with short gaps. Should I paste all those .dll files from usr/lib/win32/ back into the extra directories that Stricker suggested & try again?It would be good to get them working in xine, but better if it could be done in mplayer, because mplayer is used by other programs (audiokonverter & a couple of command lines that I've worked out) to do audio file conversion.I had a look around and found a file in/etc/mplayer/ called codecs.conf and this is what it says for windows audio audiocodec wma9dmo info "Windows Media Audio 9 DMO" status working format 0x162 format 0x163 driver dmo dll "wma9dmod.dll" guid 0x27ca0808, 0x01f5, 0x4e7a, 0x8b, 0x05, 0x87, 0xf8, 0x07, 0xa2, 0x33, 0xd1audiocodec wmadmo info "Windows Media Audio DMO" status working format 0x160 format 0x161 format 0x162 format 0x163 driver dmo dll "wmadmod.dll" guid 0x2eeb4adf, 0x4578, 0x4d10, 0xbc, 0xa7, 0xbb, 0x95, 0x5f, 0x56, 0x32, 0x0aaudiocodec wma9spdmo info "Windows Media Audio 9 Speech DMO" status working format 0xa driver dmo dll "wmspdmod.dll" guid 0x874131cb, 0x4ecc, 0x443b, 0x89, 0x48, 0x74, 0x6b, 0x89, 0x59, 0x5d, 0x20audiocodec wma9spdshow info "Windows Media Audio 9 Speech DShow" status buggy format 0xa driver dshow dll "wmavds32.ax" guid 0x795b44c4, 0xf142, 0x493d, 0x8a, 0x02, 0x09, 0xbd, 0x41, 0x08, 0x95, 0xadI found the mplayer readme in /usr/share/doc/mplayer-1.0 it seemed to indicate that the binary codecs had to be installed before mplayer was installed "STEP1: Installing Binary Codecs~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~MPlayer has builtin support for the most common audio and videoformats, but some formats require external codecs. Examples include Real, Indeoand QuickTime audio formats. Support for Windows Media formats except WMV9exists but still has some bugs, your mileage may vary. This step is notmandatory, but recommended for getting MPlayer to play a broader range offormats. Please note that most codecs only work on Intel x86 compatible PCs.Unpack the codecs archives and put the contents in a directory where MPlayerwill find them. The default directory is /usr/local/lib/codecs/ (it used to be/usr/local/lib/win32 in the past, this also works) but you can change that tosomething else by using the '--with-codecsdir=DIR' option when you run'./configure'.__________________________STEP2: Configuring MPlayer~~~~~~~~~~~~~~~~~~~~~~~~~~MPlayer can be adapted to all kinds of needs and hardware environments. Run ./configureto configure MPlayer with the default options. The codecs you installed aboveshould be autodetected. GUI support has to be enabled separately, run'I know that mplayer worked fine on these files in Mandriva 2006 on a 32 bit machine. The win32 codecs downloaded for Firefox plugins were 32 bit - will I also have to use the mcc to install 64 bit win 32codecs for mplayer? I had hoped that downloading essential-amd64-20061203.tarbz2 and putting the results where directed would solve the problem!Looking forward to yet more support :) GrogerHallo again!!Found more documention in /usr/share/doc/mplayer-1.0/HTML/en/installation_codecs.html (what do I do to make this easier to find?), it makes it quite plain "2.2. Codecslibavcodec: This codec package is capable of decoding H.263/MJPEG/RV10/DivX3/DivX4/DivX5/MP41/MP42/WMV1/WMV2/SVQ1/SVQ3 encoded video streams and WMA (Windows Media Audio) v1/v2 audio streams, on multiple platforms. It is also known to be the fastest for this task. See FFmpeg section for details. Features: gain decoding of videos mentioned above, on non-x86 machines encoding with most of the mentioned codecs this codec is the fastest codec available for DivX/3/4/5 and other MPEG-4 types. Recommended! Win32 codecs: If you plan to use MPlayer on x86 architecture, you will possibly need them. Download a codec package from our codecs page and put the codecs in /usr/local/lib/codecs BEFORE compiling MPlayer, otherwise no Win32 support will be compiled!"Does this mean that I should copy all the files to /usr/local/lib/codecs , then remove & reinstall mplayer to get it all working?Looking forward to more understanding!Grogerf Edited by Grogerf
Link to comment
Share on other sites

I found the mplayer readme in /usr/share/doc/mplayer-1.0 it seemed to indicate that the binary codecs had to be installed before mplayer was installed
Does this mean that I should copy all the files to /usr/local/lib/codecs , then remove & reinstall mplayer to get it all working?
Usually this is if you compile mplayer from source . . . . but you could indeed try to un-install mplayer and re-install it again.You could even, if after the re-install it still does not work, un-install it again and get the .tar.gz package and try to compile it from source.;) Bruno
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...