Jump to content
SueD

FF 3.6 breaks Invision power board editor?

Recommended Posts

SueD

I've got a new problem and because of it, I can't start a new topic. So if a mod could be so kind as to move this thread, I'd be most appreciative.I can't reply to a post unless I use the Fast Reply option. If I just use Reply, my cursor doesn't appear. Firefox 3.6 in Archlinux.Thanks.

Share this post


Link to post
Share on other sites
rbdietz

Windows 7 and Firefox 3.5.7 here so maybe this doesn't apply.When I click the reply button, the cursor doesn't appear until I activate the reply window by clicking in it.

Share this post


Link to post
Share on other sites
SueD
Windows 7 and Firefox 3.5.7 here so maybe this doesn't apply.When I click the reply button, the cursor doesn't appear until I activate the reply window by clicking in it.
I'm now trying it with a different browser (epiphany) so it's an FF issue. Off to check my add-ons now.Thanks. B)

Share this post


Link to post
Share on other sites
Urmas

Ahem... questions:1. When you click on "Add Reply", "New Topic" etc, do you get the reply window? If you do:2. When you click on "Reply with quote", does the quoted text appear in the "reply box"? If it does:3. When you click on the "reply box" and type something, click on "Preview Post", do you see what you've typed?4. Have you tried another browser?5. Have you tried with another Firefox theme?6. Extensions? Pheeew... what else?EDIT: Oopsy... x-posted. Fuggedabout 4.

Share this post


Link to post
Share on other sites
SueD

1. When you click on "Add Reply", "New Topic" etc, do you get the reply window? If you do: Yuppers2. When you click on "Reply with quote", does the quoted text appear in the "reply box"? If it does: Yuppers3. When you click on the "reply box" and type something, click on "Preview Post", do you see what you've typed? Nope...can't type4. Have you tried another browser? Yuppers5. Have you tried with another Firefox theme? Just about to6. Extensions? Pheeew... what else? Removing them...will be back.

Share this post


Link to post
Share on other sites
SueD

Sonofagun, with my addons disabled and the theme set to default, it still won't work!Ideas anyone?

Share this post


Link to post
Share on other sites
Urmas

Well... it's either the theme or a misbehaving addon. Rocket scientist, moi. B) 1. Test the "previous" theme without addons. Still working?2. Enable your addons one by one. Shoot the culprit.3. Have fun! :thumbsup:

Share this post


Link to post
Share on other sites
SueD

At the moment, I'm running FF without addons and the default theme...still not able to use the Reply button.I'll work on this tomorrow when I'm not so frustrated.Thanks.

Share this post


Link to post
Share on other sites
Urmas
I'll work on this tomorrow when I'm not so frustrated.
Sorry, Sue... I must've been asleep last night; I somehow managed to misread "sonofagun, with my addons disabled and the theme set to default, it still won't work!"... nevermind. :( Anyway... more info on this –– CAN FOLKS USING FIREFOX 3.6 VERIFY THIS?
It seems to me FF 3.6 update borks the Invision PB rich text editor. At the very least it suddenly stopped working when I upgraded to FF 3.6.________________This is a behaviour change induced by a modification in Firefox. It is not yet determined (in the bug) if the new Firefox behaviour is correct or if it is a new bug introduced by Fx 3.6.For the moment, a user has been able to find a collection of about 20 code modifications that changed the behaviour. This very same user is still investigating in order to pinpoint the culprit. Once this is done, a dev will likely be able to study the problem and determine who is the culprit, Firefox (in that case, expect a fix in 3.6.1 or 3.6.2) or the RTE relying on a previous bug (in that case, Invision will have to fix it).
http://forums.mozillazine.org/viewtopic.ph...9&t=1710095So... if that is so, here's what you should try:Reply window, top right corner, there's a "switch between standard and rich text editor" button:rte-switch-editor.pngClick on it... that'll take you back to "standard mode", i.e. less WYSIWYGness in the reply box; you'll see bolded words in "b tags" instead of... ahem... bold. And so on. Eh. I prefer the "standard mode" anyway; when the fancy "rich text thingy" gets things wrong, it's abother fine mess...P.S. Edited the title to... fit the plot. :thumbsup:

Share this post


Link to post
Share on other sites
SueD
Sorry, Sue... I must've been asleep last night; I somehow managed to misread "sonofagun, with my addons disabled and the theme set to default, it still won't work!"... nevermind. :( Anyway... more info on this –– CAN FOLKS USING FIREFOX 3.6 VERIFY THIS?http://forums.mozillazine.org/viewtopic.ph...9&t=1710095So... if that is so, here's what you should try:Reply window, top right corner, there's a "switch between standard and rich text editor" button:rte-switch-editor.pngClick on it... that'll take you back to "standard mode", i.e. less WYSIWYGness in the reply box; you'll see bolded words in "b tags" instead of... ahem... bold. And so on. Eh. I prefer the "standard mode" anyway; when the fancy "rich text thingy" gets things wrong, it's abother fine mess...P.S. Edited the title to... fit the plot. :thumbsup:
Aha, that worked! It never occured to me to turn off the editor.Thanks Urmas. :thumbsdown:

Share this post


Link to post
Share on other sites
Urmas

Just got a confirmation from Frank Golden. Frank uses FF 3.6 (multiple OS's), and the rich text editor no worky. :)

Share this post


Link to post
Share on other sites
SueD
Just got a confirmation from Frank Golden. Frank uses FF 3.6 (multiple OS's), and the rich text editor no worky. :)
Oh thank goodness! Usually, when I'm the only one with the problem, it's because of something I did. Glad to hear I'm not alone in this. :)

Share this post


Link to post
Share on other sites
Urmas
:)

Share this post


Link to post
Share on other sites
V.T. Eric Layton

Hmm... testing.Now is the time for all good men to come to the aid of their country.Testing...=====Cursor disappears in RICH mode. :)

Share this post


Link to post
Share on other sites
Urmas

OK, n=3... statistical significance achieved. :) FIREFOX 3.6 USERS: For the time being, you will have to use the reply editor in "standard mode" (see post #9).

Share this post


Link to post
Share on other sites
V.T. Eric Layton

I've been coming here for 4 years and never noticed that you could switch. I really didn't notice any big diff. I think you can use HTML in RICH mode. Whoop-dee-do.

Share this post


Link to post
Share on other sites
mlangdn
I've been coming here for 4 years and never noticed that you could switch. I really didn't notice any big diff. I think you can use HTML in RICH mode. Whoop-dee-do.
I am using FF-3.6 and I just hit the Reply button and am happily typing in the box. So, I have no idea what is going on.

Share this post


Link to post
Share on other sites
mlangdn
I am using FF-3.6 and I just hit the Reply button and am happily typing in the box. So, I have no idea what is going on.
Replying to me with the editor off - can't see much difference. Oh well............

Share this post


Link to post
Share on other sites
Urmas

You sure? Here's what formatting a post in "standard mode" looks like:kuvakaappaus1.pngRichie Rich mode:kuvakaappaus.png

Share this post


Link to post
Share on other sites
mlangdn

I generally use fast reply anyway. However, for the above, I did use the Reply button and had no problems with the cursor. I don't use the Richie Rich stuff anyway. When I did click on the editor button, I saw no difference, so maybe it don't work for me anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...