Jump to content

Dual Boot


Recommended Posts

Hondanut

Hi all. I have decided to make my system dual boot a hardware way. I have found a DPDT "on / on" switch that are soldered to the leads that run from the switches and led's found mostly on the older AT style cases. These leads have small plugs on the ends to connect to the motherboard. They also happen to fit the jumper pins on hard drives. Lucky me ;) Now when connected to the master pins on the hard drives in place of the nomal jumpers enables me to shut down the computer and flick the switch. On the next boot the master slave configuation is reversed. You also have to set the BIOS settings for the hard drives to auto. This will make the drives auto detect on every boot. The hard drives in my system at least, when left with no jumper makes that drive the slave. you would have to check your drives to make sure that this is the case for you as well. If you decide to go this route. This works very well. Now my question is this. I originally installed Mandrake 9.1 dual boot with windows xp. The lilo boot loader is on my windows hard drive which was originaly "hda Windows" to linux. I want to change the boot loader to be "hda Linux" the problem I think I am having is that I have to boot the windows hard drive to get into linux right now with the current boot loader when I am in linux it still finds hda to be the windows drive. so from there I cant change the boot loader to be in the right place. Short of having to reinstall linux how do I install the boot loader to the linux drive? After I figure this out I will go into the Windows XP recovery console and "fixmbr" to remove lilo from the windows drive, then each system will boot completly indepenent of each other. I think I will have to do this from a floppy when the linux drive is set to be the master. Any ideas on this? Thanks

Link to post
Share on other sites

Hi HondanutWhat you´re trying to do looks possible, but you do not have a bootsector on your second HD where Mandrake lives.Restoring the MBR on HD 1 with XP is no problem and works the way you indicated.Either you have to create a bootsector on HD 2 and give the command ¨/sbin/lilo¨ from mandrake. Or you will have to reinstall Mandrake disabling HD 1, in order to let Mandrake create the new bootsector on HD 2Hope this answers your question.;) Bruno

Link to post
Share on other sites
Hondanut

Ok great. Thanks. Any idea how to create the boot sector before running the command? I have to get to work now. So I wont get a chance to try it till tonight though.

Link to post
Share on other sites
Peachy
Ok great. Thanks. Any idea how to create the boot sector before running the command? I have to get to work now. So I wont get a chance to try it till tonight though.
Do you have a rescue disk? If you do first boot with that so that you get Linux up and running. This I presume would mean you would be booting with the XP drive in the Primary Master position or /dev/hda in Linux lingo. You will have to give us more detail about which OS is sitting on which drive and how they are partitionned. This information is critical otherwise what I am about to tell you may fail. So, please give us a thorough partition layout of each drive and where exactly is LILO sitting. To help, please post the contents of your /etc/lilo.conf file to this thread.
Link to post
Share on other sites
Hondanut

Hi Peachy. Thanks for taking this on. The first one I will give you was before I started messing with it to try to have it boot from the linux drive. boot="/dev/hda"map=/boot/mapkeytable=/boot/us.kltpromptnowarntimeout="100"message=/boot/messagemenu-scheme=wb:bw:wb:bwdefault=windowsimage="/boot/vmlinuz" label="linux" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet" vga=788 read-onlyimage=/boot/vmlinuz label="linux-nonfb" root=/dev/hdb1 initrd=/boot/initrd.img append="devfs=mount hdd=ide-scsi acpi=off" read-onlyother=/dev/hda1 label="windows" table=/dev/hdaimage="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" label="" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off" read-onlyother=/dev/fd0 label="floppy" unsafeimage="/boot/vmlinuz" label="old_linux" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off" vga=788 read-onlyimage=/boot/vmlinuz label="failsafe" root=/dev/hdb1 initrd=/boot/initrd.img append="devfs=nomount hdd=ide-scsi acpi=off failsafe" read-onlyThis second one is how it looks now :blink: :D boot="/dev/hdb"map=/boot/mapkeytable=/boot/us.kltpromptnowarntimeout="100"message=/boot/messagemenu-scheme=wb:bw:wb:bwdefault=linuximage="/boot/vmlinuz" label="linux" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet" vga=788 read-onlyimage="/boot/vmlinuz" label="linux-nonfb" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off" read-onlyother=/dev/hda1 label="windows" table=/dev/hdaimage="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off"image="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" label="" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off" read-onlyother=/dev/fd0 label="floppy" unsafeimage="/dev/fd0" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off"image="/dev/fd0" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off"image="/boot/vmlinuz" label="old_linux" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off" vga=788 read-onlyimage="/boot/vmlinuz" label="failsafe" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=nomount hdd=ide-scsi acpi=off failsafe" read-onlyI have two hard drives installed. One is a 60 gig Maxtor with a c and d drive split about 50/50 and the second drive is a 6.4 gig Fugitsu with Linux taking up all of it in 3 partitions. I have tried to tell lilo to install in the root of the linux drive and thats how it looks now. I think I would have to change this from a boot floppy when the linux drive is set at master. I did try to upgrade the install with the linux drive set to master but it detects errors when it gets to checking the file system. A fresh install would fix it but thats a lot of work.Oh and one last thing lilo is installed in the boot sector of the windows drive.

Link to post
Share on other sites
Hondanut

One more thing you asked. Do I have a rescue disk. I don't have a rescue disk for mandrake 9.1 but I do have a boot floppy for mandrake 7.1 that will get me to a prompt. I also have a susie live 8.2 cd if that will help.

Link to post
Share on other sites
Peachy
boot="/dev/hda"map=/boot/mapkeytable=/boot/us.kltpromptnowarntimeout="100"message=/boot/messagemenu-scheme=wb:bw:wb:bwdefault=windowsimage="/boot/vmlinuz" label="linux" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet" vga=788 read-onlyimage=/boot/vmlinuz label="linux-nonfb" root=/dev/hdb1 initrd=/boot/initrd.img append="devfs=mount hdd=ide-scsi acpi=off" read-onlyother=/dev/hda1 label="windows" table=/dev/hdaimage="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" label="" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off" read-onlyother=/dev/fd0 label="floppy" unsafeimage="/boot/vmlinuz" label="old_linux" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off" vga=788 read-onlyimage=/boot/vmlinuz label="failsafe" root=/dev/hdb1 initrd=/boot/initrd.img append="devfs=nomount hdd=ide-scsi acpi=off failsafe" read-onlyI have two hard drives installed. One is a 60 gig Maxtor with a c and d drive split about 50/50 and the second drive is a 6.4 gig Fugitsu with Linux taking up all of it in 3 partitions. I have tried to tell lilo to install in the root of the linux drive and thats how it looks now. I think I would have to change this from a boot floppy when the linux drive is set at master. I did try to upgrade the install with the linux drive set to master but it detects errors when it gets to checking the file system. A fresh install would fix it but thats a lot of work.Oh and one last thing lilo is installed in the boot sector of the windows drive.
Okay, let me see if I understand this: 2 disks; 60GB Primary Master containing Windows XP and LILO on the MBR; 8GB Secondary Master containg Mandrake. LILO dual boots using the Linux install on /dev/hdb1 and Windows from /dev/hda1.So far so good. Now, the tricky part: when you boot directly from the 8GB disk, does the BIOS see this as the Secondary Master still or has it made it the Primary Master. I'm not sure how this DPDT on/on switch thingamabob works. Judging by your second /etc/lilo.conf file it appears Linux is being told it is still the Secondary Master or /dev/hdb:
This second one is how it looks now  :) :) boot="/dev/hdb"map=/boot/mapkeytable=/boot/us.kltpromptnowarntimeout="100"message=/boot/messagemenu-scheme=wb:bw:wb:bwdefault=linuximage="/boot/vmlinuz" label="linux" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet" vga=788 read-onlyimage="/boot/vmlinuz" label="linux-nonfb" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off" read-onlyother=/dev/hda1 label="windows" table=/dev/hdaimage="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off"image="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" root="/dev/hdb1" initrd="/boot/initrd.img" append="devfs=mount hdd=ide-scsi acpi=off quiet"image="/dev/hda1" label="" root="/dev/hdb1" initrd="/boot/initrd.img" append="quiet devfs=mount hdd=ide-scsi acpi=off" read-only
But fair enough. Let's leave it at that. Since you haven't copied the Linux bootsector from the Windows disk to the Linux disk, then you should do that first and then see if you can boot from the Linux disk when you switch drives.To do that boot from the Windows disk and get into Linux from the LILO menu. You can still do that, correct?Log in as root, and get to a console and type the following command:dd if=/dev/hda of=/dev/hdb bs=512 count=1This will copy the MBR from the Windows disk to the Linux disk. When you boot the Linux disk it should now boot properly assuming that your /etc/lilo.conf is correct. If not, then change the location of the Linux image line to /dev/hda and /dev/hda1, etc. and run /sbin/lilo to affect the change.Hope this works. :D
Link to post
Share on other sites
Hondanut

Ok thanks. You are correct on all accounts. I will give it a go a bit later tonight. Thanks for your help.

Link to post
Share on other sites
Hondanut

Just an update for those that have helped me along with this. I wasnt able to get the boot loader over to my linux drive. So I reinstalled the whole Mandrake 9.1 OS from scratch. I did this with the intended hard drive set as master. Worked perfectly. :lol: The boot loader is now on thie Linux drive, where I wanted it to be. I removed the boot loader from the Windows drive and now I have a system that will boot whatever system I want at the flick of a switch. What I have done here is the same as changing drives to make what ever hard drive I want to run as master. The conventional way to do this is to remove the case and manualy change the jumpers on the hard drives and then reboot. Now I dont have to do that. Its all done by a switch. When I boot to the windows drive it now boots straight to windows without a Linux style boot loader. When I boot The Linux drive I get the grub boot loader and the normal choices it gives you. Including booting windows. I could remove this choice if I wanted to. Linux still mounts the Windows XP partitions and are accessable. Windows of course cant see Linux. Ha Ha. Microsoft may be just a little to near sighted for their own good. :P Just a minor note. If the switch is flipped with the computer running nothing changes or happens till the next reboot. My kids gave me a little R&D with that one :P :D

Link to post
Share on other sites

Bravo HondanutLooks like you achieved your goal, I was afraid a new install of Mandrake would be the only option to get that bootsector on HD2. Anyway: ¨All's well that ends well¨.:lol: Bruno

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...