Jump to content
Sign in to follow this  
steel

Evolution in Slackware . . how ?

Recommended Posts

steel

thanks Bruno, i was orginally looking for Evolution and AfterStep for my slack, not sure if i can even get Evolution email, and friend asked me if i could get him a dvd iso, but i will take your advice and download just the regular cds for him, i am curious at one thing some sites there are 4 cds not 3 dunno why i thought that there were only 3 cds

Share this post


Link to post
Share on other sites
Bruno

The 4th CD used to have the extrs KDE 3.3 packages . . . but it seems they took them out, so there is nothing much left on CD4 ;) . . . . and CD 1- 3 will do fine for a default install. . . . . . he can always add packages later with URPMI and have all the software he wants :DThe nluug mirror ids the furum favirite because it gives a good fast steady download speed.:w00t: Bruno

Share this post


Link to post
Share on other sites
steel

yeah i use the nluug its great as for the 4th cd that explains things was reading of 4th being empty now i understand why lol as for the speed i get from some European countries makes me jealous of there 10 megabit per second ultra speed isp puts my broadband to shame ;) wooooohoo @ evolution your the man Bruno, i tried all the others but love evolution the best myself

Share this post


Link to post
Share on other sites
Bruno

I hope you will not run into too much dependency problems with Evolution . . it needs a good few Gnome libs . . . and Gnome is not Patrick's ( Slack ) favorite . . . ;) Bruno

Share this post


Link to post
Share on other sites
Bruno

As I expected . . . . . from Linuxpackages:

This package has a bunch of dependencies. You will need to install the following packages for this to work the packages marked with * are upgrades from before and need to be upgraded for this package as well..Evolution-data-server 1.0.2 *openldap-client 2.2.15gtkhtml3 3.2.3 *gal2 2.2.3 *gnome-pilotlibgpg-error 0.7libgcryptopencdkgnutlsgpgme 0.3.16libsoup 2.2.1 *gnome-spell (not required but enables spell checking)gnome-vfs 2.8.2You will also need a bunch of the gnome libraries from Slackware-10 also pilot-link and gnupg from the base sl10. If you have a standard gnome install you will be fine. For more information on the additional deps see the slack-required file. This is the latest stable release of Evolution and has many changes from the 1.4 version. Also included is NTP support in this package. Please ensure you have all the above deps and a fully patched Slackware 10.0 system.
Well, anyway it will give you a good way to spend the Sunday evening :DB) Bruno

Share this post


Link to post
Share on other sites
steel

i was thinking about deps myself :w00t: hmmm if you had time Bruno perhaps you could always do a lil tutorial how you set it up ;) i even installed thunderbird but i dont like it i perfer evolution myself even to kmail

Share this post


Link to post
Share on other sites
Bruno

Well, Steel . . . it is actually real simple . . you download the package and then you do:

# installpkg evolution-2.0.2-i486-1jim.tgz

and see what errors you get . . it will tell you exactly what you are missing . . then you get the missing package and install that first ( with installpkg ) and then try again . . to see the next dependency error . . . and get that one solved . . etc. etc. etc. . . . just as long as you do not get errors anymore and evolution gets installed :) :DB) Bruno

Share this post


Link to post
Share on other sites
steel

ohhh ok Bruno i was expecting something tougher hehe, sounds easy enough and whats the difference between this is as well? http://gnome.org/projects/evolution/download.shtml also i did what you said and i got this error checking for SunOS broken spool format... nochecking for libgtkhtml-3.1... Package libgtkhtml-3.1 was not found in the pkg-config search path.Perhaps you should add the directory containing `libgtkhtml-3.1.pc'to the PKG_CONFIG_PATH environment variableNo package 'libgtkhtml-3.1' foundconfigure: error: Library requirements (libgtkhtml-3.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.$ slocate libgtkhtml-3.1.pc/usr/local/lib/pkgconfig/libgtkhtml-3.1.pc$ slocate libgtkhtml-3.1/usr/local/lib/libgtkhtml-3.1.la/usr/local/lib/libgtkhtml-3.1.so/usr/local/lib/libgtkhtml-3.1.so.11/usr/local/lib/pkgconfig/libgtkhtml-3.1.pc/usr/local/lib/libgtkhtml-3.1.so.11.1.6/usr/local/lib/libgtkhtml-3.1.a/usr/local/include/libgtkhtml-3.1/usr/local/include/libgtkhtml-3.1/gtkhtml

Share this post


Link to post
Share on other sites
Bruno

Hi SteelThis is simple:There is a file called "/etc/ld.so.conf" add the line "/usr/local/lib/" to that file . . . then give the command:

# /sbin/ldconfig

And after that try again . . . :thumbsdown: :DWhat it does is: it adds the path where to look for libs to where pkg-config can find them . . :DB) BrunoPS : I will have to split this off from this thread Steel . . . . . . because it is about mandrake 10.1 CDs :hmm:

Share this post


Link to post
Share on other sites
trigggl
This is simple:There is a file called "/etc/ld.so.conf" add the line "/usr/local/lib/" to that file . . . then give the command:
# /sbin/ldconfig

Bruno,Would this be doing the same thing as:
$ PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig$ export PKG_CONFIG_PATH

I had this same problem with gphoto.

Share this post


Link to post
Share on other sites
steel

hi Bruno and Trigg well i did as you said and even updated the db and still tells me the same thing :thumbsdown: checking for libgtkhtml-3.1... Package libgtkhtml-3.1 was not found in the pkg-config search path.Perhaps you should add the directory containing `libgtkhtml-3.1.pc'to the PKG_CONFIG_PATH environment variableNo package 'libgtkhtml-3.1' foundconfigure: error: Library requirements (libgtkhtml-3.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.$ locate libgtkhtml-3.1.pc/usr/local/lib/pkgconfig/libgtkhtml-3.1.pcalso /usr/local/lib/ already in my /ld.so.conf file so i even added /usr/lib/pkgconfig then i updated db again and still cant see it same error :hmm:edit ...i even added a few lines and now my files looks like this $ cat /etc/ld.so.conf/usr/local/lib/usr/X11R6/lib/usr/i486-slackware-linux/lib/opt/kde/lib/usr/lib/qt/lib/usr/local/include//usr/local/lib/pkgconfig//usr/local/include/libgtkhtml-3.1/usr/local/lib/pkgconfig/libgtkhtml-3.1.pcstill cant find path :hmm:

Share this post


Link to post
Share on other sites
Bruno

Hi Steel . . that means you have to add "/usr/local/lib/pkgconfig/" to "/etc/ld.so.conf" too . . and run /sbin/ldconfig again . . . running "updatedb"does not help here :thumbsdown: ( just keep adding lines to directories with libs where the installer does not look for them.The installer checks only the paths that are mentioned in /etc/ld.so.conf . . . but at every line you add you have to run /sbin/ldconfig again.Hi GregNope that is not the same, that only corrects the path from /usr/lib/pkgconfig to /usr/local/lib/pkgconfig . . . what we do here is setting adding a path to all kind of libraries that are in /usr/local/lib in stead of /usr/lib ( the usual place ) where the installer expects them . . . . sure if there are even more libs in /usr/local/lib/pkgconfig/ we have to add that too to the /etc/ld.so.conf file where ALL the paths to the libs are stored . . . and ldconfig updates at every boot the path-setting ( you can even see it at boot in the boot-messages that ldconfig is running. ( So a reboot helps too ):hmm: Bruno

Share this post


Link to post
Share on other sites
Bruno
edit ...i even added a few lines and now my files looks like this $ cat /etc/ld.so.conf/usr/local/lib/usr/X11R6/lib/usr/i486-slackware-linux/lib/opt/kde/lib/usr/lib/qt/lib/usr/local/include//usr/local/lib/pkgconfig//usr/local/include/libgtkhtml-3.1/usr/local/lib/pkgconfig/libgtkhtml-3.1.pcstill cant find path :hmm:
That looks good . . . ( last 2 are useless though, but the /usr/local/include/ is essential !! ) but did you run "/sbin/ldconfig" after that ?? ( Or reboot ):thumbsdown: Bruno

Share this post


Link to post
Share on other sites
steel

hi Bruno i did both rebooted and ran /sbin/ldconfig .. i still get the same error checking for libgtkhtml-3.1... Package libgtkhtml-3.1 was not found in the pkg-config search path.Perhaps you should add the directory containing `libgtkhtml-3.1.pc'to the PKG_CONFIG_PATH environment variableNo package 'libgtkhtml-3.1' foundconfigure: error: Library requirements (libgtkhtml-3.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.$ cat /etc/ld.so.conf/usr/local/lib/usr/X11R6/lib/usr/i486-slackware-linux/lib/opt/kde/lib/usr/lib/qt/lib/usr/local/include//usr/local/lib/pkgconfig/

Share this post


Link to post
Share on other sites
tranquilo

Have you tried setting the $PKG_CONFIG_PATH ?this may work:export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfigif not... unset it.unset PKG_CONFIG_PATHGood luck.

Share this post


Link to post
Share on other sites
steel

thanks tranquilo i will give the exports a try as well, not sure why its not seeing it now

Share this post


Link to post
Share on other sites
steel

i ran trigggl

$ PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig$ export PKG_CONFIG_PATH

this is what i got checking for libegroupwise-1.0 >= 1.0.3... Requested 'libegroupwise-1.0 >= 1.0.3' but version of libegroupwise is 1.0.2configure: error: Library requirements (libegroupwise-1.0 >= 1.0.3) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

Share this post


Link to post
Share on other sites
tranquilo

You can check whether the PKG_CONFIG_PATH is set properly using the following:echo $PKG_CONFIG_PATHif its not set, set it using:export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfigwhich should set the PKG_CONFIG_PATH to /usr/lib/pkgconfig and usr/local/lib/pkgconfig unset using:unset PKG_CONFIG_PATHGood luck :P

Share this post


Link to post
Share on other sites
steel

thanks tranquilo, more notes addedthe error i am getting now is

checking for libegroupwise-1.0 >= 1.0.3... Requested 'libegroupwise-1.0 >= 1.0.3' but version of libegroupwise is 1.0.2

seems like i am just missing Evolution Data Server 1.0.3 now ... just downloading it now

Share this post


Link to post
Share on other sites
Bruno

Hi Steel,I see you're getting close . . . keep digging, you will get there ! :DB) Bruno

Share this post


Link to post
Share on other sites
steel

hi everyone this seems to be such an easy problem but i cant seem to figure it out yet ... this is the problem that having ... i can get email on slackware using evloution but when i try to reply to it this is what happens, ... i cant post my screenshot of it :P from what i gather i should have gnome-gtkhtml-editor in path ..because my errror message is the error message i get is "Cannot create composer window unable to activate the address selector control" # which gnome-gtkhtml-editorwhich: no gnome-gtkhtml-editor in (/usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin)# slocate gnome-gtkhtml-editor/usr/local/lib/gtkhtml/libgnome-gtkhtml-editor-3.1.a/usr/local/lib/gtkhtml/libgnome-gtkhtml-editor-3.1.la/usr/local/lib/gtkhtml/libgnome-gtkhtml-editor-3.1.so# $PATHbash: /usr/local/sbin:/usr/local/bin:/sbin:/usr/sbin:/bin:/usr/bin: No such file or directoryalso what is oafd ?

Share this post


Link to post
Share on other sites
Bruno

Hi SteelMaybe add to your "/etc/ld.so.conf" this line to: "/usr/local/lib/gtkhtml/" ( Run ldconfig after :P )And, just to be sure: add to your path: /usr/local/lib and /usr/local/lib/gtkhtmlB) BrunoPS: So you did get it installed did you ?? Bravo !!!!!!!! :P :D

Edited by Bruno

Share this post


Link to post
Share on other sites
Bruno

HURRAYYYYY !!!!Congrats Steel !!!!! Well done !:"> Bruno

Share this post


Link to post
Share on other sites
steel

thanks Bruno you helped me alot with your tips for linux explore :"> thanka again :">

Share this post


Link to post
Share on other sites
Bruno

You're welcome Steel . . . . anytime ! ;):"> Bruno

Share this post


Link to post
Share on other sites
Bruno

Not really advisable . . . it will mess up your libraries real bad . . . Mandrake has the MCC and adding a second package manager will mix up things and you will not be happy. . :DB) Bruno

Edited by Bruno

Share this post


Link to post
Share on other sites
steel

yikkkess ok thanks Bruno just that Dropline looks so nice ...so mandrake has to wait uh? :">

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...