Jump to content


Samba howto?


  • Please log in to reply
9 replies to this topic

#1 OFFLINE   zox

zox

    Multithreader

  • Forum MVP
  • 1,234 posts

Posted 14 May 2003 - 10:00 PM

Hi Bruno & co. :)I am fiddling with Mandrake again on my home server, due to not being able to configure samba properly on Suse.I went ahead and installed Mandrake 9.1 on my Athlon 600Mhz, (my home server) and everything went fine.On my main computer I am still using dual boot WinXP/Suse 8.2.During installation of Mandrake, I installed samba server, client and everything related.I updated it with about 160 Mbs of patches, etc.I configured Samba and share but for some reason I can't connect to it from my main computer.I am on a local network and I know I am making some small stupid mistake but you need experience to figure it out.I remember on WinXP when I first got it, I was banging my head on the wall untill I finally read somewhere how to share it on network, now it's a breeze to set it up.I am guessing it will be same with Samba.Again, I went through couple of books and found different solutions on how to setup Samba server, but very similar.I tried all versions but no success.I can see workgroup in "My Network Neigbourhood" but can't access it.On my Suse, I can't access it at all, I tried through "smb://192.168.0.3" and with GUI through "LinNeighbourhood" but again no success.What am I doing wrong?Thanks in advance!(I am not giving up that easy) ^_^

#2 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,448 posts

Posted 14 May 2003 - 10:59 PM

A couple of things you need to be aware of when setting up Samba. Any time you make editing changes to your /etc/samba/smb.conf file you will need to restart Samba. At a console you can type the command: service smb restart.For instance, hopefully you set your workgroup name correctly like so:workgroup = WORKGROUPNAMEserver string = BRIEF COMMENT ABOUT SERVERSamba requires that users be added in its own database. If you are lucky, your Samba install should have place this script file in your /usr/bin directory, mksmbpasswd.shRunning this command, cat /etc/passwd | mksmbpasswd.sh > /etc/samba/smbpasswd will create Samba users from your existing Linux users. Give only root rights to this file by typing chmod 600 /etc/samba/smbpasswdFor each user you want to give Samba access to you will need to create a password for them. For security reasons it is recommended that you use a different password then the Linux one for that user. Alternatively, you can be brave and give the Samba user the same password as your Linux user. Type this to create the password:smbpasswd username where username is the user. Make sure Samba is restarted by typing service smb restart.Make sure you edit the shares properly. For example to give each user access to their home directory uncomment these lines in your /etc/samba/smb.conf file:[homes]      comment = Home Directories      browseable = no      writable = yes      valid users = %S      create mode = 0664      directory mode = 0775Test it from SuSE by typing in a console window: smbclient //hostname/sharename -U usernamewhere hostname is the Samba host and sharename is the share you want to connect to. If you've enabled home directories then sharename would be the same as the username. If you see the prompt smb:\> then you are in. Type dir to get a directory listing. Also, make sure your firewall is allowing the smb protocol.

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#3 OFFLINE   zox

zox

    Multithreader

  • Forum MVP
  • 1,234 posts

Posted 15 May 2003 - 07:08 AM

Thanks Peachy for reply.I am at work and will be late home tonight so I'll let you know what happened.In the meantime, just to let you know, I was using SWAT for configuration and also manually editing smb.config file.I was under impression, that unless you specify external server for users/passwords samba will pick up users from system ??Well, I will go over my books again, but I am pretty sure that's what they say and no mention of your solution.I was trying also to setup samba  to be "USER", and "SHARE" but never could get even guest access.Thanks Peachy again and I'll let you know tonight. :(

#4 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,448 posts

Posted 15 May 2003 - 08:21 AM

zox, on May 15 2003, 07:08 AM, said:

I was under impression, that unless you specify external server for users/passwords samba will pick up users from system ??
Yes, but you have to create the database of Samba users. The default install doesn't do that; at least not in Red Hat. Good luck!  B)

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#5 OFFLINE   zox

zox

    Multithreader

  • Forum MVP
  • 1,234 posts

Posted 16 May 2003 - 06:54 AM

few, I hardly found my post deeply buried on 3rd page, from yesterday??This forum is getting really hot as it seems :)Peachy, no success.I am sure it's just user/permission thing as I can access my Apache server serving on TCP/IP, I created different workgroup just in case, and I can see different workgroup but "No permission to access it" B) I didn't have time to play with it more, I am waiting for Sunday, too much on a plate at the moment.I am not loosing my spirit, I am sure I'll get to the bottom of this, of course withthis forum's help B)

#6 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,448 posts

Posted 16 May 2003 - 11:40 AM

I've pinned this topic so it won't get lost. Is your firewall allowing smb:tcp traffic?

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#7 OFFLINE   zox

zox

    Multithreader

  • Forum MVP
  • 1,234 posts

Posted 16 May 2003 - 12:29 PM

I am not sure how to check that.I am runing software firewall on my PC under WinXP and no matter what I do, boot without firewall, disable/enable, add my machine as "full trusted", no help.I am not running any firewall on Linux as far as I know, how can I find out that??I am behind NAT hardware router/switch, but I don't think that is related since that is just for my internet connection.

#8 OFFLINE   zox

zox

    Multithreader

  • Forum MVP
  • 1,234 posts

Posted 16 May 2003 - 10:34 PM

It's working now Peachy.I have to backtrace all my steps but basically I just edited smb.conf and got rid of some security such as IP/subnet only and it worked.I must have had misconfigured it, or I did not setup my static IP home network properly  B) B) Anyway, from this point on I'll play a bit more, step at the time as long as I can access it propely :)Thanks Peachy again  :)

#9 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,448 posts

Posted 16 May 2003 - 10:37 PM

You're welcome! Glad to hear it's working for you.

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#10 OFFLINE   zox

zox

    Multithreader

  • Forum MVP
  • 1,234 posts

Posted 17 May 2003 - 07:08 AM

Yes, I've got rid of IP/subnet thing and "valid users = %S".One of these two or both were preventing me to access my samba share.I'll try later to see which one.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users