Jump to content

Lychee - not the fruit


abarbarian
 Share

Recommended Posts

Self-hosted photo-management done right

 

Lychee is a free photo-management tool, which runs on your server or web-space. Installing is a matter of seconds. Upload, manage and share photos like from a native application. Lychee comes with everything you need and all your photos are stored securely.

 

https://lychee.electerious.com/

 

I would have posted some screenshots of the program in action, however they have a very neat web demo to play around with so why not give it a go.

 

More info is available at the git.hub site. This includes some extra plugins and extensions and some useful information. Such as how to add a facility to take photos on your phone>send them to Dropbox >and then into your Lychee set up.

 

https://github.com/electerious/Lychee

 

To run Lychee, everything you need is a web-server with PHP 5.5 or later and a MySQL-Database. Follow the instructions to install Lychee on your server. Installation »

 

Most of the information on the net mentions " MySQL" like this excellent guide to setting Lychee up on Raspberry Pi.

 

Discovered thanks to the french forum dedicated to the Raspberry, Lychee is a lightweight and fast Photo Manager, easily insatiable on our favorite Raspberry (You can try it on this page). Need a database and a web server

 

http://www.pihomeserver.fr/en/2014/01/23/raspberry-pi-home-server-heberger-toutes-vos-photos/

 

For those of you that do not want to use MySQL you can use MariaDB as this guide on how to install Lychee on a Ubuntu VPS shows,

 

 

In this tutorial, we will explain how to install Lychee on an Ubuntu 14.04 VPS with MariaDB, PHP-FPM and Nginx. Lychee is an easy-to-use self hosted photo management system. This guide should work on other Linux VPS systems as well but was tested and written for an Ubuntu 14.04 VPS.

 

 

https://www.rosehosting.com/blog/install-lychee-on-an-ubuntu-vps/

 

If you want to be at the cutting edge of tech then you will want to install Lychee in a Docker container,

 

 

Docker has become more popular among developers as a platform to automate deployment of applications inside software containers within cloud servers. It is very easy for developers to deploy their applications on a Docker container, save the container image, and then, manually or automatically, deploy the application image in other Docker-enabled cloud servers without having to worry about the underlying operating system or environment settings.

It is possible to install Docker on a virtual machine running virtualization technology. In this guide, we will provide you with step-by-step instructions on how to install Docker 1.10.2 on a Ubuntu 14.04.3 LTS (64-bit) virtual machine.

 

http://www.servermom.org/install-docker-ubuntu-server/

 

The feminists out there will have noticed that the above guide was written by a female. Girl power at the cutting edge of life. :blissysmile:

 

There is a Docker image that is recommended by the creators of Lychee available here,

 

https://hub.docker.com/r/kdelfour/lychee-docker/

 

Here are a few comments by users of Lychee,

 

https://www.g2crowd.com/products/lychee/reviews

 

Lychee sounds like it may be a neat fit for me. So I will attempt to get an instance running in a Docker container on one of my Pi's. if I do so I will report back. Do not hold your breath. :breakfast:

 

Oh and do not confuse Lychee with lychee,js. :whistling:

 

https://lychee.js.org/

  • Like 1
Link to comment
Share on other sites

Well I used the HypriotOS v1.0.0 Blackbeard and used their hypriot/flash script

 

https://github.com/h...er-rpi/releases

 

https://github.com/h...aster/README.md

 

to see if I could get my Pi back in action.

 

I followed their instructions

 

 

Run flash http://downloads.hyp...-132854.img.zip

Insert SD card to your notebook

Press RETURN

Eject SD card and insert it to your Raspberry Pi - done!

 

but I had no sdb choice, that is my sd cards mount. Of course it would not show as it was not in the pc, I should have spotted that shouldn't I. So their instructions are not 100% correct.

I inserted a sd card but still no sdb showing. At the prompt I typed sdb and and away the program sailed giving me a sd card with hypriot on it.

Popped the sd into the Pi and lights flashed in wht looked like a normal pattern. Tried to

 

$ ssh pirate@black-pearl.local

 

Nothing. Tried to ping still nothing. Did a reinstall, pinged,ssh'ed still nothing. Not quite true as I got this

 

ping: icmp open socket: Operation not permitted

 

Seems there is a problem with Jessie Light and you have to reinsall on the Pi

 

sudo apt-get install --reinstall iputils-ping

 

Is this a similar problem with hypriot, does not matter as I can not access the Pi with a screen without a load of pfhaffing around.

Re-visited the hyriot site and found that a new version v1.0.1 was available, so am now downloading and installing via their flash script.

Hope this one works. :whistling:

Edited by abarbarian
Link to comment
Share on other sites

Hmmmmmmmmmm. I tried to connect to the black pearl with Vector linux which I have running on this Dell along with MX-15. I got the same response "connection timed out".

So I looked at the router to see what is going on. The router tells me that black-pearl is connected and it gives me an ip address for it, looks like the hypriot side of things is working.

On Vector ping seems to work ok so I have no idea what is wrong.

 

:'(

 

vector://home/abarbarian
root:# ssh pirate@black-pearl
ssh: connect to host black-pearl port 22: Connection timed out
vector://home/abarbarian
root:# ssh 192.168.1.3
ssh: connect to host 192.168.1.3 port 22: No route to host

 

 

vector:/~
abarbarian:$ ssh pirate@black-pearl
ssh: connect to host black-pearl port 22: Connection timed out
vector:/~
abarbarian:$ ssh 192.168.1.3
ssh: connect to host 192.168.1.3 port 22: No route to host

 

vector:/~
abarbarian:$ ping google.com
PING google.com (216.58.198.174) 56(84) bytes of data.
64 bytes from lhr25s10-in-f174.1e100.net (216.58.198.174): icmp_req=1 ttl=55 time=31.3 ms
64 bytes from lhr25s10-in-f14.1e100.net (216.58.198.174): icmp_req=2 ttl=55 time=31.7 ms
^C
--- google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 31.369/31.545/31.722/0.250 ms

 

Any ideas folks ????????????????

Edited by abarbarian
Link to comment
Share on other sites

Back in MX-15 and I still get the same results, checked the router and black-pearl is connected.

 

8nzAYT5.png

 

@reserve:~
$ sudo service ssh status
[sudo] password for bloodaxe:
[ ok ] sshd is running.
@reserve:~
$ ssh pirate@black-pearl.local
ssh: connect to host black-pearl.local port 22: Connection timed out
@reserve:~
$ ssh 192.168.1.3
ssh: connect to host 192.168.1.3 port 22: No route to host
@reserve:~
$ ssh pirate@black-pearl.local
ssh: connect to host black-pearl.local port 22: Connection refused
@reserve:~
$ ping black-pearl
PING black-pearl.dlink.com (92.242.132.16) 56(84) bytes of data.
--- black-pearl.dlink.com ping statistics ---
9 packets transmitted, 0 received, 100% packet loss, time 8063ms

 

I am confused ?????????? :'(

Link to comment
Share on other sites

I took the trouble to connect the Pi to me tv as I realised that even though hyriot has no X11 you still get text output on the screen. Shows how muddled me thinking is at present if I forgot that fact.

Anyways hypriot is running on the Pi.Ssh says it is running and ok. The router shows hypriot. Yet I still get the same results I get on Vector and MX-15 in that i can not connect the pc's through ssh.

 

At this point unless some one can help me out with some bandaid info I will have to put a hold on this project as I am in the middle of actually offering bids for property and me head is full of building repair costs etc etc. I started this project as it looked like hyriot would be an easy otb install and I could spend a bit of time relaxing by playing with something useful to me.Struck out there didn't I.

Is there something wrong with the hypriot so or is it something on my os ? Beats me.

:'(

Link to comment
Share on other sites

By gum I hate being stubborn :whistling:

 

Found some info from an outdated guide but it seemed relevant so I gave it a go.

 

Working from MX-15 I tried

 

@reserve:~
$ hostname -I
192.168.1.2 

 

Which tells me the ip of MX-15. Then tried the next step in the guide

 

@reserve:~
$ nmap -sP 192.168.1.2/24 | grep black-pearl

 

Which gave no output at all. So tried with sudo

 

@reserve:~
$ sudo nmap -sP 192.168.1.2/24 | grep black-pearl

 

Same result ie: nothing.

 

So does that info help anyone help me find a solution ? Please pretty please. :fish:

Link to comment
Share on other sites

Well I'll go to bottom of stairs.I just tried

 

@reserve:~
$ ssh pirate@192.168.1.4
pirate@192.168.1.4's password:

HypriotOS (Debian GNU/Linux 8)

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Mon Sep  5 16:27:34 2016
HypriotOS/armv7: pirate@black-pearl in ~
$ 

 

 

An voilà I have lift of :clap: I have tried that command before with no joy so have no idea why it works now. No matter I have a working Pi with hopefully a working instance of Docker.I have a feeling that all my problems were created by my muddled state of mind. Nothing to worry about there then :Laughing:

 

I think I deserve a round of applause.

 

xT8qBepJQzUjXpeWU8.gif

 

In between I have made a successful bid on a property. Hope that goes better than my computing. :breakfast:

Edited by abarbarian
  • Like 2
Link to comment
Share on other sites

Docker is up and running on the Pi via ssh.

 

HypriotOS/armv7: pirate@black-pearl in ~
$ docker pull pypi/lychee
Using default tag: latest
latest: Pulling from pypi/lychee
674ded4e0a75: Pull complete
a3ed95caeb02: Pull complete
3fe37ed373c9: Pull complete
ddf1745d8563: Extracting 35.78 MB/42.32 MB
b9ef83e0e547: Downloading 22.7 MB/128.5 MB
411d39b1247d: Download complete
5b767d10beb4: Download complete
25f5fdcb3950: Downloading 16.32 MB/22.88 MB
a0ced0754594: Download complete

 

I found a pi compatible version of Lychee

 

https://hub.docker.com/r/pypi/lychee/

 

at least I hope it is. It is ten months old so will it work ? Should I have started my Docker adventure with something tried and tested ? Nah jump in at the deep end and swim is my moto :breakfast:

 

Hmmm I could not get the pypi/lychee to work with docker on the pi. Looks like it made for a different architecture. Also it may not even be the photo management program I thought it was as on the programs web site it states

 

"I'm Lychee. A static blog generator."

 

Hmmm hyriot does not have python3-pip installed as it is based on Jessie Lite so I am downloading/installing it to the pi to see if that will help.If all else fails I'll have to make my own docker image for Lychee.

Now won't that be fun. :drooling:

Edited by abarbarian
Link to comment
Share on other sites

Turns out that Lychee docker container I found was not for arm architecture. So I will have to come back to this later as I am playing at building containers at the moment. The aim is to run a Ghost hosted blog from the Pi.

Have found a Ghost/arm container and it runs ok. Almost got the hang of building a container but not 100%. I'd like my own Ghost customised container to use as a base whilst I learn how to use Ghost.

Having to finally get to grips with networking and such, managed to give the Pi a static ip via the router. Chose the router route as there are several different ways of doing it by configs and the three ways I attempted all gave instructions for files my os does not have.

Fiddled that much I borked the Hypriot os good an proper.

Bought a domain name and am going to use these folks for a DNS service but I need to ask some questions around that so I'll start a separate thread for that.

:breakfast:

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...