Jump to content

HP 2540 printer problems !!!!


Recommended Posts

I have been forced to buy a new printer as the print quality from the local library is utter rubbish and you can not form a print queue and have to set up and print each page separately. Also when you connect to IE, note no FF, at the library you are given a "this is an outdated browser please install a secure and up to date browser" notice. What a total waste of tax payers money.Solution take out the pretend IT experts presently hired stand em up against a wall and shoot em, then they could hire me and give me a similar huge salary and I can guarantee I could provide a better service.


Rant over. :angry2:


Here is a link to the printer manual, it is quite a large file,




The printer has USB connection and two types of wireless connection. Below is a manual page showing information on WIRELESS DIRECT. As far as I can see you can connect to a local computer with wireless capabilities directly without going through a router.




More information for WIRELESS DIRECT,




The printer also supports WPS which my router has a button for.




Here is picture of some information on the PRINTER program supplied with Makulu.




In a fact sheet on WIRELESS DIRECT you can type"http//:1962.168.223.1" in a browser to customise settings.However I could only access this page if I disconnected my pc wireless and connect to the printers wireless connection (see pic 4 bottom left)




Another page from http//:1962.168.223.1




Now I can get the lights on the router and the printer to show a connection using WPS but can not print. I am a tad wary of using WPS as I think it is has weak security though I am not sure on this point.


I can connect to the http//:1962.168.223.1 web page if I set up the printer on its own wireless connection. Trying to connect through my normal gets me nowhere. Using www.http//:1962.168.223.1 gets me to the page but apart from a header it is blank and unresponsive.


To connect to the http//:1962.168.223.1 on its own connection using FF threw up a UNTRUSTED CONNECTION message, I gave the page, dubiously, a trusted status and reviewed what was on offer. It seems that I have WIRELESS DIRECT set up with security it has its own configuration page. there is also a wireless connection page and this shows no connection. I did not set this up due to untrusted warning, as it asks for my routers name and password.


So can anyone help me to set up the printer so I can use wireless directly from my pc without using the router ?


If this is not possible is WPS safe to use ? an can someone help me set it up ?


Or do I bite the bullet and use a long cable ? This would be a right pain as I could have saved loot by buying the usb only printer.


Erik the failed geek :'(

Edited by abarbarian
Link to comment
Share on other sites

I have an HP wireless printer Envy 5530. I installed the Windows printer software on the desktop, which basically allows me to configure the printer using a browser. I then manually went in and set the wifi IP for the printer at (the gateway on my router is I then made sure the IP in the computer software was I believe the manual settings on the printer can be accessed in the Advanced area of the printer display.

Then I did the same on a Windows 7 laptop, With a Linux desktop on the LAN I just set it up with HPLIP. All 3 computers use the same wifi printer. The reason I set the IP manually was to get it outside the DHCP range of my router.

Edited by raymac46
Link to comment
Share on other sites

Well I checked that the version of HPLIP that comes with Makulu was ok for my printer. Ran the "hp-setup" command and it ran and seemed to set up ok. There is an icon on the task bar as you can see in the picture and it tells me that the printer has printed several jobs which I set it to do. Problem is nothing has happened at the printer, no prints appeared, no printing noise, nowt.


I have two other printers set up and working with this Makulu, trouble is they both have terrible print quality due to semi blocked jets. I have tried several times to clear the jets and they are printing the best they can but I need good quality printing that is why I bought the HP.





I am utterly fed up of buggy stuff that does not work. I have wasted nearly the whole weekend on stuff that plays up and does not do what it says on the tin. Hacked of does not describe how I feel. :'(

Edited by abarbarian
Link to comment
Share on other sites

I assume you've tried pinging the printer if it's on the LAN. I can ping mine with no problem.

HPLIP has a program in Linux Mint at least called hplip-gui that gives you the HP toolbox. I just used the Printers item on the LM17 menu and it found the printer no problem. This was after I had it configured on the LAN and working in Windows. The Linux part was the easiest.

Link to comment
Share on other sites

I assume you've tried pinging the printer if it's on the LAN. I can ping mine with no problem.

HPLIP has a program in Linux Mint at least called hplip-gui that gives you the HP toolbox. I just used the Printers item on the LM17 menu and it found the printer no problem. This was after I had it configured on the LAN and working in Windows. The Linux part was the easiest.


Hmm I recon you are incorrectly crediting me with networking experience and the ability to use a brain.


I gave up on the wireless aspect as me life is in turmoil at present and all I need is the ability to print at home.


So I plugged in a usb cable. Yay it worked , then it did not, then it refused to do anything. CUPS I thought that is what I am missing. So I did the configure bit and yay it worked, then it did not. Switched printer off then on and yay it worked...........guess what came next ?


So had to do some more research and found the Arch Wiki which is where I should have looked in the first place. Mind you I had to remember about CUPS first.Nevermind all that.The wiki mentions uninstalling HPLIP and reinstalling and fiddling with CUPS I'll have to read up again to get the full detail.I get the feeling that this routine will solve my problems.I hope so anyway.


Ta fer the input an I'll post if I get a working set up. :breakfast:

Link to comment
Share on other sites

I wish I could be of more help. I have fiddled around with CUPS when I had a non HPLIP compliant printer, but lately I've made sure to get HP. That plus using a fairly mainstream distro like Linux Mint has made printer configuration so easy I never even think about it any more., Josh probably can help you more than I can if it's an Arch install you are dealing with.

Link to comment
Share on other sites

Ta again for the concern.


I have two Epsom printers that I have managed to set up and use with CUPS both on Arch and Makulu, they were both usb connected.


I am trying to set up on Makulu as me Arch is dead caused by hardware failure. I sort of have everything working but then it all stops so I recon I just need one tiny tweak somewhere to have it working properly.

The Arch Wiki has loads of info relevant to other os's. For example I managed to print via the command line in Makulu following it but then it stopped again.


I have cleared some of the immediate problems in me life today so now have a clearer head and will have a proper try at setting up later in the week.


It is typical ain't it. I have had several pc's working just fine for a few years and basically have just been playing with them. Time comes when I need a working pc and one fails completely and the other has two os's running but one is crippled and the other has gone bottom up, ie: it fires up then tells me Cinnamon has crashed and produces a black screen that I can do nothing with,can not even get to another tty. Blooming marvellous. :breakfast:

Link to comment
Share on other sites

  • 2 weeks later...

Well I go the printer working from a usb cable connection in a stable fashion. No wireless yet I'll have a look into that later on.


I deleted the printer from the Cups website and deleted the HPLIP program on the pc intending to reinstall HPLIP and then see if I could get it to work.However I could not install HPLIP as I kept getting 404 errors when I tried to install via Synaptic. So I gave up and added the printer to Cups and blow me it just worked and kept on working.


So I at least have a partial solution, a workable one. Mr Spooky is fascinated by the noise and the paper flying out of the printer when I print.I leave the paper output slide half in so the paper drops to the floor just so I can see what Spooks does. :Laughing:

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...