Jump to content

I have had it with Pulse Audio!


Recommended Posts

Guest LilBambi

OK, as you all know, I run pure Debian Wheezy.

 

I got sick and tired of having the audio be flaky so I did the following to get rid of Pulse Audio:

 

in a true TTY command line as root:

 

apt-get update

apt-get remove pulse audio

apt-get alsa base

apt-get autoremove

reboot

apt-get upgrade

 

logged out of root and also in command line:

 

alsamixer

 

and set my settings.

 

Lots more available control now on the Mixer in the system tray area!

 

Yea!!!!

 

And no more stupid Pulse Audio tricks!!

Link to post
Share on other sites
securitybreach

Yes, I absolutely hate Pulse Audio with a passion. I always disable (or remove if I can) and install the good ole tried and true Alsa.

  • Like 1
Link to post
Share on other sites
Guest LilBambi

Me too! I truly gave it a try. But it is just not ready for prime time and I am frustrated that so many distros are using it as the default.

Link to post
Share on other sites
V.T. Eric Layton

Piss Audio is just bad. ALSA is always the way to go in GNU/Linux.

  • Like 2
Link to post
Share on other sites
Guest LilBambi

Totally agree!

 

I have been around long enough to remember the 'lag' that used to happen when the Alsa audio server first started, but at least it worked right! Unlike Pulse Audio!

Link to post
Share on other sites
V.T. Eric Layton

Somewhere around here there is a thread where Bruno and I are pulling our hair out trying to find out how to fix some issue I was having with Pulse Audio in some distro that I don't even remember now (not Slackware). We finally gave up. I purged the distro of all things Pulse Audio and enabled ALSA. That was the best solution of all; something which Bruno recommended from the beginning, but I have a hard-headed streak sometimes. ;)

  • Like 3
Link to post
Share on other sites
amenditman

We finally gave up. I purged the distro of all things Pulse Audio and enabled ALSA. That was the best solution of all; something which Bruno recommended from the beginning, but I have a hard-headed streak sometimes. ;)

Boy, does that sound familiar. I don't think you are alone in that around these here parts.

I've been fighting with an internet only sound problem off and on for about 4 months. Mostly off, just couldn't get motivated to track it down and whip it.

Today was the day, apparently.

 

Looking through my notes, not very organized but they do exist, I found that I had installed Pulse Audio while trying to set up Steam. That is when the entire problem started.

 

I uninstalled everything Pulse and Steam related. No joy.

I started looking at multiple versions of flash/flashplugin and thinking here is the problem.

I uninstalled the 32 bit flashplugin.

Finally remembered that Chrome(ium) and Firefox both ship with internal support for flash and uninstalled the 64 bit flashplugin.

 

Yay! I have sound on the browser again.

 

If I get brave, I might re-install Steam. But I don't know why, I don't use it much.

  • Like 2
Link to post
Share on other sites
V.T. Eric Layton

Well, seems as though you've accomplished something today in spite of yourself. ;)

Link to post
Share on other sites
Guest LilBambi

Yeah, I finally had just had it with Pulse Audio on the computer where I do a lot of audio and video. It's just not worth the aggravation.

 

I will likely do the same with my other two Debian Wheezy installs as well. I can almost guarantee it. ;)

Link to post
Share on other sites
securitybreach

Boy, does that sound familiar. I don't think you are alone in that around these here parts.

I've been fighting with an internet only sound problem off and on for about 4 months. Mostly off, just couldn't get motivated to track it down and whip it.

Today was the day, apparently.

 

Looking through my notes, not very organized but they do exist, I found that I had installed Pulse Audio while trying to set up Steam. That is when the entire problem started.

............................

If I get brave, I might re-install Steam. But I don't know why, I don't use it much.

 

Odd as steam does not require pulseaudio at all (I use steam all the time and do not have pulse installed):

comhack@Cerberus ~ % pacman -Qi steam

Name : steam

Version : 1.0.0.47-2

Description : Digital distribution client bootstrap package

Architecture : x86_64

URL : http://steampowered.com/

Licenses : custom

Groups : None

Provides : None

Depends On : bash desktop-file-utils hicolor-icon-theme curl dbus freetype2 gdk-pixbuf2 ttf-font zenity lib32-libgl lib32-gcc-libs lib32-libx11

Optional Deps : lib32-ati-dri: for open source ATI driver users

lib32-catalyst-utils: for AMD Catalyst users

lib32-intel-dri: for open source Intel driver users

lib32-nouveau-dri: for Nouveau users

lib32-nvidia-utils: for NVIDIA proprietary blob users

lib32-flashplugin: for flash video [installed]

lib32-alsa-plugins [installed]

Required By : None

Optional For : None

Conflicts With : None

Replaces : None

Installed Size : 2282.00 KiB

Packager : Daniel Wallace

Build Date : Tue 22 Apr 2014 08:27:16 PM CDT

Install Date : Wed 23 Apr 2014 10:45:44 AM CDT

Install Reason : Explicitly installed

Install Script : Yes

Validated By : Signature

Link to post
Share on other sites
amenditman

I didn't say it was required, just that I installed for some unknown reason when installing Steam.

The beginning of all sound related problems = Pulse Audio.

  • Like 1
Link to post
Share on other sites
securitybreach

I didn't say it was required, just that I installed for some unknown reason when installing Steam.

The beginning of all sound related problems = Pulse Audio.

 

Ah ok B)

Link to post
Share on other sites
raymac46

Strangely I haven't had major problems with Pulse Audio at all in any mainstream distros I've installed (like Mint.) With Arch you just use ALSA anyway - although I had trouble there even with ALSA, because my video card kept trying to install a HD driver that stepped on the basic sound module in my old PC. As far as Steam goes, I have that on a Windows machine.

Edited by raymac46
Link to post
Share on other sites
V.T. Eric Layton

See! I knew there was at least one person in the world who had no issues with Pulse Audio. ;)

 

Me too... Steam on MS Windows. :yes:

Link to post
Share on other sites
amenditman

On Arch I use pacman to find all installed pulse audio files and dependencies.

Then deleted them. Easy peasy.

Link to post
Share on other sites
Capt.Crow

I get all audio except Skype echo/test service . No sound. I can raise the Alsa mixer , capture +1+ 2 no adjustment.input source ditto head.. the same..

Edited by Capt.Crow
Link to post
Share on other sites
Guest LilBambi

Maybe use your package manager to remove Skype and then reinstall Skype.

 

Skype is not as smart as it used to be, or as smart as it thinks it is. Maybe it didn't get the message about the audio server change?

 

Don't forget to delete any dot files/folders related to Skype in your home after removing Skype.

 

You might even be able to close Skype fully and remove the dot files/folders and reopen Skype and get it to re-read your system for audio.

 

It's a thought...

Link to post
Share on other sites
Capt.Crow

Its failed again . with no reprieve .

 

Pulseaudio is gone . Still have Ear candy.. Had a look at that . Alsa shows up there as does Skype. I've set both to voip . Still no sound. But Kde 4.......? {not sure here} plays the Skype sounds when clicked on in their folder.

Link to post
Share on other sites
Guest LilBambi

It's a setting somewhere... Maybe remove Skype and Ear candy via apt-get or other package manager as appropriate and then reinstall them now that you are using only Alsa.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...