Jump to content

Preferred application in XFCE not persisting


Neil P
 Share

Recommended Posts

In yet another of what I'm sure are simple questions:

 

I am using XFCE4 (4.10) as my desktop environment in Arch. When I click on the "Web Browser" shortcut in the dock, it asks, every time, what application to use. I want it to use google-chrome. I select it. On startup, Chrome says "Chrome isn't your default browser, would you like it to be" (or whatever the message is), I say yes, make default. On subsequent relaunches, I go through the same thing. The setting never sticks. Setting it through Settings -> Preferred Applications doesn't matter either. What am I doing wrong? Is it a permissions thing? I don't even know where to look. Searching google just takes me to the documentation on how it's supposed to work.

 

:(

Link to comment
Share on other sites

securitybreach

I do not know how to do graphically but try running this command as user to set chrome as the default browser:

 

xdg-settings set default-web-browser google-chrome.desktop

Link to comment
Share on other sites

Hmm. I ran the command and shut down Chrome and tried to launch it. The set preferred application dialog came up again. I picked Chrome and closed it. Launched again, and this time Chrome launched. I don't know if it's set default. I'm going to try starting xfce again and see if it works.

Link to comment
Share on other sites

securitybreach

Hmm. I ran the command and shut down Chrome and tried to launch it. The set preferred application dialog came up again. I picked Chrome and closed it. Launched again, and this time Chrome launched. I don't know if it's set default. I'm going to try starting xfce again and see if it works.

 

Hopefully that fixed it for you :thumbsup:

Link to comment
Share on other sites

I think it worked. I restarted xfce and it still worked, and I even rebooted and it worked. Chrome doesn't see itself as default (it still pops up the message) but it launches each time. Thanks!

Link to comment
Share on other sites

securitybreach

I think it worked. I restarted xfce and it still worked, and I even rebooted and it worked. Chrome doesn't see itself as default (it still pops up the message) but it launches each time. Thanks!

 

Try going into the Chrome settings and click the box under Default Browser.

Link to comment
Share on other sites

Try going into the Chrome settings and click the box under Default Browser.

Ok. It seems that Chrome somehow borks it. Setting it in Chrome is what causes the selector to come up when I launch "Web Browser". So I told Chrome to never ask me.
Link to comment
Share on other sites

securitybreach

Ok. It seems that Chrome somehow borks it. Setting it in Chrome is what causes the selector to come up when I launch "Web Browser". So I told Chrome to never ask me.

 

Sounds like an issue with your Xfce version but I dunno. As long as it works, whatever :thumbsup:

Link to comment
Share on other sites

So, is it OK now, Neil?

Yeah, it seems to be working fine now. The problem, I guess, was with Chrome trying to set itself as default. Once I set it in XFCE and ignore Chrome itself, it works.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...