Jump to content
Sign in to follow this  
RSX-S_Hfx

Win XP Pro and Remote connections

Recommended Posts

RSX-S_Hfx

Hi, I'm using Win XP Pro at home and Windows 2000 Pro at work. I make remote connections from work to home using the XP remote connection tool from the CD. I should also note that I have both my work and home PC set up for a left handed mouse (i.e. click is right mouse key, right click is left mouse key)The problem I am experiencing is that in the remote connection window, the mouse reverts back to a right handed mouse configuration and I can't see how to stop this. This is getting very confusing as well as highly annoying. Anyone have any ideas?Thanks

Share this post


Link to post
Share on other sites
Guest ThunderRiver

Is there any person in your home right handed?What type of account you access from work to home? Administrator?I haven't had such problem yet though I am bidexterous. Sometimes it does get confusing, but for remote connection, the host machine that you try to access will use the default setting that you set, which in this case lefty. Now, if there is anyone in your house that is right handed, it might change the setting back and forth. Well, I know, it has always been a long battle between right handed and left handed..oh well :)

Share this post


Link to post
Share on other sites
imranj

Interesting issue, but what's the solution for such switching from left to right......would setting up a VPN connection might help out......or if i am righti think their is a option in RDPC where u specify what type of mouse connection u want.not sure :D by the way whats your mouse- brand.......i did test a Remote connection with my pal, we both had a right had mouse so i never encountered such a issue,Scot can u throw any light on it? :D

Share this post


Link to post
Share on other sites
Scot

I keep meaning to set up Remote Desktop Web Connection here in SFNL Labs. With two forms of broadband and two networks, and I can make like I'm logging in somewhere else to test stuff just like this. But I haven't gotten around to it.Remote Desktop Connection (same idea, but not over the Internet) is very similar but not the same, so what I'm about to say may not apply:1. When you remotely access, you take on many of the settings and controls of the target computer. So if the computer you are remotely accessing has right-handed mouse, you are going to have a right-handed mouse while you are connected to it. You should be able to open the Control Panel and change that though. It won't change you locally, but will change the setting on the host computer.In other words, I just ran a test with RDC. I changed the mouse setting on the host computer to left-handed. It stayed left handed for me when I remotely accessed it. So I'm not duplicating your problem (but note the caveats about the different software I'm using).2. The RDC dialog does NOT have an options setting for mouse buttons that I can find.But I think I know what the cause of the problem is: Windows 2000. I know for a fact that Microsoft greatly extended for Win XP the set of controls that can be managed with Terminal Services/RDC. My bet is that Windows 2000 Terminal Services don't provide this mouse-button functionality, even though Windows XP's Remote Desktop (they renamed it) does. If I'm right about that, you should be able to go back the other way, using your Win2K machine to remotely access your Win XP Pro machine while retaining your left-hand mouse settings. To prove that to yourself, you would need to download and install this XP version of the RDC client on your Windows 2000 Pro machine:http://www.microsoft.com/WINDOWSXP/pro/dow.../rdclientdl.aspHope this helps. Bottom line: If I am right, the only solution I'm aware of would be an upgrade to XP for your Win2000 box at work. It is possible that Microsoft has released some sort of upgrade or patch for Win2K Terminal Services that I'm not aware of though. You might try searching the Microsoft Knowledgebase:http://support.microsoft.com/default.aspx?...N-US&pr=kbinfo&For more on Remote Desktop Connection, see this Scot's Newsletter article:http://www.scotsnewsletter.com/29.htm#xptut-- Scot

Share this post


Link to post
Share on other sites
Scot

I read the question and my answer again, and there are some things that don't add up in my answer.First, I just tested RDWC with two XP PCs and got the same results. Mouse button orientation did get conveyed properly. (I haven't had time to set up Win2000 to test it with XP though. And I do suspect that may be where the problem lies.)I had it mixed up, though. I thought you were going from home to work, not work to home, when the problem occurred.Bottom line, I did some searching in the Microsoft Knowledgebase. In Remote Assistance -- yet another variant of this technology -- there is an acknowledged problem that "conflicting orientation settings can result in the functionality of the right and left mouse buttons being reversed." That seems to be the case when the local and remote mice are configured oppositely. Here's the Microsoft doc:Unexpected Mouse Behavior During a Remote Assistance Sessionhttp://support.microsoft.com/default.aspx?...kb;en-us;305405You might want to try reversing your Win2K mouse in advance of RDWC connecting just to see if it reverses back.RSX-S_Hfx, if you're still there, tell me about how you configured your Win2000 computer (if, in fact, you did anything at all) to access your Windows XP computer.I am interested in this problem. But I begin to think it may be something that can't be fixed. And, again, that may be due to the Win2K to WinXP match up.-- Scot

Share this post


Link to post
Share on other sites
RSX-S_Hfx

First off, I'd like to say thanks for the replies and sorry for taking so long to get back to you.I've tried all the suggestions you've made, nothing has solved the problem though. Form the links Scott has posted, this may be one of the many inherent "features" of the windows world that is not really a big deal, just a little frustrating.Scot, there is really nothing special about my setups, either at home (XP Pro) or work (W2k Pro). Both are set to use a left handed mouse, accounts on both have administator rights, and I am connecting from work (W2k Pro) to home (XP Pro) with the Remote Desktop Connection client.As far as configuring W2k to connect to XP, I did nothing more than install the RDC client from the XP CD on my work machine and enter the appropriate settings (IP, username, bandwidth, etc, etc).Thanks again for the help

Share this post


Link to post
Share on other sites
Scot

Yeah, I think it's one of those "have to live with it" problems. I think if they ever upgrade you to XP or beyond at work, the problem will go away.-- Scot

Share this post


Link to post
Share on other sites
LilBambi
Yeah, I think it's one of those "have to live with it" problems. I think if they ever upgrade you to XP or beyond at work, the problem will go away.-- Scot
Scot --Is this what you have been asking M$ for specifically, or is this another angle of the same problem? This is a new KB article.Files on Network Shares Open Slowly or Read-Only or You Receive an Error Message
SYMPTOMSYou may experience any of the following symptoms:When you copy a file over the network in Windows XP, if the source file is located on a Windows 2000-based network share, you may receive either of the following error messages: File or network path no longer exists. No network provider accepted the given network path.When you try to open a file from a network share, the file may take a long time to open.You may receive various error messages, or other problems may occur, when you use a program that opens and closes files, or creates temporary files, on a Windows 2000-based server with Server Message Block (SMB) signing enabled.A file that you open over the network is opened as read-only, or a sharing violation occurs, and you must save the file locally to make changes. This may occur even if your permissions are set to Full Control for both the share and the volume that uses the NTFS file system, and no other user has the file open. In this case, you may receive one of the following error messages: File in use: Filename is locked for editing by username. Click 'Notify' to open a read-only copy of the document and receive notification when the document is no longer in use.This command is not available because the document is locked for editing.The document Filename is locked for editing by another user. To open a read-only copy of his document, click...File is locked for editing, do you want to open a read-only version of the file.Cannot open Filename on network share. Make sure a disk is in the drive you specified.Access is denied. The file may be in use by another application.Programs such as Excel or PowerPoint may open two files successfully but display a "Read-Only" error message when you open a third file.Network programs that rely on heavy network file input/output (I/O) may seem to stop responding (hang), or delays may occur when you open or close files (because "Oplock Break" requests are ignored).Problems may occur when Windows applies group policies or runs logon scripts.You can save a Microsoft Office file by using the same file name only after you have the file open for at least 30 minutes.You may also receive other error messages, depending on the program that you are using. For example, you may receive error messages that indicate that a file is already in use or can be opened only as read-only.
M$ outlines a path of things to resolve these issues on the page.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...