Jump to content

ALMOST "Powered by SuSE"


Recommended Posts

GolfProRM

Since my second harddrive (4 gig) died, ruining my Mandrake installation, I decided to use the Linux partition I had on my main drive to install SuSE... Couldn't get connected to the DHCP server from the boot disc, so just FTP'ed the whole installation stuff and installed it locally from my harddrive... Got it up and running with no problem, except that I can't connect to the internet. I've got a cable connection, direct connected to the cable modem... using RealTek8139 card (had no troubles installing the card). I noticed that I am getting connected to the DHCP server (I've got an IP), but I still can't connect. Very interesting distro, quite a bit different from Mandrake.... would like to give it a whirl, but can't connect! <_<

Link to post
Share on other sites
GolfProRM

Thanks for the help quint, but I'm using the driver that's supposed to work with Kernel V. 2.4... That's the driver that SuSE defaulted to... I've tried removing everything and resetting all the settings/connections, but to no avail...

Link to post
Share on other sites
Peachy

Try the 8139too driver. You say you have an IP. Can you confirm with ifconfig from a console? Have you tried ping?

Link to post
Share on other sites
GolfProRM

using the 8139too driver (that's what I meant above, guess I wasn't clear)... ifconfig shows I have an IP, but I can't ping anything (not even my ISP)

Link to post
Share on other sites
Peachy

Okay, I think I know what your problem might be. Your cable ISP most likely provides you with a hostname when you use DHCP. Apparently, SuSE by default does not have the dhcp client set to accept the hostname provided to you.. No hostname, no internet.To check this, run YaST2, select System and then Editor for /etc/sysconf file. Another YaST2 window pops up. Select network and then drill down until you see DHCP>DHCP client>DHCLIENT_SET_HOSTNAME and make sure it says YES

Link to post
Share on other sites
Peachy

Bruno,I thought of that too, but Mike's setup is slightly different; his machine isn't directly connected to the cable modem. If it's the firewall why would SuSE default to block DHCP traffic if the user selects DHCP client setting for networking. Hence I don't believe it's the firewall because my SuSE is set to accept a dynamic IP address and it works fine.

Link to post
Share on other sites
Bruno,I thought of that too, but Mike's setup is slightly different; his machine isn't directly connected to the cable modem. If it's the firewall why would SuSE default to block DHCP traffic if the user selects DHCP client setting for networking. Hence I don't believe it's the firewall because my SuSE is set to accept a dynamic IP address and it works fine.
Sounds logic to me Peachy, you have a point there !:unsure: Bruno
Link to post
Share on other sites
GolfProRM

Okay... had the DHCLIENT_SET_HOSTNAME set to yes already (tried it both ways) and still no luck... disabled the firewall completely and it didn't matter...when it boots and tries to connect to the DHCP client, it doesn't seem to get it in time to report it during the boot... (says DHCP . . . . . . No IP Address yet... backgrounding).One weird thing, when I booted to it this morning, Konqueror opened up (didn't shut Konqueror down when I booted back to windows), and yahoo's page came up... All fine and dandy, but wouldn't connect anywhere else... very weird...Here's my ifconfig file... blocked out all the x's, but do show an IP. Not sure aobut the local loopback thing, but have tried connecting with it both enabled and disabled...eth0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx inet addr:xx.xxx.xx.xx Bcast:255.255.255.255 Mask:255.255.255.224 inet6 addr: xxxx::xxx:xxxx:xxxx:xxxx/64 Scope:Link UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1 RX packets:664 errors:0 dropped:0 overruns:0 frame:0 TX packets:12 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:100 RX bytes:41712 (40.7 Kb) TX bytes:3470 (3.3 Kb) Interrupt:11 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:71 errors:0 dropped:0 overruns:0 frame:0 TX packets:71 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:5197 (5.0 Kb) TX bytes:5197 (5.0 Kb)

Link to post
Share on other sites
Peachy

Ryan,Try typingifconfig down eth0to bring down the interface. Then type:ifconfig up eth0to bring it up, then type ifconfig again to see if it took a new IP address.lo is your loopback interface; it is always there and using 127.0.0.1You said you disabled the firewall? That will eliminate one variable, anyway.

Link to post
Share on other sites
GolfProRM

Peachy... I've tried that a couple times and it doesn't seem to change anything... the address it's showing in SuSE is the same one I have in Windows... I've rarely had my IP change here on our system... I had the same IP for 3 months at my old place (just changed when I moved).Firewall is disabled... still no change in status...

Link to post
Share on other sites
Peachy

Okay, from a console type:ping -a localhostand you should get an echo reply from the localhost, where the -a switch tells ping to resolve hostnames. The response should look similar:

PING your linux hostname (127.0.0.1) 56(04) bytes of data.64 bytes from your linux hostname (127.0.0.1): icmp_seq=1 ttl=64 time=1.20 ms

etc...Now see if your hostname matches your Windows hostname when you run ipconfig /all in XP's command line. If they aren't the same then set your Linux hostname to be the same as your Windows one. You can do this by editing your /etc/hosts file and placing the hostname on the 127.0.0.1 inserting it just before the localhost value so it looks something like:

127.0.0.1          host.domain  localhost localhost.localdomain

Link to post
Share on other sites
Peachy

Ryan,By any chance, is your ISP using a proxy server? Also, take a look in your /etc/resolv.conf file and make sure the nameserver entries are your ISP's DNS servers.

Link to post
Share on other sites
GolfProRM
Ryan,By any chance, is your ISP using a proxy server? Also, take a look in your /etc/resolv.conf file and make sure the nameserver entries are your ISP's DNS servers.
Peachy, no Proxy server... I'll have to take a look at the /ect/resolv.conf file when I boot back again... (it's a pain when I have to reboot everytime to try something... wish I had a router instead of ICS with my second computer :(Anyway... here's my /etc/hosts file... I had to change the 127.0.0.1 to what you see below.. it originally was just localhost... did I do it correctly?
## hosts      This file describes a number of hostname-to-address#            mappings for the TCP/IP subsystem.  It is mostly#            used at boot time, when no name servers are running.#            On small systems, this file can be used instead of a#            "named" name server.# Syntax:#    # IP-Address  Full-Qualified-Hostname  Short-Hostname#127.0.0.1 golfpro.xxx.xx.com localhost localhost.localdomain# special IPv6 addresses::1          localhost ipv6-localhost ipv6-loopbackfe00::0      ipv6-localnetff00::0      ipv6-mcastprefixff02::1      ipv6-allnodesff02::2      ipv6-allroutersff02::3      ipv6-allhosts127.0.0.2    golfpro.xxx.xx.com  golfpro
Now when I ping localhost, I get
golfpro:/home/ryan # ping -a localhostPING golfpro.xxx.xx.com (127.0.0.1) 56(04) bytes of data.64 bytes from golfpro.xxx.xx.com (127.0.0.1): icmp_seq=1 ttl=64 time=0.067 ms64 bytes from golfpro.xxx.xx.com (127.0.0.1): icmp_seq=2 ttl=64 time=0.068 ms
Still can't ping out or connect anywhere else though...
Link to post
Share on other sites
Peachy

Now, I bet you that's not your hostname in Windows XP or is it? I would have thought with most cable modem providers also set the hostname for you. It should be something like:c324396-a.plstn1.tor.home.comIt's that hostname that your Linux box will need to be set to. The other thing you could try is to release the IP address in XP by typing ipconfig /release and then reboot into SuSE. That way, SuSE will have to pick up a new IP address. What appears to be happening is that Linux seems to pick up your IP alright, but it didn't get the hostname correctly.The other place you may want to check is your /etc/nsswitch file and see that the line that begins with host: has files dns listed beside. You can switch the order and place dns before files.

Link to post
Share on other sites
GolfProRM

You tell me... The LAC5 is the ICS port, LAC4 is the actual connection...

C:\Documents and Settings\Ryan\Desktop>ipconfig /allWindows IP Configuration        Host Name . . . . . . . . . . . . : golfpro        Primary Dns Suffix  . . . . . . . :        Node Type . . . . . . . . . . . . : Unknown        IP Routing Enabled. . . . . . . . : Yes        WINS Proxy Enabled. . . . . . . . : NoEthernet adapter Local Area Connection 5:        Connection-specific DNS Suffix  . :        Description . . . . . . . . . . . : NETGEAR FA310TX Fast Ethernet Adapter (NGRPCI)        Physical Address. . . . . . . . . : 00-A0-CC-60-65-6C        Dhcp Enabled. . . . . . . . . . . : No        IP Address. . . . . . . . . . . . : 192.168.0.1        Subnet Mask . . . . . . . . . . . : 255.255.255.0        Default Gateway . . . . . . . . . :Ethernet adapter Local Area Connection 4:        Connection-specific DNS Suffix  . : ISP.domain.com        Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Ethernet NIC        Physical Address. . . . . . . . . : 00-50-22-BB-B0-7C        Dhcp Enabled. . . . . . . . . . . : Yes        Autoconfiguration Enabled . . . . : Yes        IP Address. . . . . . . . . . . . : xx.xxx.xx.xxx        Subnet Mask . . . . . . . . . . . : 255.255.255.224        Default Gateway . . . . . . . . . : xx.xxx.xxx.xxx        DHCP Server . . . . . . . . . . . : xx.xx.xx.xxx        DNS Servers . . . . . . . . . . . : xx.xx.xx.xxx                                            xx.xxx.xxx.xx                                            xx.xxx.xxx.xx        Lease Obtained. . . . . . . . . . : Monday, June 02, 2003 10:57:17 AM        Lease Expires . . . . . . . . . . : Tuesday, June 03, 2003 7:58:02 AM
Link to post
Share on other sites
Peachy

Doh, I forgot you had a dual-homed PC. Should have remembered that you mentionned you were using ICS with XP. Bad, Peachy! B) Okay,We may be on to something here. It looks router/default gateway related. Okay, when you type ifconfig in Linux does the line with eth0 have HWaddr equal to this: 00-A0-CC-60-65-6C or this: 00-50-22-BB-B0-7C

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...