Jump to content

Linux Mint 19

  • Please log in to reply
2 replies to this topic

#1 OFFLINE   raymac46


    Discussion Deity

  • Forum MVP
  • 3,997 posts

Posted 07 August 2018 - 12:15 PM

I have decided to upgrade my basement desktop to LM 19. I used the CLI mintupgrade tool to upgrade in place.
The hardest part (and it wasn't too hard) was to replace the mdm display manager with lightdm and get rid of mdm. Both Ubuntu 18.04 and Mint 19 now use lightdm - which I prefer anyway. After that it was just a matter of backing up the old system, downloading the upgrade packages and installing the upgrade. About 2500 packages got upgraded. It was similar to a netinstall of Debian.
Everything worked after I rebooted. My hardware is old enough now that things like AMD video cards will work out of the box.
Posted Image

#2 OFFLINE   securitybreach


    CLI Phreak

  • Forum Admins
  • 24,656 posts

Posted 07 August 2018 - 12:52 PM

Nice :thumbsup:

Even with new hardware, stuff should work out of the box on most distros.
Posted ImagePosted Image
Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#3 OFFLINE   raymac46


    Discussion Deity

  • Forum MVP
  • 3,997 posts

Posted 07 August 2018 - 02:07 PM

Not if it's AMD. I got a "new" video card a few years ago - R7 360. It was just a rebrand of an older 260X but the kernels older than 4.5 didn't recognize its PCI ID so the Radeon driver didn't load. With LM 17.3 I could still use the fglrx driver but if I upgraded to LM 18 that wasn't an option anymore. So for a while if you had this card you were between a rock and a hard place. By the time they released LM 18.1, everything was sorted out and the Radeon driver has worked ever since.
Posted Image

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users