Jump to content


Hard Lesson Learned BTRFS


  • Please log in to reply
5 replies to this topic

#1 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,266 posts

Posted 05 July 2018 - 02:13 PM

Well I learned another hard lesson about the BTRFS file system. I installed the latest Linux Mint 19 last week when it was released. I installed it using BTRFS on one SSD and installed using EXT4  on another SSD. When I went to Back up the new install using BTRFS to a External Drive with all of the Updates installed. I found that It will only backup to a BTRFS partition. Wish I had known that. So I backed it up to my root partition. I have three partitions, root, swap, and home. had a problem installing some files and went to the backup. it not only borked my Hard drive but eliminated my Windows boot manager. What a mess. I reinstalled Windows and will reinstall Mint 19 using EXT4 file system. I cannot see any advantage using the BTRFS. Only problems. The tried and true is best for me. I know better, but with spare hard drives I can experiment.
Mel
:devil:
Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#2 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 24,660 posts

Posted 05 July 2018 - 02:20 PM

Well it is supposed to be where you can do easy backups but I stick with the tried and true Ext4.
Posted ImagePosted Image
Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#3 OFFLINE   ebrke

ebrke

    Board Bigwig

  • Forum MVP
  • 2,874 posts

Posted 05 July 2018 - 04:15 PM

I'm going to have to be careful on my next OpenSuse install. I carelessly let the default of BTRFS stand last time, and was sorry. Snapshots kept crowding my root partition and I had to resort to routinely going in and deleting them.

#4 OFFLINE   sunrat

sunrat

    Thread Kahuna

  • Forum Moderators
  • 5,946 posts

Posted 05 July 2018 - 07:16 PM

BTRFS sounds good in theory. I've heard too many stories like this to ever use it. Maybe it's ok for some kind of professional use. ext4 & rsync backups ftw (rsnapsot is working well now but maybe overkill for me).
There's a user called bester69 on Debian forums who swears by it. He often installs programs from outside the repository and advocates lots of Windows programs via Wine. The fact that he uses it definitely scares me off!
registered Linux user number 324659  ||    The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted ImagePosted Image
For the things we have to learn before we can do them, we learn by doing them.

#5 OFFLINE   V.T. Eric Layton

V.T. Eric Layton

    Nocturnal Slacker

  • Forum Admins
  • 21,769 posts

Posted 06 July 2018 - 10:50 AM

Meh... I remember a similar episode from my early Slackware daze. Back then Slack was installed by default with ReiserFS as the file system. ReiserFS was actually an outstanding FS. Unfortunately, development on this file system became a bit spotty after Hans Reiser was convicted and sent to jail for murdering his wife. :(

Ext2, 3, and 4 for me, thank you!

#6 OFFLINE   Fuddster

Fuddster

    Post Master

  • Members
  • PipPipPipPip
  • 145 posts

Posted 13 July 2018 - 10:18 PM

I've been leery of BTRFS on my openSuse install until last week when I borked my system trying to install and configure VNC  to interface with my Raspberry Pi. I was able to roll back to a previous snapshot without an issue. No problems since then.
MAXIM 41: "Do you have a backup?" means " I can't fix this."

Posted Image

The Rute Cellar | Fuddster on Twitter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users