Jump to content


Redhat 9 first time install


  • Please log in to reply
10 replies to this topic

#1 OFFLINE   skmz

skmz

    New Kid

  • Members
  • Pip
  • 5 posts

Posted 15 May 2003 - 08:15 PM

I took the plunge to try Linux.  I set up a linux partition and swap file using Partition Magic 8.  During the desktop user install process I manually formatted the 5G partition using ext3 and assigned / for root partition. Also formatted the 512M swap file. One questionable selection I made was that my video card an All-in-Wonder Radeon 7500 was not specifically an option. I selected the default Radeon 7500.  (I am not looking for the tv tuner or video capture at this point.) I have set up using selection for 'other' boot manager to use boot magic 8.  When I boot I get the text "Preparing machine to load 'Red Hat Linux' " and then it stalls.  I have waited over 10 minutes and nothing happens.  I have reinstalled to no avail.  I would greatly appreciate your suggestions as to where to go from here.  Let me know what other details are needed to troubleshoot.ThanksSteve

#2 OFFLINE   quint

quint

    Linux Miner

  • Forum MVP
  • 3,899 posts

Posted 15 May 2003 - 08:40 PM

skmz, on May 15 2003, 08:15 PM, said:

I took the plunge to try Linux.  I set up a linux partition and swap file using Partition Magic 8.  During the desktop user install process I manually formatted the 5G partition using ext3 and assigned / for root partition. Also formatted the 512M swap file. One questionable selection I made was that my video card an All-in-Wonder Radeon 7500 was not specifically an option. I selected the default Radeon 7500.  (I am not looking for the tv tuner or video capture at this point.) I have set up using selection for 'other' boot manager to use boot magic 8.  When I boot I get the text "Preparing machine to load 'Red Hat Linux' " and then it stalls.  I have waited over 10 minutes and nothing happens.  I have reinstalled to no avail.  I would greatly appreciate your suggestions as to where to go from here.  Let me know what other details are needed to troubleshoot.ThanksSteve
Welcome. Sorry, can't help you /w the Radeon, but before you install Linux, you must set BM8 up. Open it, enable it, click "add", and if the partition you created does not show, click advanced (or something like that), then you will see an ext2 or ext3 partition. Select that, label it, and then install Linux. When you get to the bootloader part, elect to put it in the root partition - you will then be OK. Make sure you create a boot disk, as Bruno says, it can be a lifesaver. Best of good fortune, and enjoy the marvelous penguins. :D
~ Linux User # 314972 ~ Ubuntu User # 12930 ~

If you tell the truth you don't have to remember anything.
                -- Mark Twain



#3 OFFLINE   skmz

skmz

    New Kid

  • Members
  • Pip
  • 5 posts

Posted 15 May 2003 - 09:05 PM

Good thought but Boot Magic was set up from the beginning. When I startup the BM8 screen appears, I select RedHat Linux (which is what I labeled it) then I immediately see the text  "Preparing machine to load 'Red Hat Linux' " and then nothing.

#4 OFFLINE   quint

quint

    Linux Miner

  • Forum MVP
  • 3,899 posts

Posted 15 May 2003 - 09:13 PM

skmz, on May 15 2003, 09:05 PM, said:

Good thought but Boot Magic was set up from the beginning. When I startup the BM8 screen appears, I select RedHat Linux (which is what I labeled it) then I immediately see the text  "Preparing machine to load 'Red Hat Linux' " and then nothing.
Ok, if you choose either LILO or GRUB, and place it in the root, when you select RH at the BM8 screen, you will be taken to either LILO or GRUB; at which, you just hit enter, and RH will start. Hope this helps, and hope you don't have to re-install Linux again... :D The true experts are around, and will help you if I am misunderstanding,
~ Linux User # 314972 ~ Ubuntu User # 12930 ~

If you tell the truth you don't have to remember anything.
                -- Mark Twain



#5 OFFLINE   quint

quint

    Linux Miner

  • Forum MVP
  • 3,899 posts

Posted 15 May 2003 - 09:17 PM

Another thought: if you do re-install RH, just use GRUB as the bootloader - make sure you disable BM8 before the install - it will offer you a choice of RH or Windows, but choose quickly...you've got 10 seconds, I believe. :D
~ Linux User # 314972 ~ Ubuntu User # 12930 ~

If you tell the truth you don't have to remember anything.
                -- Mark Twain



#6 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,448 posts

Posted 15 May 2003 - 09:48 PM

Quint is correct. It sounds like you didn't install the the Linux boot loader properly. I would also recommend GRUB (its the default in Red Hat 8.0), but when you choose it, make sure you select the option to modify the defaults during install. You will want to put GRUB on the actual boot partition of your ext3 partition and not the MBR. You will see those two choices during the setup. Make sure you create the bootdisk. BM, when you enable it again should see the Linux partition and let you choose it.

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#7 OFFLINE   skmz

skmz

    New Kid

  • Members
  • Pip
  • 5 posts

Posted 18 May 2003 - 09:00 AM

I am back and success!  Thanks Quint and Peachy. I had to do a complete reinstall and I am using GRUB. Couple of questions using GRUB, (I know I should not be asking this on a Linux forum but here goes) how do I make XP the default choice to load?  If you are still reading this  :lol: how do I reduce the wait time to start the default os from 10 seconds?  Thanks again,Steveps Please point me to a good thread on how to install a canon s9000 printer driver in RH9.

#8 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,448 posts

Posted 18 May 2003 - 09:32 AM

skmz, on May 18 2003, 09:00 AM, said:

I am back and success!  Thanks Quint and Peachy. I had to do a complete reinstall and I am using GRUB. Couple of questions using GRUB, (I know I should not be asking this on a Linux forum but here goes) how do I make XP the default choice to load?  If you are still reading this  :lol: how do I reduce the wait time to start the default os from 10 seconds?  Thanks again,Steveps Please point me to a good thread on how to install a canon s9000 printer driver in RH9.
To make XP your default you will need to edit your /boot/grub/grub.conf file. Open a new terminal window and type vi /boot/grub/grub.conf and you will see the contents of your grub.conf file. You will see to lines starting with title and then the description. The Linux line will say Red Hat 9 and the XP one will say DOS or something similar. The first title section is 0 and the second one is 1. Look at the default line and see what number it is. It should be pointing to Red Hat. Just change the default= to the other title. As for the delay, change the timeout valule. 0 means no delay and 10 means 10 seconds. You can change the DOS title to something more descriptive, like, Windows XP. To edit this file you need to press the "i" key to change to INSERT mode. Once you are finished editing, press [ESC] then press [colon], then "w" and finally "q".To add a printer in GNOME, click on the Red Hat, select System Settings > Printing. Click on the New button. Follow the prompt using the wizard. Assuming it is a locally connected printer, select /dev/lp0 for a parallel port printer and if its a USB printer it will typically be /dev/usb/lp0.

Edited by Peachy, 18 May 2003 - 09:38 PM.

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#9 OFFLINE   skmz

skmz

    New Kid

  • Members
  • Pip
  • 5 posts

Posted 18 May 2003 - 03:15 PM

Got it, I appreciate your patience, I have the family with two active boys so my interests tend to get the reader's digest version and the people on this forum are a great resource!  Two points I discovered using VI editor; you need to log in as root to edit the grub.conf file and to write and quit file press colon (not semicolon) wq.  I already tried adding the printer using Gnome but I should have mentioned that the Canon S9000 does not have an available driver to choose. I have found some on the web but how do I add the driver?Thanks,Steve

#10 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 18 May 2003 - 06:24 PM

skmzFor Canon you do not always need the precize driver, sometimes another type number can do the trick !Suggestion: do  Google for ¨ Linux Canon S9000¨ and see what it brings, look under the yellow tab for groups too !See if anyone speaks of using the , lets say S600, driver in stead of the non existant S9000 driver.I have solved a problem with my canon that way in the past ! ( Today I have another Canon and looked in advance if it was supported ):) BrunoPS: found this:I have just set up a Canon S9000 printer under Suse 8.0 usingTurboprint. Software costs about 20 euro to register but worth it.Install Turboprint and run Yast to select & install printer. Printerdoesn't appear in Canon list but does under Other. Choose the Canon_S900Turboprint driver and follow your nose.You have options to alter pretty well everything including gamma.

#11 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,448 posts

Posted 18 May 2003 - 09:39 PM

skmz, on May 18 2003, 03:15 PM, said:

Got it, I appreciate your patience, I have the family with two active boys so my interests tend to get the reader's digest version and the people on this forum are a great resource!  Two points I discovered using VI editor; you need to log in as root to edit the grub.conf file and to write and quit file press colon (not semicolon) wq.  I already tried adding the printer using Gnome but I should have mentioned that the Canon S9000 does not have an available driver to choose. I have found some on the web but how do I add the driver?Thanks,Steve
Sorry, colon, is correct. Yes, you need to be root to edit grub.conf. Not that vi needs to be run as root. You don't want anyone but root to change the *.conf file.

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users