Jump to content

Archlinux News: primus_vk>=1.3-1 update requires manual intervention


securitybreach
 Share

Recommended Posts

securitybreach

This is mainly for those who have a hybrid intel/nvidia GPU and use Bumblebee.

 

Quote

The primus_vk package prior to version 1.3-1 was missing some soname links. This has been fixed in 1.3-1 so the upgrade will need to overwrite the untracked soname links. If you get an error like:


primus_vk: /usr/lib/libnv_vulkan_wrapper.so.1 exists in filesystem primus_vk: /usr/lib/libprimus_vk.so.1 exists in filesystem

 

when updating, use:


pacman -Syu --overwrite=/usr/lib/libnv_vulkan_wrapper.so.1,/usr/lib/libprimus_vk.so.1
to perform the upgrade.

 

https://www.archlinux.org/news/primus_vk13-1-update-requires-manual-intervention/

  • Thanks 1
Link to comment
Share on other sites

V.T. Eric Layton
2 hours ago, securitybreach said:

This is mainly for those who have a hybrid intel/nvidia GPU and use Bumblebee.

 

Oh, darn. That leaves me out. ;)

  • Like 2
Link to comment
Share on other sites

Bumblebee is hard, one of the main source of help requests at MX and Debian forums along with wifi. If I ever get a laptop I will probably avoid Optimus graphics.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...