Jump to content
Sign in to follow this  
Guest genaldar

Folder Sharing

Recommended Posts

Guest genaldar

I've got a problem with windows 2k pro. My desktop is on the domain here and school and I'd like to share the my documents folder with a specific user (myself using my laptop). I can share the folder with everyone but I can't add a different user. I get an security alert saying "Unable to display the user selection dialog". I've tried sharing while logged in on my regular account (admin group), logging into the domain using my domain user name and logged in using the admin account. Users have the right to share folders without a domain admin account (i.e. the my documents folder on my laptop is shared just to my desktop). I've tried using protronic and they were stumped, I asked everyone I know who works with computers and they didn't have a clue and lastly I tried searching google and I only saw mentions of people complaining of the problem. No solutions. Any ideas would be greatly appreciated.btw in the hard drive properties tab I don't have a security tab. I have sharing and all the other normal ones but no security tabbed. At this point I'm thinking my system needs a clean install, and finally migrating to xp.

Share this post


Link to post
Share on other sites

I'm not quite sure I have the whole picture. It's tough with networking problems. But try this. Add the user name you want to share to on the computer you want to share from in the User Accounts control panel.-- Scot

Share this post


Link to post
Share on other sites
Guest genaldar

Done. But it still won't allow me to share the folder. I'm currently trying to map the drive that the my documents folder is on and connecting as the user name I created. But of course the network is having connection problems between the wireless (laptop) and wired (desktop). I'll let you know how it goes.

Share this post


Link to post
Share on other sites
Guest genaldar

It won't allow me to map the drive unless I share it, and since I can't share it securely (like I said I can share with everyone, but I don't want to) it's not really an option.

Share this post


Link to post
Share on other sites
btw in the hard drive properties tab I don't have a security tab.  I have sharing and all the other normal ones but no security tabbed.  At this point I'm thinking my system needs a clean install, and finally migrating to xp.
Are you logging in under Admin? You need to and you should be able to share the drive and logon/password protect it to gain access.Just an option.

Share this post


Link to post
Share on other sites
Guest genaldar

My main account is an admin account, it still doesn't work. I've also tried when logged in as admin.

Share this post


Link to post
Share on other sites

genaldar,Don't take this the wrong way, but your original post seemed hurried, and made a lot of assumptions about network setup/config that I wasn't able to follow. As I wrote in the second post in this thread, I'm not sure that I have the picture of your network environment. There are folks here who can help, but I'm wondering if you'd take the time to post the problem here again, taking a bit more time to explain.Thanks,-- Scot

Share this post


Link to post
Share on other sites
Guest genaldar

No offense taken, the post was kind of hurried. The college I go to requires everyone to lease a laptop from them, the laptops this year are all xp. Users have the privelages to share folders. All desktops have to be on the domain (nameofpc.schoolname). My desktop runs 2kpro and when they added it to the domain (adding systems to the domain has to be done by the helpdesk staff as a password is required) I think it may've changed some settings. I'm trying to share the my documents folder on my desktop so I can keep the files in synch with my laptop. I right click on the my documents folder and select sharing, select share this folder and click on the permissions tab. On the share permissions tab I click on add and I get a security warning that says "Unable to display the user selection dialog box." Below (still in the warning box) it says "(null)". I almost forgot the desktops have to be the username of the owner (name0034.nameofschool).

Share this post


Link to post
Share on other sites

Ah, ok, now I'm getting it. So, just thinking out loud about one thing you wrote, the desktops don't have the same name, do they? (They must have a way around this.)I'm going to set up a similar scenario on my network and see what comes of it. But I will say that unless there's some other piece I'm missing, this does sound unusual, not right. Like something is messed up.Question: On the XP PC (is it Pro or Home?), you have added the 2K PC as a specific user, right?-- Scot

Share this post


Link to post
Share on other sites
Ah, ok, now I'm getting it. So, just thinking out loud about one thing you wrote, the desktops don't have the same name, do they? (They must have a way around this.)I'm going to set up a similar scenario on my network and see what comes of it. But I will say that unless there's some other piece I'm missing, this does sound unusual, not right. Like something is messed up.Question: On the XP PC (is it Pro or Home?), you have added the 2K PC as a specific user, right?-- Scot
I'm not sure how much light this will shed on the subject, but I know that when I was using RC1 and RC2 of XP in a dual boot environment with Windows 2000 that I had to name my computer different names in each OS for them to be seen by other computers on my network. Not even sure why that was, but it was that way. Anyone know why?

Share this post


Link to post
Share on other sites

This may or may not apply, but here's what appears to be a similar situation:this link is to an article called - Annoyances.org - Right click Properties Ineffective (Windows 2000 Discussion Forum)

Right click Properties Ineffective When I right click on the folders to access the Sharing or Properties in Explore mode, Windows simply does not respond with the expected windows. However if I go to Computer Management's Shared Folder\Shares and right click from there I can get the splash screens to set my sharing and permissions. This of course limits me to only folders that are already shared. This seriously limits the flexibilty of tweaking the permissions. I cannot navigate conveniently around to set the permissions in Explore mode that are several layers beneath the root folders. Anybody got this as well?
Their situation appeared to have something to do with ZoneAlarm and system resources on the Windows 2000 computer.If this doesn't apply, please disregard. Hopefully the testing that Scot is doing will have an answer for you.

Share this post


Link to post
Share on other sites

Disabling ZoneAlarm, or any software firewall, would *definitely* be good advice. I have so many times forgotten to disable ZoneAlarm with odd networking problems that I should write it on my own forehead. It causes a lot of problems like this. Usually you can configure it around the problem. It's not permanent. But it's one of the reasons why ZA is not my only recommended firewall.About naming computers the same. There were a LOT of problems with Win XP late releases and networking. That seemed to be the area they couldn't get right. (Some would argue that they still haven't gotten it quite right in.) But it is possible to have multiple workstations on the same network with the same name under shipping XP. Several computers on my network do. But I am curious about the share names on those two desktops.My initial check on my network didn't turn up this problem, but there are a couple of other things I want to try when I get time.-- Scot

Share this post


Link to post
Share on other sites
Guest genaldar

my laptop is actually numbered (nb2101) so its not the same name problem. It shouldn't be zone alarm either, I used to have it installed but since the network is protected by hardware firewalls I uninstalled it. It's possible that in my removing of all mentions of zone alarm from the registry I missed one, or I deleted a string that I shouldn't have.

Share this post


Link to post
Share on other sites

About ZoneAlarm, I sort of doubt that's your problem -- that ZA isn't fully uninstalled. But just in case, this should help:http://www.scotsnewsletter.com/35.htm#csavvyIt was the desktop names, not the PC names, that I was wondering might be the same. You said your school named desktops. But maybe you meant PCs.I really am near to being stumped on this one. I begin to think that there is something with how your Win2K box is set up or admitted to the network that's causing the problem. That doesn't seem likely to me, but I'm not coming up with any other ideas, sorry to say. I'll keep noodling it. Please post back if you learn anything more. Sometimes it takes only one added fact to solve one of these.-- Scot

Share this post


Link to post
Share on other sites
Guest genaldar

I'm pretty sure it's a problem with the setup. I definetly remember being able to share folders before my desktop was added to the network. But they occasionally block machines not on the network. Rather annoying so they're inept enough to not be able to tell if an xp desktop is on the net, but with any other box they just compare it against the list and if its not on it, bye bye internet. I'm going to just try and remove it from the network and if that doesn't work I'll live with it.

Share this post


Link to post
Share on other sites

If that is the case, they are rightly protecting their network from potentially insecure OSes and shares to help protect their network.Not a bad idea really, but it can be a real pain to users.

Share this post


Link to post
Share on other sites
Guest genaldar

I don't think it was intentional. The help desk sends out itm majors to add desktops and of course they're only trained on xp. It's just like tech support, if its not in the binder it can't possibly be fixed.

Share this post


Link to post
Share on other sites

Yep ... I hate dealing with Tech Support folks that think the binder is "God" and there is no other way! :)

Share this post


Link to post
Share on other sites

Genaldar,I want to draw your attention to a nearby thread that *may* have something in it that applies to your problem.Please see this thread:http://www.scotsnewsletter.com/forums/inde...act=ST&f=2&t=87Scroll down to the post by "yourpcgeek" and see his discussion about turning off "Use simple file sharing." And use the question mark icon on that screen to get help by pointing at this option. The information in that pop-up sounds to me like it might apply to your problem. Please check it out.-- Scot

Share this post


Link to post
Share on other sites

Question - Does your school operate an Active Directory domain structure, and if so are there Group Policy Objects that joining their domain enforce?As a security measure they may have mucked about your settings?Do your two machines network only thru two drops into the infrastructure, or are you cross connecting or small switch?I'd be curious if you networked as a test only your two machines and logged onto them with Local User accounts instead of doamin accounts, - does the same problem occur?BruceMCSE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...