Jump to content

pclinuxos- 7 mouse buttons


boilertech
 Share

Recommended Posts

OK. Now we are getting somewhere. I removed the line from my append box. I ran xev and the buttons now are read. Except they should be buttons 6 and 7 instead they are 2 and 3. Buttons 6 and 7 are not listed so I have two buttons for 2 and 3. I will try to explain better. Left button=1 wheel button=2 right button =3 wheel up=4 wheel down=5 left side=2 right side=3. The two side buttons should be 6 and 7.

Link to comment
Share on other sites

Hi BoilertechGlad you got some progress finally !!What happens if you give the command:

imwheel -k -b "67"

. . . . does that make any change ?:ph34r: Bruno

Link to comment
Share on other sites

Same. I did try that. Also tried this.

[mike@localhost ~]$ xmodmap -ppThere are 7 pointer buttons defined. Physical Button Button Code 1 1 2 2 3 3 4 6 5 7 6 4 7 5
Link to comment
Share on other sites

Hi boilertechMaybe this gives some info: http://fresh.t-systems-sfr.com/linux/src/i.../imwheel.1.html( note: I saved the text to a file and renamed it to imwheel.html so it can be viewed "normal" in a browser )Or here it talks about

Option "ButtonNumber" "7"
( http://www.glaurung.demon.co.uk/info/linux.mx500.howto.html ):ph34r: Bruno
Link to comment
Share on other sites

I changed my Option "Protocol" "IMPS/2" to Option "Protocol" "ExplorerPS/2" And it now works. I get weird readings from "xev" But in mozilla it works great for forward and backwards. You are very patient and helpfull ( Every one here ). Thanks for all the help. Hopefully I can return the help someday.

Link to comment
Share on other sites

You're welcome my friend . . . but honestly I looks rather like you managed to figure it out yourself and my "help" was not really of much use after all :( . . . . Great job Boilertech :ph34r: :thumbsup: Bruno

Link to comment
Share on other sites

I get weird readings from "xev"
I removed the "imwheel.sh" from .kde/autostart and everything is perfect. I will sit down later tonight and write the steps I took to make this work and post here.
Link to comment
Share on other sites

It sounds like changing the mouse name is what did the trick. It is amazing what little details can do. Glad you are happy with it now. Way to go!

Link to comment
Share on other sites

This is how I got multiple buttons on my mouse to work with PCLinuxos.1). Back up lilo.conf

 # cp /etc/lilo.conf{,-BACKUP}

2). Remove "psmouse.proto=imps " from append. ->Control Center ->Boot ->Configure Lilo ->highlight default entry (has a * at the end) ->Click modify ->remove "psmouse.proto=imps" from append.3). Backup xorg.conf.

 # cp /etc/X11/xorg.conf{,-BACKUP}

4). Edit xorg.conf

 # kate /etc/X11/xorg.conf

look for the ¨input device¨ mouse section and adapt it to look like: ( line 3, 5 and 6 !! )

Section "InputDevice" Identifier "Mouse1" Driver "mouse" Option "Protocol" "ExplorerPS/2" Option "Device" "/dev/mouse" Option "ZAxisMapping" "6 7" Option "Buttons" "7"EndSection
5). Make a script in .kde/Autostart
$ kate  ~/.kde/Autostart/mouse

Insert these lines

#!/bin/shxmodmap -e "pointer = 1 2 3 6 7 4 5"
Make sure you set it to executable.6). Download the program ¨imwheel¨ (1.0.0pre1) you can find it Here and install it. Once your wheel works you can test to see the extra buttons with < xev > (place mouse in the square and click the buttons and see what happens).
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...