Jump to content
Scot's Newsletter Forums
Sign in to follow this  
georgeg4

Conexant modem problems

Recommended Posts

Actually bruno I didn't get that much help from him ,But it was not because his advice wasn't in any way wrong or incomplete , It was just because I had allready found the drivers he recomended on my own before he became involved . conexant has drivers for linux for most of its modems ,However I cannot get them to work on my installation for some reason . I have recently tried to install the drivers using kppp and it seems to recognize it now however I keep getting the message " The modem is busy " and I haven't been able to figure that one out as yet . But I am not giving up just yet . I am a stubborn dutchman and I refuse to let a machine get the better of me . It didn't with Windows and it won't with linux it is just a matter of time

Share this post


Link to post
Share on other sites
One time when all I could get was a modem busy error after an install, I believe it was an IRQ conflict with my sound card; at one point I could have one or the other (sound or Internet) on one of my computers.Wonder if that could George's problem with his modem since he appears to have the right driver for the modem?

Share this post


Link to post
Share on other sites
Hi George,[quote]I have recently tried to install the drivers using kppp[/quote] It is not completely clear what you mean here George. Kppp is not a program that lets you install the drivers. Kppp does only use the drivers to make the modem work.Another question I have comes from the other thread where we looked into your modem problems: did you ¨say No to PnP aware OS in your BIOS¨ ? If so, is there an optoin in the BIOS to disable your soundcard ?But the way you installed those drivers are the point I like to have clear first ! :):rolleyes: Bruno

Share this post


Link to post
Share on other sites
Let me start from the beginning maybe that will help.First linux would not detect my modem but after I installed ( Mechanically) the second modem ( Conexant) Linux recognized it But it would not work because the only driver I had was my original incompatible modem . I went to conexants site and downloaded the linmodem driver and burned them to cd.I installed the drivers from cd by right clicking and choosing install with ???I forget the name of the installer but I am sure you will know it . I then tried to configure with the internet connection wizard which looked like it was working but each time I tried it it would be deactivated again . I also notice in the internet configuration I do not have U.S.A. in the list .Perhaps that is a problem . I haven't disabled PNP in the bios but I will on the next reboot . However the PnP is definately working as I said before it detected the new modem when I installed it.I am going to reboot now and disable PnP and I will let you know if that works . By the way in answer to the sound card Linux doesn't recognize it either so while I am in bios I will disable it if I can.

Share this post


Link to post
Share on other sites
[quote]I also notice in the internet configuration I do not have U.S.A. in the list .Perhaps that is a problem .[/quote] This is strange. RedHat is made in US, why would they leave that out ?[quote]but each time I tried it it would be deactivated again[/quote] Is this in the wizard ? Or in kppp ?Anyway, lets wait what the PnP ¨NO¨ does, you have to go the the internet connection wizzard again to reconfigure.:) Bruno [i]NOTE: we set PnP to NO because the kernel takes care of the recognition of the devices like your modem.[/i]

Share this post


Link to post
Share on other sites
:) SuSE doesn't have Australia (or anywhere near) in the list but the modem still works on mine.I always disable plug and pray OS in the BIOS for Linux, it doesn't seem to need it.

Share this post


Link to post
Share on other sites
Ok Here I am again I reinstalled another application of RH on a different partition I allready had empty . This time I just installed the desktop pc version . I also disabled PnP in the bios . I also disconnected my primary modem in Windows . And configured it to use this one ( conexant which I have a driver for ) after installing I opened the driver and installed it with the default application . I then opened the internet wizard and tried to activate the modem ( it wouldn't activate) since there is no kppp in the default installation I rebooted and booted into the original ( full ) installation . There I opened the panel and tried to input the following string " setserial/dev/ttys2 irq 10 port 0xecb autoconfig " and recieved the message "invalid command dev/ttys2 etc"There is no option in my bios to disable the sound card but when I boot up the hardware configuration wizard detects it and I click on "do nothing" I don't need sound that much and if necessary I could do without it .Back to the drawing board :)

Share this post


Link to post
Share on other sites
Hi George,[quote]setserial/dev/ttys2 irq 10 port 0xecb autoconfig[/quote] Was that a command mentioned in the README of the drivers ? There is a small mistake in there: between setserial and /dev/ttys2 there has to be a space. Also the modem has to be connected to what they call ¨com3¨ in windows. Also you have to be root to give this sort of commands. Why didn´t you try the GUI config tool ?I´m going to split of this in a new topic, the title will be: ¨Conexant modem problems¨ I hope it will get more attention that way and more people might jump in to help you.Can you provide us with the following info:Where did you get those drivers ? ( a link please )What was the exact driver you downloaded ? ( type number )We just have to crack this one !:) Bruno

Share this post


Link to post
Share on other sites
I got the command from a linux book/tutorial that I have had since RH4 and it was mentioned on a site that someone gave me . You have to forgive my memory it isn't as good as it used to be The site for conexant linmodems is [url="http://www.linuxant.com/drivers/hsf/downloads-rh-i586.html"]HERE[/url]And the driver is hcfpcimodem-0.9linxtbeta03042700k-2.4.20_8-1rh.i586.rpm

Share this post


Link to post
Share on other sites
O.K. that looks like the right driver, if your kernel is the 2.4.20-8 !It was a rpm so clicking would install it on the right place.So far nothing can go wrong. Now find a ¨window¨ where you can configure your modem, don´t go in the commandline thing you tried before.Find a GUI ¨internet connection configuration¨ and try to configure it that way.:) Bruno

Share this post


Link to post
Share on other sites
George did you see [url="http://www.linuxant.com/drivers/hsf/install.html"]This[/url] ?There is a full discription of the install routine !¨hsfconfig¨ is the command to configure your modem.From the howto:[quote]With "hsfconfig  --country" you may select another country supported by your modem.[/quote]:) Bruno[i]PS: You have the binary rpm not the src ![/i]

Share this post


Link to post
Share on other sites
Hey guys..... Hey george... Got your self a better winmodem, huh? Well, I'm not sure where the rest of this post is...... But from what I've read, I think I can help you out... First off..... Don't use Kppp..... You might as well install Mandrake.... :-) Sorry Bruno....... I like Mandrake alot but it's too much like Xp.... I got bored pretty quick.... It does everything for you..... Are you using Gnome or KDE? Use ppp0/Gnome.... I tried using kppp and your right, it asked me to start with the wizard or maunal from now on and I selected Wizard, then I get to the country selection screen and there is no USA........ Hmmmmm..... So now I can only start with the wizard which is a giant loop that will never finish...... Use the Redhat button/System settings/Network.... should be ppp0 by default. wavedial? I think. Anywho. I use a conextant winmodem. HSF linmodem. I get my driver from the same page you listed. Tho I am a bit confused that the file name you listed says "HCF".......... If you are using an HSF linmodem driver on Redhat, HSFCONFIG will rarely work. You will get "no such command".... Sometimes it works, other times it doesn't..... Depends on the install.... I like to format alot.... Doesn't really matter.... Double click on the rpm. Fire and forget. Your device should be listed as ttySHSF0 in /dev....... Just create a new device in Network(modem), /dev/ttyshsf0, highest baud rate, hardware/software/none flow control.... Doesn't seem to matter...... It will not list ttyshsf0 in the drop down menu. You must type it in. The symlink of /dev/modem will not work either unless you do alot of foot work. Get your primary and secondary DNS numbers from your isp.... User name, password, access number..... It's all fairly straight forward thru ppp0/network..... It should dial when you ACTIVATE under Network..... Post back and good luckJon

Share this post


Link to post
Share on other sites
Looks like this modem is a real pain, jong357. Thanks for jumping in here !The page he links to in his post are for the hsf drivers, but in his post he talks about the hcf drivers. I think first we have to get clear he´s got the right [b]hsf[/b] drivers from the page he linked us to.Installing is no problem after that, but we might want to un-install the hcf drivers first. Think we need to take little steps.;) Bruno

Share this post


Link to post
Share on other sites
Hi On the discussion of HCF AND HSF I did try both drivers on my original install and neither one worked properly . However on the chip in the modem it says it is an HCF made by monopack for conexant . the other info on the chip itself ispt3517Conexant R6785-11monopack HCF And the computer info isVendor I.D. 14f1dev 1035sub Ven 144fSub dev 1010 rev-08Also on the modem board is the info Conexant HCF P85I am going to RH now to try again with Jong's advice I will post back shortlyAnd Bruno I did check out that link you gave me Thanks

Share this post


Link to post
Share on other sites
No such luck I reinstalled the package and reconfigured it using network intered my dialm up info and dns info as suggested . The modem activated and everything looked good but no cigar linux thinks the modem is online while it isn't . Somehow I believe it is the lowlevel config but I don't know how to fix it .Linux does not list my modem in the hardwware list either . So I don't believe it is the drivers it just isn't getting that far . Is there a way to query the modem similar to Windows hyperterminal .P.S. Bruno I have no com3 port on my machine .I can add one and try to reinstall the modem to it if you think that is the problem .

Share this post


Link to post
Share on other sites
Wait a minute George,What you´re saying is:[quote]linux thinks the modem is online while it isn't[/quote] explain that to me.Does it dial ? Does it connect to your isp, but you can´t get on the internet ?[quote]Linux does not list my modem in the hardwware list either[/quote] This is normal because it is not officialy supported.Please dial-in, open a console and type: ¨ping www.scotsnewsletter.com¨ and tell me what you get.;) Bruno

Share this post


Link to post
Share on other sites
[quote]it doesn't dial but in the console it says it does[/quote] ??????? Please explain step by step, take your time, but make this clear to me. :DDid you try to ping ?;) Bruno

Share this post


Link to post
Share on other sites
Ok when I open the network up it brings up the internet connection wizard . I enter my ISP's phone number , my user name,and password ,then on the top I chose edit and in the next window I entered what jong suggested ttySHSF0 and I moved it to the highest baud rate .Then in the next tab/window I entered my dns numbers and then clicked activate . It went through to smaller popups and then the third said it was configuring the modem , It then came back up and said the modem is active . And when I tried to connect it said modem is allready open

Share this post


Link to post
Share on other sites
George,What is the exact name of your drivers rpm package ?What does ¨uname -m¨ tell you as you type that in a console ?;) Bruno

Share this post


Link to post
Share on other sites
The driver is hcfpcimodem-099inxtbeta0304200k2.4.20_8-1rh.i586.rpmAnd I haven't queried uname -m Only uname Also when you say console am I correct in RH that it is the Terminal , That is the only place I saw to enter commands

Share this post


Link to post
Share on other sites
GeorgeYes I mean terminal, sorry for the lingouname -m brings you i586 ?uname -r brings you 2.4.20_8 ?;) Bruno

Share this post


Link to post
Share on other sites
George, where are you ? Don´t run away . . . don´t give up . . . . . .!! . . . . .We´ll crack it ! :);) Bruno

Share this post


Link to post
Share on other sites
I'm here bruno "nature call" sorrywhen I log off I checked the version and it says 2.4.20-8 in RHi586there is another thing I noticed when I tried to load the kde packages when I mount the cd drive it comes up as i386 instead of i586 .Did you see my question about the Hyper Terminal in windows . does linux have a similar program

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...