Jump to content


Xorg problem in Opensuse


  • Please log in to reply
2 replies to this topic

#1 OFFLINE   réjean

réjean

    Discussion Deity

  • Forum MVP
  • 4,321 posts

Posted 06 April 2012 - 12:14 AM

Hi all!
I upgraded Opensuse and now I cannot open X. The message is;

QUOTE
xinit failed. /usr/binXorg is not setuid,maybe the reason?
If so either use a display manager ( strongly recommended) or adjust /etc/permissions.local


Here is the content of /etc/permissions.local

CODE
#
# /etc/permissions.local
#
# This file is used by SuSEconfig and chkstat to check or set the modes
# and ownerships of files and directories in the installation.
#
# In particular, this file will not be touched during an upgrade of the
# installation. It is designed to be a placeholder for local
# additions by the administrator of the system to reflect filemodes
# of locally installed packages or to override file permissions as
# shipped with the distribution.
#
# Format:
# <file> <owner>:<group> <permission>
#
# Please see the file /etc/permissions for general usage hints of the
# /etc/permissions* files.
# Please remember that logfiles might be modified by the logfile
# rotation facilities (e.g. logrotate) so settings entered here might
# be overridden. Also devices files (/dev/*) are not static but
# managed via udev so this file can't be used to modify device
# permissions either.
#

#
# suexec is only secure if the document root doesn't contain files
# writeable by wwwrun. Make sure you have a safe server setup
# before setting the setuid bit! See also
# https://bugzilla.novell.com/show_bug.cgi?id=263789
# http://httpd.apache.org/docs/trunk/suexec.html
#
#/usr/sbin/suexec2            root:root       4755

# setuid bit on Xorg is only needed if no display manager, ie startx
# is used. Beware of CVE-2010-2240.
#
#/usr/bin/Xorg                 root:root       4711


What should I do?

Edited by réjean, 06 April 2012 - 02:13 PM.

registered linux user #374889

#2 ONLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 16,024 posts

Posted 06 April 2012 - 01:27 AM

Possibly: http://forums.opensuse.org/english/get-tec...tart-fails.html
Posted ImagePosted Image Posted Image
CNI Radio/Archlinux G+/Configs/PGP Key π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#3 OFFLINE   réjean

réjean

    Discussion Deity

  • Forum MVP
  • 4,321 posts

Posted 06 April 2012 - 02:02 PM

Yahoo!
I had been there josh but since we couldn't find a fix I thought that someone else here would know.

After my problem last night I had been in yast (text) and install nvidia-gfxG02-kmp-desktop instead of nvidia-gfx-kmp-desktop to no avail. I just reinstalled the 2nd (gfx, no G02) and I am back into Gnome. Now I am happy!
registered linux user #374889




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users