Jump to content


No sound -- yet again ********


  • Please log in to reply
57 replies to this topic

#1 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 29 February 2012 - 06:40 PM

Well I have no sound yet again.

Jamendo has no sound.

You Tube opens up with SMplayer but has no sound.

Gogglesmm gives me a message,

QUOTE
Session bus not available.All features requiring dbus are disabled


then,

QUOTE
Unable to initialize audio driver


If I check in a terminal I get,

CODE
# lspci | grep -i audio
02:08.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]


So where is my sound. !!!!

I'm lost any ideas folks.  mad.gif

Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#2 OFFLINE   amenditman

amenditman

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,187 posts

Posted 29 February 2012 - 07:13 PM

It's possible your system is trying to use an alternate (non-existant) audio device. Mine occasionally creates virtual copies of my sound device and sets the new one as default. I usually check alsamixer then the alsa ArchWiki page. Something to do with aplay or asound if I remember correctly.

From the ArchWiki ALSA page
QUOTE
Set the default sound card
In Kernel Space

Telephony-capable modems and modern graphics cards with HDMI output can conflict with the sound card for the default sound card slot. (pcspkr is another, non-ALSA PC speaker module. It will not conflict with ALSA sound cards.) To prevent this, discover your sound card model name with lspci(8) and your ALSA driver module names with ls(1):

CODE
$ ls -l /sys/module/snd/holders


QUOTE
Or better (source[1]):
CODE
$ cat /proc/asound/modules


Then add the names of your sound card modules to (source[2]):

/etc/modprobe.d/alsa.conf


Tweak it 'til it breaks, then learn how to fix it.  L.I.F.E. (Linux Is For Everyone)
Registered Linux User # 474004 (06/16/2008)

The HeliOS Project  -  B.O.D.
A Child's Exposure to Technology Should Never Be
  Predicated On The Ability To Afford It

#3 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 29 February 2012 - 07:54 PM

QUOTE (amenditman @ Feb 29 2012, 08:13 PM) <{POST_SNAPBACK}>
It's possible your system is trying to use an alternate (non-existant) audio device. Mine occasionally creates virtual copies of my sound device and sets the new one as default. I usually check alsamixer then the alsa ArchWiki page. Something to do with aplay or asound if I remember correctly.

From the ArchWiki ALSA page


Well I followed securitybreaches advice and got sound last week.

QUOTE
I just disabled my secondary audio using this:

First find the pci id with:
QUOTE
╔═ comhack@Cerberus 08:42 AM
╚═══ ~-> lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Barts HDMI Audio [Radeon HD 6800 Series]


Find the correct folder
QUOTE
╔═ comhack@Cerberus 08:43 AM
╚═══ ~-> find /sys/devices -name *01:00.1
/sys/devices/pci0000:00/0000:00:03.0/0000:01:00.1


And add this to the /etc/rc.local
QUOTE
echo 1 > /sys/devices/pci0000\:00/0000\:00\:03.0/0000\:01\:00.1/remove


See now it does not show up:
QUOTE
╔═ comhack@Cerberus 08:55 AM
╚═══ ~-> lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)

╔═ comhack@Cerberus 08:55 AM
╚═══ ~->



NOTE: Your numbers may or may not be the same as mine.


and this is what I get today which is the same as last week.

CODE
# lspci | grep -i audio
02:08.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]


These are the outputs from amenditman's links.

CODE
$ cat /proc/asound/modules
1 snd_virtuoso


CODE
$ ls -l /sys/module/snd/holders
total 0
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_hda_codec -> ../../snd_hda_codec
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_hda_codec_analog -> ../../snd_hda_codec_analog
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_hda_codec_hdmi -> ../../snd_hda_codec_hdmi
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_hda_intel -> ../../snd_hda_intel
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_hwdep -> ../../snd_hwdep
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_mpu401_uart -> ../../snd_mpu401_uart
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_oxygen_lib -> ../../snd_oxygen_lib
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_pcm -> ../../snd_pcm
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_rawmidi -> ../../snd_rawmidi
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_seq_device -> ../../snd_seq_device
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_timer -> ../../snd_timer
lrwxrwxrwx 1 root root 0 Feb 29 23:24 snd_virtuoso -> ../../snd_virtuoso


I'm totaly lost on this.

From the Wiki

QUOTE
ALSA is included in the default Arch kernel as a set of modules, so installing it is not necessary.

udev will automatically probe your hardware at boot, loading the corresponding kernel module for your audio card. Therefore, your sound should already be working, but upstream sources mute all channels by default.


QUOTE
The current version of ALSA installs with all channels muted by default. You will need to unmute the channels manually.

It is easiest to use alsamixer ncurses UI to accomplish this (alternatively, use amixer from the commandline):

$ alsamixer


Here is what I get,

CODE
$ alsamixer
cannot open mixer: No such file or directory


CODE
# alsamixer
cannot open mixer: No such file or directory


CODE
# alsaconf


Tells me "no legacy drivers are available"

and yes I read,

QUOTE
Warning: Do not use alsaconf if you have a PCI or ISAPNP sound card, as the entries alsaconf adds to the modprobe.conf file might break udev's autodetection.


but my "modprobe.conf" is empty so I recon that shows that "alsaconf" is doing sweet zip for me.

This Arch install is turning into a nightmare  pinch.gif I did not have half as many problems last year when I did my first install and I knew nothing at all  rant.gif
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#4 OFFLINE   amenditman

amenditman

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,187 posts

Posted 29 February 2012 - 08:16 PM

Check if you can install or have installed alsa-utils from the extra repos.

CODE
[amenditman@amendesk ~]$ yaourt -Ss alsa utils
extra/alsa-utils 1.0.25-1 [installed]


This package contains the alsamixer and some other stuff you need.
Tweak it 'til it breaks, then learn how to fix it.  L.I.F.E. (Linux Is For Everyone)
Registered Linux User # 474004 (06/16/2008)

The HeliOS Project  -  B.O.D.
A Child's Exposure to Technology Should Never Be
  Predicated On The Ability To Afford It

#5 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 29 February 2012 - 08:22 PM

QUOTE (amenditman @ Feb 29 2012, 08:16 PM) <{POST_SNAPBACK}>
Check if you can install or have installed alsa-utils from the extra repos.

CODE
[amenditman@amendesk ~]$ yaourt -Ss alsa utils
extra/alsa-utils 1.0.25-1 [installed]


This package contains the alsamixer and some other stuff you need.


Did that last week. That is how I unmuted the sound.


CODE
$ yaourt -Ss alsa utils
extra/alsa-utils 1.0.25-1 [installed]
    An alternative implementation of Linux sound support
aur/alsa-utils-transparent 1.0.25-1 (11)
    An patched version of the alsa-utils package to support transparent
    terminals
aur/lirc-utils-oss 0.8.3-1 (Out of Date) (1)
    Linux Infrared Remote Control utils without ALSA dependence



looks like they are still installed.  thumbsup.gif


Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#6 OFFLINE   V.T. Eric Layton

V.T. Eric Layton

    Nocturnal Slacker

  • Forum Admins
  • 17,161 posts

Posted 29 February 2012 - 09:10 PM

Simon and Garfunkel - The Sound of Silence

tongue.gif
Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#7 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 29 February 2012 - 09:30 PM

QUOTE (V.T. Eric Layton @ Feb 29 2012, 09:10 PM) <{POST_SNAPBACK}>
Simon and Garfunkel - The Sound of Silence

tongue.gif


Read PC = Television

QUOTE
HANCOCK ON TELEVISION MAINTENANCE

TELEVISION REPAIR MAN:
    Have you been kicking it?
HANCOCK:
    Well of course I've been kicking it - how else do you think I change the channels over? One kick: B.B.C.; Nine kicks: I.T.A.. I had to change over six times last night - I've got toes like globe artichokes here. I'll be glad when my television-kicking boots come back from the menders!


http://www.phespirit.info/hancock/  cool.gif
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#8 OFFLINE   V.T. Eric Layton

V.T. Eric Layton

    Nocturnal Slacker

  • Forum Admins
  • 17,161 posts

Posted 29 February 2012 - 09:45 PM

Kicking and smacking are most definitely integral items in the repairman's tool box. wink.gif
Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#9 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 14,383 posts

Posted 29 February 2012 - 11:24 PM

Are you a member of the audio group?
QUOTE
╔═ comhack@Cerberus 09:24 PM
╚═══ ~-> groups
lp wheel kvm video audio optical storage power users vboxusers wireshark comhack adbusers


Also, did you reboot after today's kernel update?

Lastly, can you post the ouput of :
CODE
lsmod | grep snd

Posted ImagePosted Image Posted Image
Comhack.com/CNI Radio/G+ Profile/Configs/PGP Key π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#10 OFFLINE   sunrat

sunrat

    Discussion Deity

  • Forum Moderators
  • 4,197 posts

Posted 01 March 2012 - 04:18 AM

I have several suggestions: first post the result of the command securitybreach mentioned in his above post.
-Go into the BIOS and disable the soundcard you are not using, then reboot. Check alsamixer to make sure it's unmuted and levels are up, test for sound (this works for my system with onboard chip and Audiophile 2496 PCI card)
-If no luck try, if it's not listed in the lsmod output (as root)
CODE
modprobe snd-oxygen


Some more info is at http://www.alsa-project.org/main/index.php...x:Module-oxygen, although some of it is dated and obsolete.
registered Linux user number 324659  || The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted Image  Posted ImageLinuxBBQ
For the things we have to learn before we can do them, we learn by doing them.

#11 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 01 March 2012 - 08:51 AM

securitybreach

Are you a member of the audio group?  == yes
CODE
# lsmod | grep snd
snd_oxygen             16214  0
snd_hda_codec_hdmi     24121  0
snd_hda_codec_analog    79760  0
snd_virtuoso           33445  3
snd_oxygen_lib         30589  2 snd_virtuoso,snd_oxygen
snd_mpu401_uart         6011  1 snd_oxygen_lib
snd_rawmidi            19458  1 snd_mpu401_uart
snd_hda_intel          23375  0
snd_seq_device          5300  1 snd_rawmidi
snd_hda_codec          89160  3 snd_hda_intel,snd_hda_codec_analog,snd_hda_codec_hdmi
snd_hwdep               6389  1 snd_hda_codec
snd_pcm                74780  5 snd_hda_codec,snd_hda_intel,snd_oxygen_lib,snd_hda_codec_hdmi
snd_page_alloc          7153  2 snd_pcm,snd_hda_intel
snd_timer              19544  2 snd_pcm
snd                    59214  17 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_seq_device,snd_hda_intel,snd_rawmi
di,snd_mpu401_uart,snd_oxygen_lib,snd_virtuoso,snd_hda_codec_analog,snd_hda_code
c
_hdmi,snd_oxygen
soundcore               6210  1 snd
[root@longship bloodaxe]# modprobe snd-oxygen
[root@longship bloodaxe]# modinfo soundcore


sunrat

Check alsamixer  == see my earlier posts I did all this originaly. == alsamixer was not playing yesterday but it is today. == naughty penguin.

modprobe snd-oxygen == does not seem to do anything.

securitybreach

Also, did you reboot after today's kernel update? == NO == switched on today and have sound ==   oops.gif bangin.gif bangin.gif bangin.gif  bangin.gif bangin.gif       blushing.gif    


  sunrat + securitybreach

I followed the link and tried

CODE
modinfo soundcore


which of course showed the module loaded in the kernel.

However it mentions "/etc/​modules.conf" which I have but it is empty . Is it worth my while doing,

QUOTE
Here's the example for this card. Copy and paste this to the bottom of your /etc/​modules.conf file.

# ALSA portion
       alias char-major-116 snd
       alias snd-card-0 snd-oxygen
       # module options should go here
      
       # OSS/Free portion
       alias char-major-14 soundcore
       alias sound-slot-0 snd-card-0
      
       # card #1
       alias sound-service-0-0 snd-mixer-oss
       alias sound-service-0-1 snd-seq-oss
       alias sound-service-0-3 snd-pcm-oss
       alias sound-service-0-8 snd-seq-oss
       alias sound-service-0-12 snd-pcm-oss


Or seeing as I have sound should I just keep me fingers crossed and leave things a s they are.  rolleyes.gif

Oh and of course many many thanks for the help  thumbsup.gif

Edited by abarbarian, 01 March 2012 - 09:36 AM.

Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#12 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 14,383 posts

Posted 01 March 2012 - 10:06 AM

Whenever you do a kernel upgrade, some of the modules and other things do not load correctly until you reboot.
Posted ImagePosted Image Posted Image
Comhack.com/CNI Radio/G+ Profile/Configs/PGP Key π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#13 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 01 March 2012 - 11:41 AM

QUOTE (securitybreach @ Mar 1 2012, 10:06 AM) <{POST_SNAPBACK}>
Whenever you do a kernel upgrade, some of the modules and other things do not load correctly until you reboot.


Yup I remember that very fact came up here recently.  thumbsup.gif
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#14 OFFLINE   sunrat

sunrat

    Discussion Deity

  • Forum Moderators
  • 4,197 posts

Posted 01 March 2012 - 06:15 PM

Yay, it's working! snd-oxygen has obviously been renamed to snd_oxygen since that alsa page was written, and it is already loaded.
registered Linux user number 324659  || The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted Image  Posted ImageLinuxBBQ
For the things we have to learn before we can do them, we learn by doing them.

#15 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 01 March 2012 - 06:53 PM

Yup the B52's sound greaaaaaaaat  laugh.gif

Thanks guys.  thumbsup.gif
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#16 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 13 March 2012 - 10:33 AM

Well once again I have no sound. I tried to fix it but had no sucess so I thought. What if I delete files and folders( I had lost trck of what had been altered) and uninstall some alsa stuff. Then reboot. Then reinstall the alsa stuff do a pacman -Syu and reboot. But no joy.
When I try to run alsamixer I get (see the end of the code)

CODE
[root@longship bloodaxe]# lsmod | grep snd
snd_oxygen             16214  0
snd_hda_codec_hdmi     24121  4
snd_hda_intel          23375  0
snd_hda_codec          89160  2 snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               6389  1 snd_hda_codec
snd_virtuoso           33445  0
snd_oxygen_lib         30589  2 snd_virtuoso,snd_oxygen
snd_mpu401_uart         6011  1 snd_oxygen_lib
snd_rawmidi            19458  1 snd_mpu401_uart
snd_seq_device          5300  1 snd_rawmidi
snd_pcm                74780  4 snd_hda_codec_hdmi,snd_oxygen_lib,snd_hda_codec,snd_hda_intel
snd_page_alloc          7153  2 snd_pcm,snd_hda_intel
snd_timer              19544  1 snd_pcm
snd                    59214  12 snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq_device,snd_rawmidi,snd_mpu401_uart,
snd_oxygen_lib,snd_virtuoso,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_oxygen
soundcore               6210  1 snd
[root@longship bloodaxe]#  cat /proc/asound/modules
0 snd_virtuoso
1 snd_hda_intel
[root@longship bloodaxe]# alsamixer
ALSA lib conf.c:3700:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL default
cannot open mixer: No such file or directory


Oops  blushing.gif
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#17 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 14,383 posts

Posted 13 March 2012 - 12:12 PM

What do you get when you run alsaconf as root?
Posted ImagePosted Image Posted Image
Comhack.com/CNI Radio/G+ Profile/Configs/PGP Key π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#18 OFFLINE   V.T. Eric Layton

V.T. Eric Layton

    Nocturnal Slacker

  • Forum Admins
  • 17,161 posts

Posted 13 March 2012 - 12:32 PM

WARNING: You have broken (or maimed) your Arch system. Please initiate Nominal Utility-grade Kinetic Energy option immediately.



hysterical.gif
Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#19 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 13 March 2012 - 04:54 PM

QUOTE (securitybreach @ Mar 13 2012, 12:12 PM) <{POST_SNAPBACK}>
What do you get when you run alsaconf as root?



I find this warning in the Alsa Wiki very puzzling,I have a ASUS Xonar DS PCI sound card.

QUOTE
Warning: Do not use alsaconf if you have a PCI or ISAPNP sound card, as the entries alsaconf adds to the modprobe.conf file might break udev's autodetection.


Seeing as me sound seems screwed I ran alsaconf and got this output

CODE
[root@longship bloodaxe]# alsaconf
bash: alsaconf: command not found


Running aplay -l outputs this


CODE
[root@longship bloodaxe]# aplay -l
**** List of PLAYBACK Hardware Devices ****
ALSA lib conf.c:3700:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:0
aplay: device_list:261: control open (0): No such file or directory
ALSA lib conf.c:3700:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:951:(snd_ctl_open_noupdate) Invalid CTL hw:1
aplay: device_list:261: control open (1): No such file or directory


Running "/etc/init.d/alsasound restart" or "/sbin/alsa force-reload" outputs this

CODE
[root@longship bloodaxe]# /etc/init.d/alsasound restart
bash: /etc/init.d/alsasound: No such file or directory

[root@longship bloodaxe]# /sbin/alsa force-reload
bash: /sbin/alsa: No such file or directory
[root@longship bloodaxe]#



rolleyes.gif

Edited by abarbarian, 13 March 2012 - 05:02 PM.

Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#20 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 13 March 2012 - 05:26 PM

Running lspci -v outputs
CODE
01:00.1 Audio device: NVIDIA Corporation GF104 High Definition Audio Controller (rev a1)
        Subsystem: ASUSTeK Computer Inc. Device 835c
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fbffc000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Kernel driver in use: snd_hda_intel

02:08.0 Multimedia audio controller: C-Media Electronics Inc CMI8788 [Oxygen HD Audio]
        Subsystem: ASUSTeK Computer Inc. Virtuoso 66 (Xonar DS)
        Flags: bus master, medium devsel, latency 32, IRQ 18
        I/O ports at 9c00 [size=256]
        Capabilities: [c0] Power Management version 2
        Kernel driver in use: snd_virtuoso


and now from  # cat /proc/asound/modules I output


CODE
[root@longship bloodaxe]# cat /proc/asound/modules
0 snd_hda_intel
1 snd_virtuoso


So it looks like the sound cards have swapped places  blushing.gif


Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#21 OFFLINE   abarbarian

abarbarian

    Discussion Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 3,043 posts

Posted 13 March 2012 - 05:33 PM

The Arch Wiki also says this

QUOTE
Or better (source[1]):

$ cat /proc/asound/modules

Then add the names of your sound card modules to (source[2]):

/etc/modprobe.d/alsa.conf

options snd slots=snd-intel8x0

These entries ensure that the Intel 82801DB-ICH4 sound card will become card 0 and the PC speaker will become card 1. If there's more cards that have to fall into specific order, their modules can be given to “slots” option as follows:

/etc/modprobe.d/alsa.conf

options snd slots=snd-intel8x0,snd-interwave

This way cards driven by snd-intel8x0 module are enumerated before interwave cards.


Trouble is I do not have "/etc/modprobe.d/alsa.conf" only thing I have in "/etc/modprobe.d/" is a empty file "modprobe.conf"

rolleyes.gif
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#22 OFFLINE   V.T. Eric Layton

V.T. Eric Layton

    Nocturnal Slacker

  • Forum Admins
  • 17,161 posts

Posted 13 March 2012 - 06:39 PM

Sure... go ahead and ignore me. In the end, we always resort to the nuke from orbit option. wink.gif
Posted ImagePosted ImagePosted ImagePosted ImagePosted Image

#23 OFFLINE   sunrat

sunrat

    Discussion Deity

  • Forum Moderators
  • 4,197 posts

Posted 13 March 2012 - 06:53 PM

I mentioned it before, but again I suggest to go into BIOS and disable onboard sound.
registered Linux user number 324659  || The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted Image  Posted ImageLinuxBBQ
For the things we have to learn before we can do them, we learn by doing them.

#24 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 14,383 posts

Posted 13 March 2012 - 11:50 PM

QUOTE (abarbarian @ Mar 13 2012, 03:54 PM) <{POST_SNAPBACK}>
Running "/etc/init.d/alsasound restart" or "/sbin/alsa force-reload" outputs this

CODE
[root@longship bloodaxe]# /etc/init.d/alsasound restart
bash: /etc/init.d/alsasound: No such file or directory

[root@longship bloodaxe]# /sbin/alsa force-reload
bash: /sbin/alsa: No such file or directory
[root@longship bloodaxe]#



rolleyes.gif

I agree with Eric but the reason you are getting "No such file or directory" is because that is not how you stop|start|restart a daemon (alsa). In order to do this, you have two options:
CODE
/etc/rc.d/alsa start|stop|restart

or
CODE
rc.d stop|start|restart alsa


You can replace alsa with whatever daemon(service) you want to modify and use one of the three options listed. Ex:
CODE
rc.d restart alsa


The daemons(services) loaded at boot are listed at the bottom of /etc/rc.conf:. Ex:
CODE
╔═ comhack@Cerberus 10:48 PM
╚═══ ~-> cat /etc/rc.conf | grep DAEMONS
# DAEMONS
DAEMONS=(hwclock syslog-ng @network @netfs crond @alsa @dbus @sensors !ntop @mpd @openntpd !vboxdrv @sshd !tor @pgl)


BTW the @ means to background the service so the next one does not have to wait for the previous one to finish (faster bootup). The ! is used to disable the daemon from starting at boot.
Posted ImagePosted Image Posted Image
Comhack.com/CNI Radio/G+ Profile/Configs/PGP Key π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#25 OFFLINE   amenditman

amenditman

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,187 posts

Posted 14 March 2012 - 12:00 AM

QUOTE (sunrat @ Mar 13 2012, 05:53 PM) <{POST_SNAPBACK}>
I mentioned it before, but again I suggest to go into BIOS and disable onboard sound.

I use a Bose USB sound system.
Used to have a bunch of inconsistant sound troubles.
Went into the BIOS and disabled the onboard sound and now have much less trouble. Not none, just a lot less.
Tweak it 'til it breaks, then learn how to fix it.  L.I.F.E. (Linux Is For Everyone)
Registered Linux User # 474004 (06/16/2008)

The HeliOS Project  -  B.O.D.
A Child's Exposure to Technology Should Never Be
  Predicated On The Ability To Afford It




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users