Jump to content


How to disable the Windows Help feature


  • Please log in to reply
1 reply to this topic

#1 OFFLINE   Tushman

Tushman

    Forum Fiend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,804 posts

Posted 04 July 2011 - 03:19 PM

I recently had to buy a new keyboard and the those darn function keys are so ridiculously tiny that I often hit the F1 key inadvertently when renaming my files. This of course has the undesired effect of launching the Windows help feature.  Before someone chimes in about how you can rename files using the mouse (right click) and choosing the rename from the context menu, yes I know that people.   :rolleyes: I am fast typist and I don't like taking my hands off the keyboard if I don't have to.  I love using keyboard shortcuts whenever possible and for something like renaming files - it's just inconvenient to take my hands off the keyboard and back on again to type the new filename.  I much prefer using F2.In previous version of Windows (NT/2000/XP etc.) I would always disable the Windows help feature by going into the services applet and disabling the help service.  However, with Windows 7 that simple solution no longer works.After several days of searching, I finally found the solution.  Keep in mind that I am running Win 7/64-bit so for those of you running 32-bit, you may have to modify accordingly.1. Launch the registry editor as admin.  If you're already logged in with admin privileges, simply type "regedit" in the run command line.2.  Navigate to:HKEY_CLASSES_ROOT\CLSID\{8cec58ae-07a1-11d9-b15e-000d56bfe6ee}\LocalServer32In the right hand pane, you will see a default value.
%SystemRoot%\helppane.exe
Rename to:
%SystemRoot%\helppane.exe_BKUP
3.   Now do the same thing for the following registry key:HKEY_CLASSES_ROOT\Wow6432Node\TypeLib\{8cec5860-07a1-11d9-b15e-000d56bfe6ee}\1.0\0\win32A reboot is not required once you make the changes.  To test if you did this correctly, click on any BLANK space on the desktop and press F1.  Nothing should happen.** NOTE **  Even if you are logged in as the admin, there are certain keys in the registry where permissions are not granted to modify/delete/whatever.  This default setting is in place for security purposes so that malicious applications or viruses don't have cart blanche access to important system keys in the registry.  If you try to make the above changes and you get an error message such as "You don't have permissions to modify or change this setting", you will need to give yourself effective privileges for that subkey.  Follow the instructions in this link in order to do so.  Although it says "Windows XP & Server 2003" the directions are the same for Windows 7 users.Keep in mind this is just to disable the Windows 7 help menu.  Applications such as Microsoft Office have their own (separate) help menu functionality so the above fix does not apply.If anyone is running Win 7/32-bit and would like to post their own solution, please do so.  I would love to hear about it.

#2 OFFLINE   Corrine

Corrine

    The Mystical Rose

  • Forum Admins
  • 3,496 posts

Posted 05 July 2011 - 10:40 AM

As a reminder to readers of this tip, always back up the registry prior to making any changes.  See Back up the registry.
Posted Image

Take a walk through the "Security Garden" -- Where Everything is Coming up Roses!

Remember - A day without laughter is a day wasted.
May the wind sing to you and the sun rise in your heart.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users