Jump to content


OOo shows empty or partly empty toolbar and menu bar - v. 2.0.2


  • Please log in to reply
1 reply to this topic

#1 OFFLINE   striker

striker

    handyman

  • Honorary Moderators
  • 8,508 posts

Posted 10 September 2006 - 07:09 AM

After doing some updates through YUMEX Fedora worked flawlessly, that is until one day I fired up OOo writer to do some text editing. To my dismaze I saw only a few icons in the toolbar and just a couple of menus. When I hovered the mouse over any of them all menus and icons would disappear, leaving me with an empty toolbar and empty menu bar or just some parts of it. Toggling from not maximized mode to full maximized mode did reappear the menu bar and the toolbars icons, until you hovered the mouse over them again, then they would vanish into the gulag again. Duh !Here's an example of what I mean:http://www.oooforum....ight=menu iconsI googled, I searched the forums,the OOo forums and Fedora forums to no avail : the problem was mentioned at the OOo forums but left unsolved.This is what I did to solve the problem:I completely uninstalled OOo through YUMEX. I then deleted the .OpenOffice2 directory in the /home directory. Then rebooted. Previously I had downloaded the 2.0.3 version of OOo into my /home/deposit directory as a .tar.gz file;I extracted it into a new directory, opened it ,navigated to the RPMS directory in there and once in there I opened up a console and gave these commands :
$ su$ <password># rpm -Uvh *rpm..........# exit
for the standard installation in /opt.I then cd'd into the desktop-integration directory and executed
$ su$ <password># rpm -Uvh openoffice.org-redhat-menus-2.0.3-2.noarch.rpm..........# exit
After that I rebooted and fired up OOo : it all works flawlessly now, no more problems.The commands above came from the OOo Set Up Guide which you can download from here:http://documentation...ide2/index.htmlThere's also uninstall information in there if you need it (!).Hope this helps some poor soul asking what to do with the toolbar and menu problems.
Striker
still the same...

#2 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 10 September 2006 - 01:16 PM

Thanks Striker ! Good to know there is a solution !I think what happened is that OOo has special KDE/Gnome packages to adapt the look to the window manager . . . I see from your post that RH has openoffice.org-redhat-menus. Now with uploading updates for OOo, and not the "special" packages, they ( RH ) could potentially create a problem that looks like the situation you are describing.Anyway, glad you solved it and posted what you did to fix it. B) ;) Bruno




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users