Jump to content


PCLinuxOS No Sound


  • Please log in to reply
17 replies to this topic

#1 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 03:53 AM

Hello-I am having a little trouble and I am not sure where to go again. First I tried PCLinuxOS 9.1 Live CD and everything worked very well. Graphics and sound were all there. I finally made the choice to install it on my hard drive. Everything went smooth with no problems. I rebooted and then login. I recieved the following error message:

Quote

Sound server informational message:Error while initializing the sound driver:device: default can't be opened for playback (No such file or directory)The sound server will continue, using the null output device.
So I tried googling etc... and didn't really come up with anything... so I tried to see if I could do anything from the command line.

Quote

$ alsamixerNo mixer elems found
Has anyone ran into this or can maybe lead me in the right direction? Like I said the sound worked great on the Live CD...

#2 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 09 October 2005 - 04:03 AM

Hi GhostThe error you get is for the aRts-sound-server and should only affect the system-sounds ( and not playing mp3s in xmms for example ).You can disable aRts in the KDE control Center under "Sound" --> "Sound System" and use "an external player" for the system sounds ( KDE Control Center --> Look & Feel --> System Notifications --> "Player Settings" --> "Use an External Player" and fill in the box "/usr/bin/play"Next, if you still have no sound, please post the output of
$ aumix -q
:hmm: Burno

#3 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 04:24 AM

View PostBruno, on Oct 9 2005, 01:03 AM, said:

Hi GhostThe error you get is for the aRts-sound-server and should only affect the system-sounds ( and not playing mp3s in xmms for example ).You can disable aRts in the KDE control Center under "Sound" --> "Sound System" and use "an external player" for the system sounds ( KDE Control Center --> Look & Feel --> System Notifications --> "Player Settings" --> "Use an External Player" and fill in the box "/usr/bin/play"Next, if you still have no sound, please post the output of
$ aumix -q
:hmm: Burno
Hi Burno-Let me also add this... I don't have sound for anything. I cannot hear any audio streams or music files on my hard drive. When I open kmix there is only a mic setting, no master volume control, bass, etc....I can go to aRts Master Volume but I don't see an option to Use External Player...Here is aumix -q:

Quote

$ aumix -qbash: aumix: command not found
When I try to open streaming radio with Xmms I get:

Quote

Please check that:Your soundcard is configured properlyYou have the correct output plugin selectedNo other program is bloking the soundcard

Edited by Ghost, 09 October 2005 - 04:30 AM.


#4 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 09 October 2005 - 04:38 AM

Hi GhostCould you have a look if "aumix" is available in the synapticpackage manager ? Install it and do the "aumix -q" again.:hmm: Bruno

#5 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 04:49 AM

View PostGhost, on Oct 9 2005, 12:53 AM, said:

Hello-I am having a little trouble and I am not sure where to go again. First I tried PCLinuxOS 9.1 Live CD and everything worked very well. Graphics and sound were all there. I finally made the choice to install it on my hard drive. Everything went smooth with no problems. I rebooted and then login. I recieved the following error message:Has anyone ran into this or can maybe lead me in the right direction? Like I said the sound worked great on the Live CD...
I found it, installed it. Logged out/in and here is what I am getting:

Quote

$ aumix -qaumix:  error opening mixer
I don't know if this is a concern... When I installed PCLinuxOS I put the / and /home on different partitions. I don't assume that to be a problem. I am just trying to give you as much info. as possible. Like I said it worked great from the live CD.

Edited by Ghost, 09 October 2005 - 04:52 AM.


#6 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 09 October 2005 - 04:56 AM

View PostGhost, on Oct 9 2005, 10:49 AM, said:

I don't know if this is a concern... When I installed PCLinuxOS I put the / and /home on different partitions. I don't assume that to be a problem. I am just trying to give you as much info. as possible. Like I said it worked great from the live CD.
/home and / in separate partitions is good . . . that is the best you can do . . . . so there is not the problem.You wrote that you logged out . . . maybe reboot now and when you get the progressbar during boot please press the Esc-key and see if there are any errors you can spot.:hmm: Bruno

#7 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 05:04 AM

View PostBruno, on Oct 9 2005, 01:56 AM, said:

/home and / in separate partitions is good . . . that is the best you can do . . . . so there is not the problem.You wrote that you logged out . . . maybe reboot now and when you get the progressbar during boot please press the Esc-key and see if there are any errors you can spot.:hmm: Bruno
Ok rebooted... Everything is showing pass. No fails on load. aumix -q is still showing the same error....

#8 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 09 October 2005 - 05:11 AM

Strange . . . . . :'(I take it that you see a gray ( and not blue ) "Kmix" icon next to the clock . . . can you click on it and let the mixer window pop up . . . then see if by changing the green dotsavobe the sliders you see the color of the Kmix icon change to blue ( sometimes you have to activate the "headphone" slider ):hmm: Bruno

#9 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 05:13 AM

View PostBruno, on Oct 9 2005, 02:11 AM, said:

Strange . . . . . :'(I take it that you see a gray ( and not blue ) "Kmix" icon next to the clock . . . can you click on it and let the mixer window pop up . . . then see if by changing the green dotsavobe the sliders you see the color of the Kmix icon change to blue ( sometimes you have to activate the "headphone" slider ):hmm: Bruno
Actually I don't see anything next to the clock. No speaker, nothing. If I go to Sound -> KMix the speaker shows up but when you open it there are no output settings.

Edited by Ghost, 09 October 2005 - 05:15 AM.


#10 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 09 October 2005 - 05:18 AM

Okay . . in that case I need you to boot the Live CD and do
$ su< password ># /sbin/lsmod | egrep -i snd\|sound\|audio\|game
Then post the output on the forumAfter that boot the HD installed PCLos and repeat the commands so we can compare the outputB) Bruno

#11 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 09 October 2005 - 05:26 AM

PART 2If the outputs from the post above are very different try this:Boot the Live version again and go to "PCLos Control Center" --> "Hardware" --> "Configure Alsa or OSS drivers for your soundcard" . . . note down on paper what you see there.Then boot the HD install and go to "PCLos Control Center" --> "Hardware" --> "Configure Alsa or OSS drivers for your soundcard"  . . . and make the settings the same.:hmm: Bruno

#12 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 06:45 AM

Live CD

Quote

# /sbin/lsmod | egrep -i snd\|sound\|audio\|gamesnd-usb-audio          60096  1snd-usb-lib            10880  1 snd-usb-audiosnd-seq-oss            28608  0snd-seq-midi-event      5888  1 snd-seq-osssnd-seq                44912  4 snd-seq-oss,snd-seq-midi-eventsnd-pcm-oss            46432  0snd-mixer-oss          15584  1 snd-pcm-osssnd-intel8x0           27552  1snd-emu10k1            81828  1snd-rawmidi            18688  2 snd-usb-lib,snd-emu10k1snd-seq-device          6668  4 snd-seq-oss,snd-seq,snd-emu10k1,snd-rawmidisnd-ac97-codec         68152  2 snd-intel8x0,snd-emu10k1snd-pcm                75748  5 snd-usb-audio,snd-pcm-oss,snd-intel8x0,snd-emu10k1,snd-ac97-codecsnd-timer              19524  3 snd-seq,snd-emu10k1,snd-pcmsnd-page-alloc          7364  3 snd-intel8x0,snd-emu10k1,snd-pcmsnd-util-mem            3232  1 snd-emu10k1snd-hwdep               6688  1 snd-emu10k1snd                    43716  19 snd-usb-audio,snd-seq-oss,snd-seq,snd-pcm-oss,snd-mixer-oss,snd-intel8x0,snd-emu10k1,snd-rawmidi,snd-seq-device,snd-ac97-codec,snd-pcm,snd-timer,snd-hwdepsoundcore               6656  1 sndusbcore               101400  12 snd-usb-audio,snd-usb-lib,usbmouse,pwc,usbhid,visor,usbserial,usb-storage,ehci-hcd,ohci-hcd,uhci-hcd
HD

Quote

# /sbin/lsmod | egrep -i snd\|sound\|audio\|gamesnd-usb-audio          60096  1snd-pcm                75748  1 snd-usb-audiosnd-timer              19524  1 snd-pcmsnd-page-alloc          7364  1 snd-pcmsnd-usb-lib            10880  1 snd-usb-audiosnd-rawmidi            18688  1 snd-usb-libsnd-seq-device          6668  1 snd-rawmidisnd                    43716  7 snd-usb-audio,snd-pcm,snd-timer,snd-rawmidi,snd-seq-devicesoundcore               6656  1 sndusbcore               100856  9 snd-usb-audio,snd-usb-lib,usbmouse,usbhid,pwc,uhci-hcd,usb-storage,ehci-hcd
I will do part 2 now....

#13 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 09 October 2005 - 06:53 AM

View PostGhost, on Oct 9 2005, 12:45 PM, said:

Live CDI will do part 2 now....
Yep "PART 2" should do the trick because now the HD install loads the wrong modules ( not the same as the "Live" ) . . .  .and the PCLos Control Center is where you can change this ( and once changed it will hold the setting on the next reboot(s) ):hmm: Bruno

#14 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 07:32 AM

View PostBruno, on Oct 9 2005, 03:53 AM, said:

Yep "PART 2" should do the trick because now the HD install loads the wrong modules ( not the same as the "Live" ) . . .  .and the PCLos Control Center is where you can change this ( and once changed it will hold the setting on the next reboot(s) ):hmm: Bruno
Thanks for all of your help Bruno-Now I just need to figure out how to edit this. As soon as I do I will be sure to post back and let you know what happens...~GHOST~

#15 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 10:55 PM

Got it!!!!!Well I don't know how I finally stumbled across it but here is what I did to get it up and running...modprobe snd-seq-ossalsaconfI don't the the modprobe snd-seq-oss had anything to do with it. I still couldn't get into the alsamixer.I ran alsaconf and went through the steps....Up and running finally!!!!!! Now the question is will it still work when I reboot? The modprobe.conf was edited by the alsaconf. I will keep my fingers crossed and give it a shot!Thanks Bruno for all of you help... I know it isn't easy to diag. problems like this over the net but I do thank you. I was a mechanic for 10 years and tried my best to do the samething... :w00t:  :thumbsup:  All I have to say to the bugs right now is  :harhar:

Edited by Ghost, 09 October 2005 - 11:37 PM.


#16 OFFLINE   rolanaj

rolanaj

    Board Bigwig

  • Forum MVP
  • 2,623 posts

Posted 09 October 2005 - 11:16 PM

Congratulations, don't you love it when stuff comes together.
Registered Linux User #554733

#17 OFFLINE   Ghost

Ghost

    Post Master

  • Members
  • PipPipPipPip
  • 101 posts

Posted 09 October 2005 - 11:39 PM

View Postrolanaj, on Oct 9 2005, 08:16 PM, said:

Congratulations, don't you love it when stuff comes together.
Yes it is! I logged and then back no more error messages!!! I am just happy that I finally have things going!

#18 OFFLINE   Bruno

Bruno

    Le Professeur Pingouin

  • Admin Emeritus
  • 37,904 posts

Posted 10 October 2005 - 03:48 AM

Congrats Ghost . . . . . Great job !!!Enjoy your sound. :thumbsup::thumbsup: Bruno




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users