Jump to content


iPad Dropping Wifi Connection - Set Static IP


  • Please log in to reply
6 replies to this topic

#1 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,334 posts

Posted 14 April 2016 - 07:30 PM

More problems with my technical nemesis Lillian tonight. Yes she has an iPad as well as a Windows 10 PC she can screw up. She reported that she suddenly lost Internet connection with her iPad although her Windows PC was still on the Internet. I don't know much about iPads but I told her I'd try. She has a Hitron CGN2-ROG gateway supplied by Rogers, the ISP.
I took over my Android tablet and it connected with no problem but the iPad was dead. No Internet reported in Safari and Chrome. Wifi was on. I renewed the lease on the iPad's wifi, then reset the WPA2 password. No connection. I rebooted the gateway. No connection. Then looking at the IP info it appeared that the client IP was right but instead of a subnet mask of 255.255.255.0 it was 255.255.0.0 This indicated that the iPad isn't playing very nice with the DHCP server on the gateway.
I set up the iPad with a static IP 192.168.0.5 (which I believe is outside the DHCP range of the gateway) and made sure the subnet mask and gateway were right. After restarting the iPad I got back online.
My question for iPad users is - does this make sense as a troubleshooting method? Have you had similar problems with DHCP servers?
Posted Image

Registered Linux User 445659

#2 OFFLINE   ebrke

ebrke

    Board Bigwig

  • Forum MVP
  • 2,708 posts

Posted 14 April 2016 - 08:21 PM

I'm looking forward to seeing if others have had this issue or if it's just Lillian (could she possibly be emanating some kind of weird force field that causes electronics to go bonkers?).
Registered Linux User 344759

#3 OFFLINE   LilBambi

LilBambi

    Australisches Googler

  • Forum Admins
  • 22,513 posts

Posted 14 April 2016 - 09:39 PM

Interesting. I have an iPhone and have never had that issue. Sounds like part of her Network card is failing in the iPad. If it's still under Applecare, you might encourage her to take it to the Apple Store to get it fixed before her Applecare runs out.
Bambi
AKA Fran

Posted Image
My Public Key for Email :: BambisMusings Blog :: Fran's Computer Services Blog :: MyPassionIsBooks Blog :: 5BuckReview :: CNIRadio
"The Net interprets censorship as damage and routes around it." ~John Gilmore (Time Magazine, Dec 6, 1993)

#4 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,334 posts

Posted 15 April 2016 - 08:34 AM

I'll give her a few days with the static IP and if she has more trouble I'll definitely encourage her to take it in the to Apple store for a checkup.
The gateway she has is really a piece of garbage. Rogers only rents you a combination modem/router (and the router side stinks.) So for best results you have the techs dumb the router down to a bridged modem and put on your own router. But I would never in a million years suggest that to Lillian.
That said, I wouldn't rule out a basic incompatibility between Rogers' gateway and the iPad. I'm taking DHCP out of the equation so maybe that will help.
Posted Image

Registered Linux User 445659

#5 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,334 posts

Posted 16 April 2016 - 07:06 PM

Haven't heard anything so I assume her iPad is still working.
I read on the Net that if you have a crappy router (check!) it might be too slow sending the IP to the iPad. The iPad gets impatient and assigns an IP itself which will be wrong (check!) The workaround is to set up a static IP which I have done. Hopefully this solves the problem.

Edited by raymac46, 16 April 2016 - 07:07 PM.

Posted Image

Registered Linux User 445659

#6 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,334 posts

Posted 21 April 2016 - 08:02 AM

No further input from Lillian so I'll mark it SOLVED for now. Stay tuned for the next episode of "As the iPad Churns...." or "PC Hospital."

Edited by raymac46, 21 April 2016 - 08:03 AM.

Posted Image

Registered Linux User 445659

#7 OFFLINE   LilBambi

LilBambi

    Australisches Googler

  • Forum Admins
  • 22,513 posts

Posted 02 May 2016 - 07:08 PM

Hey if it works, don't fix it :D
Bambi
AKA Fran

Posted Image
My Public Key for Email :: BambisMusings Blog :: Fran's Computer Services Blog :: MyPassionIsBooks Blog :: 5BuckReview :: CNIRadio
"The Net interprets censorship as damage and routes around it." ~John Gilmore (Time Magazine, Dec 6, 1993)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users