Jump to content


Google chrome won't stay as default in Siduction 3.0 LXQT DE


  • Please log in to reply
9 replies to this topic

#1 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,204 posts

Posted 10 July 2018 - 09:32 PM

I need and want google chrome as my default browser in Siduction Especially when I click on a link in Thunderbird. I have changed chrome as the default both visually and from the command line, But it still reverts to Firefox when I click a link in Thunderbird. I want chrome to be default system wide. There has to be a file somewhere were I can do this. have been unable to find it using google to search. any help appreciated.

I Have done more research and it appears that the problem has something to do with xdg and the magnet not being installed in LXQT for other browsers. It is installed for one of the torrent apps, not sure which one
Mel
:angry2:

I solved the problem sort of. I removed firefox completely. now the only browser is Google-Chrome.

Edited by mhbell, 11 July 2018 - 12:04 PM.

Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#2 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,633 posts

Posted 11 July 2018 - 06:52 AM

Well you could try
xdg-mime default google-chrome text/html

Or add export BROWSER="google-chrome" to your ~/.bashrc or ~/.zshrc file.
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#3 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,633 posts

Posted 11 July 2018 - 06:55 AM

Here is the official way to do it on LXDE. I would imagine that the instructions would be the same on LXQT. As root, run this:
update-alternatives --config x-www-browser

https://wiki.lxde.or.../LXDE:Questions
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#4 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,204 posts

Posted 11 July 2018 - 10:02 AM

View Postsecuritybreach, on 11 July 2018 - 06:55 AM, said:

Here is the official way to do it on LXDE. I would imagine that the instructions would be the same on LXQT. As root, run this:
update-alternatives --config x-www-browser

https://wiki.lxde.or.../LXDE:Questions
I tried this one but it still reverts to Firefox.

Quote


Well you could try

xdg-mime default google-chrome text/html
I tried this one, but got a malformed syntax "google-chrome" looks like google chrome is not recognized. in the Siduction forum some are saying it is a bug because LXQT did not include Chrome even though it is a XDG problem. will have to wait and see what develops.
Mel

Edited by mhbell, 11 July 2018 - 10:50 AM.

Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#5 OFFLINE   sunrat

sunrat

    Thread Kahuna

  • Forum Moderators
  • 5,586 posts

Posted 11 July 2018 - 10:52 AM

For Thunderbird, set Preferences > Attachments for http and https to firefox. The update-alternatives command is global but Thunderbird doesn't seem to respect its authoritah.
registered Linux user number 324659  ||    The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted ImagePosted Image
For the things we have to learn before we can do them, we learn by doing them.

#6 OFFLINE   Hedon James

Hedon James

    Topic Cop

  • Members
  • PipPipPipPipPipPipPip
  • 817 posts

Posted 11 July 2018 - 11:23 AM

I'm not sure what you've already changed mhbell, and I'm only familiar with the defaults (haven't changed anything drastically, as I'm still playing with "stock" items and monitoring long-term stability), but there's a setting in LXQt Session Settings>Default Applications that you can select default terminal emulation and web browser with pull-down menus, or by search for the desired cli/command.

Although, as I type this, I'm noticing that qupzilla is the default web browser (with firefox as a pull down choice), but there's no qupzilla in my program menu.  Firefox is the only browser on my Siduction LXQt version:  up-to-date Patience.  So either I've found a bug, or this isn't the place to change that setting.  Dunno...

#7 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,204 posts

Posted 11 July 2018 - 12:08 PM

View PostHedon James, on 11 July 2018 - 11:23 AM, said:

I'm not sure what you've already changed mhbell, and I'm only familiar with the defaults (haven't changed anything drastically, as I'm still playing with "stock" items and monitoring long-term stability), but there's a setting in LXQt Session Settings>Default Applications that you can select default terminal emulation and web browser with pull-down menus, or by search for the desired cli/command.

Although, as I type this, I'm noticing that qupzilla is the default web browser (with firefox as a pull down choice), but there's no qupzilla in my program menu.  Firefox is the only browser on my Siduction LXQt version:  up-to-date Patience.  So either I've found a bug, or this isn't the place to change that setting.  Dunno...
I finally had to use drastic measures. I removed Firefox Completely including all conf, and data files for Firefox. at first I tried just changing the name in Firefox, but it just installed a fresh version on boot up. So I removed it and now Chrome works fine and is the default.
Mel
Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#8 OFFLINE   Hedon James

Hedon James

    Topic Cop

  • Members
  • PipPipPipPipPipPipPip
  • 817 posts

Posted 11 July 2018 - 02:17 PM

Well, at least you got it doing what you want it to.  Here's a link that would've been helpful...for future reference:

https://forum.siduct...hp?topic=6158.0

kudos to sunrat for spotlighting the Thunderbird app/link issue, which you may still need to address in the future?

#9 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,204 posts

Posted 11 July 2018 - 02:32 PM

View PostHedon James, on 11 July 2018 - 02:17 PM, said:

Well, at least you got it doing what you want it to.  Here's a link that would've been helpful...for future reference:

https://forum.siduct...hp?topic=6158.0

kudos to sunrat for spotlighting the Thunderbird app/link issue, which you may still need to address in the future?
Will check it out but its not needed now because the only reason I kept Firefox was to have a backup browser. I downloaded Chromium for my backup browser. all is working fine now.
Mel
Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#10 OFFLINE   sunrat

sunrat

    Thread Kahuna

  • Forum Moderators
  • 5,586 posts

Posted 11 July 2018 - 08:40 PM

View Postsunrat, on 11 July 2018 - 10:52 AM, said:

For Thunderbird, set Preferences > Attachments for http and https to firefox. The update-alternatives command is global but Thunderbird doesn't seem to respect its authoritah.
Oops, I just realised I told you how to set Firefox as Thunderbird's web page default. It was graveyard shift time here and I had just got home from a busy evening's work. :unsure: :rolleyes:
You should have been able to set Chrome in Preferences and had it open links without removing Firefox.
registered Linux user number 324659  ||    The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted ImagePosted Image
For the things we have to learn before we can do them, we learn by doing them.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users