Jump to content


Window Maker

window manager window maker arch docker dock linux

  • Please log in to reply
136 replies to this topic

#126 OFFLINE   abarbarian

abarbarian

    Thread Kahuna

  • Forum MVP
  • 5,611 posts

Posted 01 September 2017 - 07:19 AM

View Postsecuritybreach, on 31 August 2017 - 11:41 AM, said:

Looks nice but all that movement would drive me nuts...

I thought the same but it fades into the background after a while. :th_run-around-smiley: Hasn't affected me at all :hysterical:
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#127 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,763 posts

Posted 01 September 2017 - 07:20 AM

Nice B)
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#128 OFFLINE   abarbarian

abarbarian

    Thread Kahuna

  • Forum MVP
  • 5,611 posts

Posted 24 May 2018 - 06:48 PM

Liquid Lemur Linux (aka: Lemur)

Quote

Liquid Lemur Linux (aka: Lemur) is a custom Debian distro, based on the Stable branch. Currently we have one desktop available, a Hybrid Window Maker (shown above). Available in 64bit only. Lemur includes the latest Window Maker base, custom Lemur and Window Maker apps, and lots of custom scripts / artwork. It was created to fill the void left behind by others in the same class. The goal was simple — create a fairly fast and functional base distro, that was also pleasing to the eyes. Liquid Lemur was never intended to be a “Beginner’s” distro. However, anyone familiar with Linux should be able to figure it out. We also offer help, via this site, to those that may need it. At the same time, we also accept help and suggestions from others that may have more experience in the field, as we are by no means “experts.” Liquid Lemur is a hybrid of sorts. Taking bits and pieces from many other distros, to build a more complete package. It is a growing toddler in the distro world, but continues to evolve with each release. We welcome the ideas and suggestions from the community. Although we may not use them, we will at least listen.

Posted Image

Hurray finally a developer with exquisite taste and sense.  :hysterical:
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#129 OFFLINE   abarbarian

abarbarian

    Thread Kahuna

  • Forum MVP
  • 5,611 posts

Posted 25 May 2018 - 06:35 AM

Posted Image

I start windowmaker from my .initrc with startx. Lately this no longer works and I get the above when trying to use startx. If I change my .initrc to use icewm I can use startx and icewm runs perfectly.
I am a bit puzzled as to why one runs and the other does not.
Any ideas folks ? :'(
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#130 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,763 posts

Posted 25 May 2018 - 06:45 AM

<p>You are missing a library as noted in the error:

error loading shared libraries: libMagickWant-7.Q16HDRI.so.5

That library is part of imagemagick so re<span style="color: #121112">
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#131 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,763 posts

Posted 25 May 2018 - 06:47 AM

View Postabarbarian, on 25 May 2018 - 06:35 AM, said:

I am a bit puzzled as to why one runs and the other does not.
Any ideas folks ? :'(

That is because imagemagick is not a dependency of icewm. This had nothing to do with Xorg or Nvidia as this is purely related to windowmaker and a broken dependency.
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#132 OFFLINE   abarbarian

abarbarian

    Thread Kahuna

  • Forum MVP
  • 5,611 posts

Posted 25 May 2018 - 06:59 AM

View Postsecuritybreach, on 25 May 2018 - 06:45 AM, said:

<p>You are missing a library as noted in the error:

error loading shared libraries: libMagickWant-7.Q16HDRI.so.5

That library is part of imagemagick so re<span style="color: #121112">

Ah ha I was heading in that direction and had tried to google for libMagickWant-7.Q16HDRI.so.5 but did not get any really useful results, in fact I think there were only eight results in total.
I think I will try  the Arch Window Maker program page
https://aur.archlinu...es/windowmaker/
where it looks like there is some information. I'll have to chase this up later as I have to go and get my motorcycle tested this afternoon and I need lunch before I ride of into the sunset. :breakfast:
Thanks fer the help.
Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#133 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,763 posts

Posted 25 May 2018 - 07:41 AM

Yup, the top comment:

Quote


Refutationalist commented on 2018-04-19 12:18

Based on poking around from the link below, I found a imagemagick7 patch and added it to the PKGBUILD:
https://vis.nu/crap/....8-3.src.tar.gz


I actually didn't even look at the AUR package link for windowmaker, I just knew that MagickWant was part of imagemagick.
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#134 OFFLINE   abarbarian

abarbarian

    Thread Kahuna

  • Forum MVP
  • 5,611 posts

Posted 25 May 2018 - 01:12 PM

View Postsecuritybreach, on 25 May 2018 - 07:41 AM, said:

Yup, the top comment:

Quote


Refutationalist commented on 2018-04-19 12:18

Based on poking around from the link below, I found a imagemagick7 patch and added it to the PKGBUILD:
https://vis.nu/crap/....8-3.src.tar.gz


I actually didn't even look at the AUR package link for windowmaker, I just knew that MagickWant was part of imagemagick.

Bike passed its Ministry test so I have a green light for riding legally for another year. :clap:

The package in the AUR is the same as the one I have so I am guessing that that patch is already included as it is over a month old. I think that imagemagick has been upgraded since which I suspect is causing the problem.
I have tried to backdate the imagemagick as per the wiki
https://wiki.archlin...ade_one_package
but keep on failing
[longship@18:03:10 ~]$ pacaur -U https://archive.archlinux.org/packages/imagemagick-7.0.7.34-1-x86_64.pkg.tar.xz
loading packages...
error: '/var/cache/pacman/pkg/imagemagick-7.0.7.34-1-x86_64.pkg.tar.xz': package missing required signature
I tried downloading the package and its sig file but installing fails as I need a libmagick file which I can not find anywhere.

As my problem only surfaced when I rebooted I am guessing the dev has not had this problem as he may not have done a reboot lately. SO I will mention my problem on the AUR page and see if I get a response. If not I may try the rollback the whole system thing.
:breakfast:

Oh and I tried googling libMagickWant-7.Q16HDRI.so.5 and got this

Quote

Showing results for libMagickCore-7.Q16HDRI.so.5
No results found for libMagickWant-7.Q16HDRI.so.5

Some of the results did mention libMagickWant but they were not really of any help. Now if only I had a magic wand to wave around.

Edited by abarbarian, 25 May 2018 - 01:15 PM.

Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#135 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,763 posts

Posted 25 May 2018 - 02:14 PM

View Postabarbarian, on 25 May 2018 - 01:12 PM, said:

I have tried to backdate the imagemagick as per the wiki
https://wiki.archlin...ade_one_package
but keep on failing
[longship@18:03:10 ~]$ pacaur -U https://archive.archlinux.org/packages/imagemagick-7.0.7.34-1-x86_64.pkg.tar.xz
loading packages...
error: '/var/cache/pacman/pkg/imagemagick-7.0.7.34-1-x86_64.pkg.tar.xz': package missing required signature
I tried downloading the package and its sig file but installing fails as I need a libmagick file which I can not find anywhere.

The signature has to be loaded in pacman, not just in the same location. https://wiki.archlin...Package_signing

I am heading out of town for the weekend and will probably not be available until Tuesday.

Did you ever initiate the package signing and keys?

https://wiki.archlin...e_signing#Setup
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#136 OFFLINE   abarbarian

abarbarian

    Thread Kahuna

  • Forum MVP
  • 5,611 posts

Posted 25 May 2018 - 03:48 PM

View Postsecuritybreach, on 25 May 2018 - 02:14 PM, said:

View Postabarbarian, on 25 May 2018 - 01:12 PM, said:

I have tried to backdate the imagemagick as per the wiki
https://wiki.archlin...ade_one_package
but keep on failing
[longship@18:03:10 ~]$ pacaur -U https://archive.archlinux.org/packages/imagemagick-7.0.7.34-1-x86_64.pkg.tar.xz
loading packages...
error: '/var/cache/pacman/pkg/imagemagick-7.0.7.34-1-x86_64.pkg.tar.xz': package missing required signature
I tried downloading the package and its sig file but installing fails as I need a libmagick file which I can not find anywhere.

The signature has to be loaded in pacman, not just in the same location. https://wiki.archlin...Package_signing

I am heading out of town for the weekend and will probably not be available until Tuesday.

Did you ever initiate the package signing and keys?

https://wiki.archlin...e_signing#Setup

Yup did the, below, when I first set Arch up.
    

Quote

Initializing the keyring

To set up the pacman keyring use:
# pacman-key --init

I'll figure something out or the dev will update the package sometime. I'm in no rush as I am having fun with icewm. There is the possibility that my problem is caused by some other factor entirely.
Have a groovy time on you break.
:clap:

Edited by abarbarian, 25 May 2018 - 03:48 PM.

Install ARCH
You'll never need to install it again
"I did and I'm really happy"

Posted Image~~~~~~~~~~~~~Posted Image

#137 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,763 posts

Posted 25 May 2018 - 05:34 PM

Thanks man
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984





Also tagged with one or more of these keywords: window manager, window maker, arch, docker, dock, linux

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users