Jump to content


BS 0x0000007e


  • Please log in to reply
14 replies to this topic

#1 OFFLINE   DarkSerge

DarkSerge

    Thread Head

  • Members
  • PipPipPipPipPipPip
  • 665 posts

Posted 22 January 2017 - 07:47 AM

I'm getting Blue Screen stop error code 0x0000007e in Windows 10 Home.

Quick Google search shows me it could be a bad driver. How can I figure out which one? I'm not really sure which was the last driver to be updated or installed. Maybe my video driver.

There is a dump file (should be anyway) I can find.

I know I've done this a long time ago back in Windows XP. Don't really remember how, since it was ages ago.\


Update:

In the system event viewer, just moments before the entry that gives me info about the error code mentioned above, there's an error entry stating:

The amdacpksd service failed to start due to the following error:
The system cannot find the file specified.

Which could be the problem.

Edited by DarkSerge, 22 January 2017 - 07:57 AM.

~DarkSerge

#2 ONLINE   ebrke

ebrke

    Board Bigwig

  • Forum MVP
  • 2,605 posts

Posted 22 January 2017 - 02:59 PM

Appears to be a kernel device driver:
http://www.freefixer...ksd.sys-147155/

If you Google, there are some links to download the file, but I have no idea if any are reliable sources. Someone with more knowledge should be along to give you better feedback soon.
Registered Linux User 344759

#3 OFFLINE   DarkSerge

DarkSerge

    Thread Head

  • Members
  • PipPipPipPipPipPip
  • 665 posts

Posted 23 January 2017 - 04:27 PM

There is an updated driver set that was released on the 17th, so I'm going to run the installation and see if that solves any issues.
~DarkSerge

#4 OFFLINE   DarkSerge

DarkSerge

    Thread Head

  • Members
  • PipPipPipPipPipPip
  • 665 posts

Posted 24 January 2017 - 07:23 PM

Updated the driver as I said I would above but still got another error code as mentioned above. I could try reinstalling using the clean install option and see what happens.

What can I use to read the dump file to find out where the system stopped?

It usually happens when the system is sitting idle. I come back to it and find the system has restarted itself. I check the system logs and there's an entry for the 0x0000007e error.

Update:

Installed the WinDbg kit because I remember using that in the past for dump files and tried it to see what I can find. dxgmms2.sys comes up a few times towards the end of the file, so maybe that's my problem.

Edited by DarkSerge, 24 January 2017 - 07:44 PM.

~DarkSerge

#5 OFFLINE   Corrine

Corrine

    The Mystical Rose

  • Forum Admins
  • 3,987 posts

Posted 25 January 2017 - 12:38 PM

I have a friend who specializes in helping with BSODs and have contacted him to see if he has time to assist.

Edit:  I heard back already and usasma asked that you run run the reports requested in the Blue Screen of Death (BSOD) Posting Instructions.  After the reports are run, please attach them here as a reply.  Then I'll contact him so he can evaluate and provide instructions.  (Note:  usasma is a long-time Microsoft MVP and is very knowledgeable.)
Posted Image

Take a walk through the "Security Garden" -- Where Everything is Coming up Roses!

Remember - A day without laughter is a day wasted.
May the wind sing to you and the sun rise in your heart.

#6 OFFLINE   DarkSerge

DarkSerge

    Thread Head

  • Members
  • PipPipPipPipPipPip
  • 665 posts

Posted 25 January 2017 - 07:53 PM

Wow, Thank you for this help!

I ran the reports. I don't see options to reply and attach the zip file, so I uploaded it to my Google Drive: https://drive.google...aGVxNm1vdUh1bjg

If it helps, the last BSOD was Jan. 24 around 6pm - 6:15pm. It's the third crash I've had since I noticed the problems and it usually doesn't happen every day.

Edited by DarkSerge, 25 January 2017 - 08:02 PM.

~DarkSerge

#7 OFFLINE   Corrine

Corrine

    The Mystical Rose

  • Forum Admins
  • 3,987 posts

Posted 26 January 2017 - 10:25 AM

I just notified usasma that you replied.  I'm not sure about his work schedule plus he'll need time to review the reports.  He'll likely reply this evening or tomorrow, depending on his schedule.
Posted Image

Take a walk through the "Security Garden" -- Where Everything is Coming up Roses!

Remember - A day without laughter is a day wasted.
May the wind sing to you and the sun rise in your heart.

#8 OFFLINE   usasma

usasma

    Message Adept

  • Members
  • PipPipPip
  • 88 posts

Posted 26 January 2017 - 10:31 AM

I'm here.  Waiting on a repair person for my dishwasher, so I may be interrupted.
But at least I can get a start on it.

#9 OFFLINE   usasma

usasma

    Message Adept

  • Members
  • PipPipPip
  • 88 posts

Posted 26 January 2017 - 11:43 AM

No systeminfo.txt report in the uploaded files.
As such, I can't see how many Windows Update hotfixes are installed.
Please double check for any new Windows Updates.  It only takes one update to cause a problem, so it's essential that you have all of them.  The actual number is not important.  Rather it's important that you checked manually, installed any available updates, and didn't experience any errors when checking or updating.

Your UEFI/BIOS (version IRKT54AUS) dates from 2015.  Please check at the manufacturer's website to see if there are any UEFI/BIOS updates available for your system.  If you are able to install the update through Windows (without booting from an external drive), then go ahead and update it.  WARNING - if the computer might shut down during this procedure, please don't do it, as this may physically damage the computer and prevent it from booting.
FYI - W8 and W10 communicate more with the UEFI/BIOS than previous versions of Windows, so it's important to ensure that the UEFI/BIOS is kept up to date (and that outdated UEFI/BIOS' may be the cause of some compatibility issues).

There are 3 BSOD events in the WER section of the MSINFO32 report, yet there are 9 Live Kernel Events
This can be suggestive of a hardware problem.  Please start with these free hardware diagnostics:  http://www.carrona.org/hwdiag.html
Please run ALL of the tests and let us know the results.

AMD OverDrive (AODDriver2.sys) is either a stand-alone application, or a component of the AMD VISION Engine Control Center.  This driver is known to cause BSOD's on some Windows systems.

Quote

NOTE:  these symptoms were from the previous release of OverDrive.  The new release uses the same driver name, but is dated from 4 November 2013.

Quote

Please un-install all AMD/ATI video stuff from Control Panel...Programs...Un-install a program.
Please note that I stated "video stuff", as some integrated processors may have the graphics chip built in (which may involve the chipset software).
Then, download (but DO NOT install) a fresh copy of the ATI drivers from http://www.amd.com (in the upper right corner of the page)
Use this procedure to install the DRIVER ONLY:  http://www.sysnative...ation-procedure

If the device (AODDriver or AODDriver4.01) remains a problem, open Device Manager, select the "View" item.
Then select "Show hidden devices" and scroll down to the Non-Plug and Play Drivers section.
Locate the AODDriver entry, right click on it and select "Un-install".  Reboot for changes to take affect.

Sometimes the entry will remain in Device Manager even though you've removed it.  So, open up Device Manager and check for the AODDriver4.2.0 (it may have another number).  Right click on it and select "Uninstall".  If it asks to remove software, put a check in the box.  Then click on OK.
Sometimes the driver remains and continues to cause BSOD's.  If this is the case for you, post back and we'll give further instructions for safely removing it.

If overclocking, please stop. Remove the overclock and return the system to stock/standard values while we're troubleshooting. Once the system is stable again, feel free to resume the overclocking.

If this doesn't fix the problem, please run Driver Verifier according to these instructions:  http://www.carrona.org/verifier.html


Analysis:
The following is for information purposes only. The following information contains the relevant information from the blue screen analysis:
**************************Tue Jan 24 18:13:26.791 2017 (UTC - 5:00)**************************
Loading Dump File [C:\Users\john\SysnativeBSODApps\012417-27875-01.dmp]
Windows 10 Kernel Version 14393 MP (4 procs) Free x64
Built by: 14393.693.amd64fre.rs1_release.161220-1747
System Uptime:1 days 2:38:17.833
Probably caused by :dxgmms2.sys ( dxgmms2!VidMmInterface+26c76 )
BugCheck 1000007E, {ffffffffc0000005, fffff80abe110406, ffffcf80bd30a558, ffffcf80bd309d80}
BugCheck Info: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff80abe110406, The address that the exception occurred at
Arg3: ffffcf80bd30a558, Exception Record Address
Arg4: ffffcf80bd309d80, Context Record Address
PROCESS_NAME:  System
BUGCHECK_STR:  AV
FAILURE_BUCKET_ID: AV_dxgmms2!VidMmInterface
  BIOS Version   IRKT54AUS
  BIOS Release Date 08/20/2015
  Manufacturer   LENOVO
  Product Name   90BG003LUS
  Baseboard Product Bantry CRB
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Sun Jan 22 06:11:14.924 2017 (UTC - 5:00)**************************
Loading Dump File [C:\Users\john\SysnativeBSODApps\012217-25218-01.dmp]
Windows 10 Kernel Version 14393 MP (4 procs) Free x64
Built by: 14393.693.amd64fre.rs1_release.161220-1747
System Uptime:1 days 12:34:08.710
Probably caused by :dxgmms2.sys ( dxgmms2!VidMmInterface+26c76 )
BugCheck 1000007E, {ffffffffc0000005, fffff80f81d40406, ffffc900898de558, ffffc900898ddd80}
BugCheck Info: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff80f81d40406, The address that the exception occurred at
Arg3: ffffc900898de558, Exception Record Address
Arg4: ffffc900898ddd80, Context Record Address
PROCESS_NAME:  System
BUGCHECK_STR:  AV
FAILURE_BUCKET_ID: AV_dxgmms2!VidMmInterface
  BIOS Version   IRKT54AUS
  BIOS Release Date 08/20/2015
  Manufacturer   LENOVO
  Product Name   90BG003LUS
  Baseboard Product Bantry CRB
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
**************************Fri Jan 20 17:36:45.253 2017 (UTC - 5:00)**************************
Loading Dump File [C:\Users\john\SysnativeBSODApps\012017-33125-01.dmp]
Windows 10 Kernel Version 14393 MP (4 procs) Free x64
Built by: 14393.693.amd64fre.rs1_release.161220-1747
System Uptime:9 days 1:38:12.388
Probably caused by :dxgmms2.sys ( dxgmms2!VidMmInterface+26c76 )
BugCheck 1000007E, {ffffffffc0000005, fffff801e1f50406, ffffbd80b39a0558, ffffbd80b399fd80}
BugCheck Info: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M (1000007e)
Arguments:
Arg1: ffffffffc0000005, The exception code that was not handled
Arg2: fffff801e1f50406, The address that the exception occurred at
Arg3: ffffbd80b39a0558, Exception Record Address
Arg4: ffffbd80b399fd80, Context Record Address
PROCESS_NAME:  System
BUGCHECK_STR:  AV
FAILURE_BUCKET_ID: AV_dxgmms2!VidMmInterface
  BIOS Version   IRKT54AUS
  BIOS Release Date 08/20/2015
  Manufacturer   LENOVO
  Product Name   90BG003LUS
  Baseboard Product Bantry CRB
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``


3rd Party Drivers:
The following is for information purposes only. My recommendations were given above. The drivers that follow belong to software or devices that were not developed by Microsoft.  You can find links to the driver information and where to update the drivers in the section after the code box:
**************************Tue Jan 24 18:13:26.791 2017 (UTC - 5:00)**************************
AODDriver2.sys			  Tue Feb 11 06:06:52 2014 (52FA044C)
rt640x64.sys				Tue May  5 12:21:03 2015 (5548EDEF)
usbfilter.sys			   Thu May  7 04:43:50 2015 (554B25C6)
RTKVHD64.sys				Tue Jun  2 06:47:59 2015 (556D89DF)
RtkBtfilter.sys			 Wed Jun 10 21:39:49 2015 (5578E6E5)
GeneStor.sys				Mon Oct  3 02:14:48 2016 (57F1F758)
rtwlane.sys				 Fri Nov 11 06:45:44 2016 (5825AF68)
AtihdWT6.sys				Thu Dec  8 12:20:20 2016 (58499654)
atikmpag.sys				Fri Dec 23 11:58:02 2016 (585D579A)
atikmdag.sys				Fri Dec 23 12:24:18 2016 (585D5DC2)


http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>
http://www.carrona.o.../span></strong>

Edited by usasma, 26 January 2017 - 11:45 AM.


#10 OFFLINE   DarkSerge

DarkSerge

    Thread Head

  • Members
  • PipPipPipPipPipPip
  • 665 posts

Posted 26 January 2017 - 05:15 PM

That's a lot to go through but I'll be sure to start working on that. AMD has a Clean Uninstall Utility available: http://support.amd.c...ll-Utility.aspx

I just checked and my Updates are current, nothing new available for me.

Update:

I uninstalled all the AMD software using the steps above (didn't use the utility I linked, but there was a clean uninstall option) and rebooted. I'm now running off of "Microsoft Basic Display Adapter" However when I try to manually update the driver and point it to the folder where the AMD software extracted to, it tells me I'm using the best driver and doesn't make any changes. Even if I chose the "Have Disk" option and select the .inf file manually, it lists many Radeon cards, but all I can find out about my card is "AMD Radeon R7 Series" while all the driver options are "Radeon R7 340" or 240 or "300 series" the closest I can find is "Radeon R7 Series / HD 9000"

Also, I'm having a hard time finding my computer on the Lenovo site to find an BIOS update, but I found a system update utility. It doesn't seem to detect anything BIOS related, but it does want to update the AMD chipset.

I haven't updated anything yet or made any changes other than removing the AMD graphics software and drivers and am running from the MS Basic Display Driver.

Helpful Info: https://www.newegg.c...=9SIA9JJ4UN9110 That's the system I have. The specs on this page match mine.

Another Update:

The system took it upon itself to update. Now my Device Manager shows my Display Adapter as "AMD Radeon ™ R7 Graphics" but the rest of the AMD Radeon software hasn't been installed other than a basic settings utility, which I've disabled (and everything is running just fine without it.)

Yet Another Update:

BIOS/UEFI updated. I had problems finding my system on the Lenovo site, but I managed to find an "Auto Detect" page that found everything for me. BIOS date is now 12/14/2016

I'm going to call it a night for now and continue tomorrow.

Edited by DarkSerge, 26 January 2017 - 08:18 PM.

~DarkSerge

#11 OFFLINE   usasma

usasma

    Message Adept

  • Members
  • PipPipPip
  • 88 posts

Posted 27 January 2017 - 06:45 AM

Glad to hear that things worked out.

I suspect the video card and suggest that you try the diagnostics that I listed.
Also, some Lenovo's have a Hardware Scan in the Lenovo Solution Center - try that also, as it's a bit faster.

#12 OFFLINE   DarkSerge

DarkSerge

    Thread Head

  • Members
  • PipPipPipPipPipPip
  • 665 posts

Posted 27 January 2017 - 05:28 PM

So far so good. The Lenovo software helped a lot in finding updates and I've installed the rest of the suggested updates. I will let the system run for a few days, see how things go, then probably on my next night off I'll look into hardware scanning. The Lenovo Solution Center does have the hardware scan option.  Hopefully nothing turns up, this computer isn't even a year old.

Edited by DarkSerge, 27 January 2017 - 05:38 PM.

~DarkSerge

#13 OFFLINE   usasma

usasma

    Message Adept

  • Members
  • PipPipPip
  • 88 posts

Posted 28 January 2017 - 06:35 AM

Just FYI - on my Lenovo (Y700), there is a glitch that says there's a problem with the Intel graphics
The Mathematical Operations Test will fail, but there's nothing wrong with the system.

#14 OFFLINE   DarkSerge

DarkSerge

    Thread Head

  • Members
  • PipPipPipPipPipPip
  • 665 posts

Posted 01 February 2017 - 02:06 AM

I ran the hardware scan through the Lenovo Solutions Center and everything passed. No issues.
~DarkSerge

#15 OFFLINE   usasma

usasma

    Message Adept

  • Members
  • PipPipPip
  • 88 posts

Posted 02 February 2017 - 09:27 AM

The diagnostics that I suggested are much more stressful - especially the video tests.
Please complete these diagnostics also:  http://www.carrona.org/hwdiag.html
Please finish ALL of the tests and let us know the results.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users