Jump to content


Running Virtual Box in Windows 10

virtual box win 10 host. guest

  • Please log in to reply
9 replies to this topic

#1 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,160 posts

Posted 03 July 2017 - 12:18 PM

I downloaded and installed the latest version of Virtual Box in Windows 10 as host. Tried to run a 64 bit Linux Distro as guest, it would not work. In VB all of the listed distro's and Windows are 32 bit. What gives My windows 10 and all of my Linux Distros are 64 Bit and so is my CPU. This only happens when using Windows as the host using Virtual Box. It works fine in Linux.
Mel
Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#2 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,430 posts

Posted 03 July 2017 - 09:46 PM

I've noticed this behaviour if I have Hyper-V installed. For some reason, installing Hyper-V in Windows 10 and 8/8.1 causes VirtualBox and VMware Workstation to not be able to create 64-bit VMs. 32-bit ones yes.

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#3 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,160 posts

Posted 03 July 2017 - 10:08 PM

View PostPeachy, on 03 July 2017 - 09:46 PM, said:

I've noticed this behaviour if I have Hyper-V installed. For some reason, installing Hyper-V in Windows 10 and 8/8.1 causes VirtualBox and VMware Workstation to not be able to create 64-bit VMs. 32-bit ones yes.
Thanks for the reply. Is there a fix for this problem and if so what do I need to do.
Mel
Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#4 OFFLINE   Peachy

Peachy

    Anarquista De Sartorial

  • Forum Moderators
  • 5,430 posts

Posted 03 July 2017 - 10:14 PM

First, do you actually have Hyper-V installed? If you didn't install it explicitly it will be installed if you also install the native Docker Windows client. If none of these are relevant to your situation, double-check your BIOS/UEFI settings and make sure Intel VT-x (virtualization settings) is enabled.

Another fix is to re-install VirtualBox (don't uninstall it first) and choose the Repair option.

'freedom...is actually the reason that men live together in political organisations at all. Without it, political life as such would be meaningless. The raison d'Être of politics is freedom, and its field of experience is action'.
My Flickr Photo Blog Posted Image
del.icio.us bookmarks Posted Image


#5 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,388 posts

Posted 04 July 2017 - 06:48 AM

Here is a good reference on this problem. I had it on my AMD based laptop and enabling virtualization in the BIOS fixed it for me.

https://forums.virtu...php?f=1&t=62339

Edited by raymac46, 04 July 2017 - 06:49 AM.

Posted Image

Registered Linux User 445659

#6 OFFLINE   goretsky

goretsky

    Forum Fiend

  • Forum Moderators
  • 1,924 posts

Posted 04 July 2017 - 08:22 PM

Hello,

Here's how to disable Hyper-V in Windows 10, step-by-step:
  • Open the Program and Features applet (filename APPWIZ.CPL) from the Control Panel.
  • In the left navigation pane, select Turn Windows features on or off.
  • Select the Hyper-V tree control and expand it.  Beneath it you will see two options, Hyper-V Management Tools and Hyper-V Platform.
  • Uncheck (de-select) the Hyper-V Platform option.
  • Click on OK when done to uninstall Hyper-V.
A reboot may be required when done to finish uninstalling Hyper-V.

Regards,

Aryeh Goretsky
Dexter is a good dog.

Aryeh Goretsky
Microsoft MVP (Windows - IT Pro)

Facebook Google+ personal blog personal website Twitter

#7 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,160 posts

Posted 04 July 2017 - 10:25 PM

View Postgoretsky, on 04 July 2017 - 08:22 PM, said:

Hello,

Here's how to disable Hyper-V in Windows 10, step-by-step:
  • Open the Program and Features applet (filename APPWIZ.CPL) from the Control Panel.

  • In the left navigation pane, select Turn Windows features on or off.

  • Select the Hyper-V tree control and expand it.  Beneath it you will see two options, Hyper-V Management Tools and Hyper-V Platform.

  • Uncheck (de-select) the Hyper-V Platform option.

  • Click on OK when done to uninstall Hyper-V.
A reboot may be required when done to finish uninstalling Hyper-V.

Regards,

Aryeh Goretsky
I followed your instructions. but there is no Hyper V in the Turn Windows features on or off.
Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#8 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,160 posts

Posted 04 July 2017 - 10:49 PM

There is no Hyper-v in the Bios or in Windows and I can find no VT-x to enable. It must be enabled because Virtual Box works fine in Linux. my processor is a AMD 64 bit A-8 7600 radeon. Here is more info. Under (services) there are several Microsoft Virtual Settings. No Hyper-v or tree.
Mel

Edited by mhbell, 04 July 2017 - 11:03 PM.

Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#9 OFFLINE   mhbell

mhbell

    Posting Prodigy

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,160 posts

Posted 04 July 2017 - 11:22 PM

View PostPeachy, on 03 July 2017 - 10:14 PM, said:

Another fix is to re-install VirtualBox (don't uninstall it first) and choose the Repair option.
Thanks Peachy, the above is what worked. I have it running now using 64 bit distros in windows 10.
thanks to everyone else for your advise and help.
Mel
:clap:
Registered Linux User #239772
Mint 18.1 Cinnimon, MX-16, Siduction LXQT, Debian Stretch, and Other Linux Distro's
https://pctechman.wordpress.com/

#10 OFFLINE   goretsky

goretsky

    Forum Fiend

  • Forum Moderators
  • 1,924 posts

Posted 06 July 2017 - 03:59 AM

Hello,

In that case... it sounds like the computer was missing a hardware feature required for Hyper-V.  Here are the system requirements for it:  https://docs.microso...v-requirements.

Regards,

Aryeh Goretsky
Dexter is a good dog.

Aryeh Goretsky
Microsoft MVP (Windows - IT Pro)

Facebook Google+ personal blog personal website Twitter





Also tagged with one or more of these keywords: virtual box, win 10, host. guest

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users